Solved LACP LAG group isn't working

I'm trying to configure a two port LAG group using LACP, but for an unknown reason, I cannot ever get it to connect with the switch using FreeBSD 10.2.

I have two NICs, bce0 and bce1 that I am trying to setup LACP with.

I have done the following from the command line as root.

Code:
ifconfig bce0 up
ifconfig bce1 up
ifconfig lagg0 create
ifconfig lagg0 up laggproto lacp laggport bce0 laggport bce1

When I check lagg0 using ifconfig lagg0, the flags for each lagg(4) port are always blank. They're not active, collecting, or distributing.

This is my switch configuration.

Code:
#sho run int Gi1/29
Building configuration...

Current configuration : 158 bytes
!
interface GigabitEthernet1/29
 description firewall2 bce0
 switchport trunk allowed vlan 3,9,21,90
 switchport mode trunk
 channel-group 3 mode active
end

#sho run int Gi1/30
Building configuration...

Current configuration : 158 bytes
!
interface GigabitEthernet1/30
 description firewall2 bce1
 switchport trunk allowed vlan 3,9,21,90
 switchport mode trunk
 channel-group 3 mode active
end

#sho run int Port-channel 3
Building configuration...

Current configuration : 137 bytes
!
interface Port-channel3
 description bltn-firewall-02
 switchport
 switchport trunk allowed vlan 3,9,21,90
 switchport mode trunk
end

For whatever reason, the line protocols never come up on the the port channel or the individual links. They are clearly not communicating properly.

Code:
#sho ip int Gi1/29
GigabitEthernet1/29 is up, line protocol is down
  Inbound  access list is not set
  Outgoing access list is not set

#sho ip int Gi1/30
GigabitEthernet1/30 is up, line protocol is down
  Inbound  access list is not set
  Outgoing access list is not set

#sho ip int Port-channel 3
Port-channel3 is down, line protocol is down
  Inbound  access list is not set
  Outgoing access list is not set

If I show the LACP neighbors, the switch does see the ports, but the port states are wrong.

Code:
#sho lacp neighbor
Flags:  S - Device is requesting Slow LACPDUs
        F - Device is requesting Fast LACPDUs
        A - Device is in Active mode       P - Device is in Passive mode

Channel group 3 neighbors

Partner's information:

                  LACP port                        Admin  Oper   Port    Port
Port      Flags   Priority  Dev ID          Age    key    Key    Number  State
Gi1/29    SA      32768     90b1.1c15.d031  16s    0x0    0xCB   0x3     0x45
Gi1/30    SA      32768     90b1.1c15.d031  16s    0x0    0xCB   0x4     0x45

I have a different machine running FreeNAS (FreeBSD 9.3 based) with a working port channel group. I have an identically configured machine to this one that behaves the same way, with no LACP connections.

This machine, which does not seem to connect LACP on FreeBSD, does work in a Linux LiveCD.

Thanks for any assistance.
 
My guess is the problem comes from setting the switchport configuration on your gige interfaces which isn't neccessary. This is what my config looks like and works just fine with 10.2.

Code:
interface gigabitethernet1
 channel-group 1 mode auto
!
interface gigabitethernet2
 channel-group 1 mode auto
!
interface gigabitethernet3
 channel-group 2 mode auto
!
interface gigabitethernet4
 channel-group 2 mode auto
!
interface Port-channel1
 switchport trunk native vlan 206
!
interface Port-channel2
 switchport trunk allowed vlan add 101,201,206,208-209,211-212
 switchport trunk allowed vlan add 214-216,301,303
!
 
When we remove the switchport commands from the individual interfaces, we do get it a successful connection with the switch. However, vlan tagging does not seem to work now. Not in FreeBSD or in Linux.

Code:
!
interface Port-channel3
 description bltn-firewall-02
 switchport
 switchport trunk allowed vlan 3,9,21,90

!
interface GigabitEthernet1/29
 description firewall2 bce0
 switchport trunk allowed vlan 3,9,21,90
 channel-group 3 mode active
end

!
interface GigabitEthernet1/30
 description firewall2 bce1
 switchport trunk allowed vlan 3,9,21,90
 channel-group 3 mode active
end

Simply adding the switchport trunk allowed commands to the port channel group added them to the individual links. We did not add them ourselves.
 
I got it working in a test lab with a different cisco switch. This is clearly an issue with the switch or its configuration, rather than FreeBSD. Thanks for your assistance.
 
John, on my Cisco 2960G 12.2(44)-lanbase, I use the follow config:

Code:
interface Port-channel5
description host5 LACP Trunk
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet0/23
description host5-gb1 - LACP Port Group 5
switchport mode trunk
switchport nonegotiate
channel-protocol lacp
channel-group 5 mode active
!
interface GigabitEthernet0/24
description host5-gb2 - LACP Port Group 5
switchport mode trunk
switchport nonegotiate
channel-protocol lacp
channel-group 5 mode active

The only difference I see is the channel-protocol lacp line for the interfaces. Or it could be the version of IOS running on the switch.
 
I was able to solve the problem by updating the iOS version to 15. I don't know why the old version did not work, but the new version does, and that was the only difference we could find between my test lab that worked and my production environment which did not.
 
Back
Top