keyboard and mouse does not work after x star

yoxter

Member

Reaction score: 5
Messages: 24

Hi,

I have this problem. If I start X I can't move the keyboard and the mouse. I have already added:

Code:
hald_enable="YES"
dbus_enable="YES"
to /etc/rc.conf.

I've tried with KDE 3 and Gnome 2 and I've made the xorg.conf.

I am using freeBSD FreeBSD 9.
 

wblock@

Beastie Himself
Developer

Reaction score: 3,649
Messages: 13,850

Those entries in /etc/rc.conf are only used on system startup. They won't take effect until the system is restarted. Until then, they can be started manually:
# service dbus start
# service hald start
 
OP
OP
yoxter

yoxter

Member

Reaction score: 5
Messages: 24

wblock@ said:
Those entries in /etc/rc.conf are only used on system startup. They won't take effect until the system is restarted. Until then, they can be started manually:
# service dbus start
# service hald start
Thanks a lot for help. I've reinstalled FreeBSD and installed first X, and after removing open source driver installed the official driver.
 

marcinnn

New Member

Reaction score: 1
Messages: 18

Hi,

I have very similar problem. I installed FreeBSD 9 and keyboard and mouse does not work when starting kde. I added

Code:
hald_enable="YES"
dbus_enable="YES"
but this doesn't help. I added also
Code:
Option "AutoAddDevices" "false"
but still doesn't help. When I'm trying
Code:
Option "AllowEmptyInput" "true"
it helps and both keyboard and mouse start working but they whole system is working very slow.

Can you help me with this?
 

wblock@

Beastie Himself
Developer

Reaction score: 3,649
Messages: 13,850

You'll get better results with a new thread rather than reusing one that has been solved. In that new thread, post what you have for hardware (model of CPU and video card), the version of FreeBSD, and your xorg.conf.
 

serjsk8

Active Member

Reaction score: 5
Messages: 110

@marcinnn
I have the same problem! After installing FreeBSD 9-RELEASE the mouse and keyboard did not work in X. I added a line in xorg.conf:
Code:
Option "AllowEmptyInput" "true"
Now the mouse and keyboard work, but the system is working very slow!
 

marcinnn

New Member

Reaction score: 1
Messages: 18

SirDice said:
For crying out loud, why hasn't this "solution" died a horrible death yet?

Do NOT use AllowEmptyInput!

http://www.wonkity.com/~wblock/docs/html/aei.html
Could you please give me working alternative? I tried various combinations and this one is the most working but slows down the computer. AllowEmptyInput options doesn't give solution. Adding or removing hald or dbus in rc.conf also. So what else remains?
 

jb_fvwm2

Daemon

Reaction score: 182
Messages: 1,696

serjsk8 said:
@marcinnn
I have the same problem! After installing FreeBSD 9-RELEASE the mouse and keyboard did not work in X. I added a line in xorg.conf:
Code:
Option "AllowEmptyInput" "true"
Now the mouse and keyboard work, but the system is working very slow!
If I had time, I may remove that line in my xorg.conf, but am reluctant to unbreak anything xorg until its configuration is easier. Maybe the system working slow is some other problem? sysutils/atop may be of use... (I've removed hal also...)
 

wblock@

Beastie Himself
Developer

Reaction score: 3,649
Messages: 13,850

It's one line in xorg.conf. Take it out. In the unlikely case that things get worse, put it back. Or better yet, figure out the real problem.
 

serjsk8

Active Member

Reaction score: 5
Messages: 110

As in my case, my problem is HAL.
If I do:
Code:
/usr/local/etc/rc.d/hald status
hald is not running
I am doing:
Code:
/usr/local/etc/rc.d/hald start
Shared object "libpcre.so.0" not found, required by "libdbus-glib-1.so.2"
I tried to rebuild devel/pcre, this did not lead to success.
 

serjsk8

Active Member

Reaction score: 5
Messages: 110

The first time I installed everything through the DVD and I have had the above-described problems.

Now I install packages through Internet. And HAL and Xorg works fine. Maybe it's some sort of bug in the release on DVD?
 

marcinnn

New Member

Reaction score: 1
Messages: 18

Hi,

For me it works but only with
Code:
Option "AutoAddDevices" "Off"
in the ServerLayout section, so if anyone has similar problems try different sections of xorg.conf.
 

Liam123

New Member


Messages: 1

Hi, I know I'm a bit late in the game, but I've been searching with the same problem.
I put hald_enable="YES" and dbus_enable="YES" in /etc/rc.conf, but, even after restarting, typing service dbus start showed it as running; but service hald start/cmd] always responded with [file]hald starting up[/file]. What solved it for me, was either swapping the order of the commands in [file]/etc/rc.conf[/file] -so dbus was first, then hald, or mounting the [file]proc[/file] filesystem. Not too sure, as I did both before rebooting. Mounting the [file]proc[/file] file system is only a couple of paragraphs ahead in the handbook.
 
Top