KDE Konsole won't start

  • Thread starter Deleted member 9563
  • Start date

Deleted member 9563

When starting Konsole from keyboard shortcut or from the menu, I get this error:

service 'usr/local/share/applications/kde4/konsole.desktop' is malformatted

This problem started after installing Virtualbox and persists after stopping that application. Terminals already open work fine.

Rebooting solves the issue (presumably starting the DE would too) but it came back after Virtualbox had been running for a while. I've looked at the above file, but don't know what was changed or what I should do with it. Since the date on the file is from the original OS installation, the problem probably lies elsewhere. Suggestions appreciated.
I've discovered that when restarting Virtualbox, I now get a similar message but not from KDE like the above, but from Plasma Desktop.

One thing offers a hint though. One way that I start Konsole is with a custom defined key (Crtl-Alt-T). That has worked for ages with the simple "console" command specified. I just now changed that to include the complete path and it works again. I still can't start Konsole from the menu though. It seems that the installation of Virtualbox has done something to the path, but that looks fine to me.
I've done some serious looking around, but still no fix. No answer from KDE folks yet. In fact I've discovered that the problem is much more pervasive. A number of programs won't start from the menu. They require the full path entered in the kicker. What's more, editing the individual entries in the menu editor (where this is supposed to be done) does not work. After saving, and exiting, the path is overwritten to the original setting.

PS: Had I known what was afoot here, I would have chosen a different title. :) I'm reluctant to make shortcuts for everything since it's just a coverup for the problem. However, I normally use a shortcut for opening a terminal so that particular situation is not a problem - it just points to one.
I observed this as well whenever I change/manage VirtualBox's virtual DVD drive. Previously, it manifests only whenever KDE_FORK_SLAVES is set.

My temporary solution is: a) open konsole (maybe 2 or 3 instances; alternatively, open few tabs) before firing up VBox; b) use yakuake; c) use xterm or any other terminal emulator while using VBox. Not elegant but working.

I suspect this is related to dbus and VirtualBox.

Hope it helps.
Thanks for responding. There may be some hints there. The KDE irc channel has not helped me, and a detailed post on KDE forums has garnered no responses either.

As for Konsoles, yes I always have quite a few open all the time and so they're always there. In any case my keyboard shortcut (Ctrl-Alt-t) works fine. Opening programs in the kicker (Alt-F2) with the full path is not too difficult either, but not being able to open programs with a mouse click is a bit of a shortcoming for such a fancy GUI as KDE. ;)