1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

KDE Konsole and zsh

Discussion in 'KDE' started by vdaras, Mar 9, 2012.

  1. vdaras

    vdaras New Member

    Thanks Received:

    In FreeBSD 9.0 system with KDE version 4.7.3, I changed my user's default shell using chsh to zsh and now every time I use Konsole it seems it can't spawn a zsh process at startup. If I change back to csh and run /bin/zsh (I've created a link to /usr/local/bin/zsh) Konsole works perfectly with zsh. When using chsh I tried both /bin/zsh and /usr/local/bin/zsh to no avail. Anyone experienced the same problem?
  2. xibo

    xibo Member

    Thanks Received:
    I had that problem. You can open another tab in konsole which will spawn immediately (well, lagging of cause due to the 200% cpu usage of the first tab). After about 5 minutes, the first tab will become usable too. I.e. always the first zsh session of a new konsole window will hang, for about 5 minutes on full cpu usage, with both sides spinning in select(2) iirc.

    I don't know what it's caused by, but upgrading to the new versions of kde and zsh solved it for me ;)
  3. phoenix

    phoenix Moderator Staff Member Moderator

    Thanks Received:
    Did you also update your Konsole settings to start ZSH by default instead of BASH? Works fine here, no pause at startup, no lag, no issues. Been using ZSH with Konsole since the early KDE 4.2-ish days.
  4. Persephone

    Persephone New Member

    Thanks Received:
    I was having a similar problem with KDE and zsh a couple months ago. Not sure which port upgrade(s) fixed the problem but I no longer have it with an up to date ports.