KDE and graphics card

I am new to FreeBsd
I installed it yestersday and I tryed to use X but it was the xterm with a very little font that I cant see nothing, but it works!
Today I installed the ports from CD and made the KDE 3. Now I am starting it and it says:
Failed to load module s3virge (module des not exists)
failed to load module fbdev (module des not exists)

How can I configure a default graphics card on it?


Do I need to create that file?
I am not sure what card i have :-(
But why does xterm works well (tiny fonts) and kde do not?

It sounds like in the process of installing KDE3, you may have updated parts of Xorg.

What's the output of 'pciconv -vl | grep vga' ? That will give us the vendor and device numbers of the video card, hopefully.

Look, after making KDE3 I runned the xterm and it worked. Then I created the .xinitrc for the kde and now it shows that 2 erros and doesnt starts.

That commands returns:
vgapci0@pci0:1:0:0: class 0x30000 card=0x8a135333 chip 0x8a1353333 rev=0x02 hdr=0x00


Yes, xterm (with tiny fonts) works!

Other solution: Is there any way to configure xterm with a bigger fonts?

You are using startx, in both cases, to start the X server, correct? I'm guessing that your .xinitrc file is trying to start something that does not exist :) Can you attach your /var/log/Xorg.0.log file (both when X works with the xterms, and when it fails to work with your .xinitrc) to a post here? Or use a service like http://pastebin.ca/ to post them?

There is a problem :-(
I have an internet connect on the freebsd desktop but I dont know how to access forum to send the file in command line nor using the xterm :-(
Does it detect pen drives? If I plugg one there is it mounted?

If you run 'sudo pkg_add -r pastebinit' you will install 'pastebinit'. Then you can just run 'pastebinit /var/log/Xorg.0.log' and it will pastebin the file and give you a URL back.

Great! Meanwhile I found pen of the FreeBsd.
Here is the files and how I got them:

1. I removed the X log file
2. I started xterm with success. The log file was created and here it has the name xterm.log
3. I removed the log file again
4.I created .xinitrc
5.I started kde and it shutdowns permaturely with those 2 errors. the log file here is called kde.log

Thank you

OK, a few things:

Both logs are showing the same thing. I really do think that your .xinitrc file is broken. X is starting up, trying to launch whatever is in .xinitrc, and since there is nothing executable, it's immediately stopping. What did you add to your .xinitrc file so get KDE to start?

Second, you are using the generic vesa driver. Your card should be supported by the s3virge driver, which should perform better than 'vesa'. *After* you get KDE to work, I suggest you install /usr/ports/x11-drivers/xf86-video-s3virge/ . Again, I would not try that till you get KDE working. Let's handle one problem at a time :)

Try putting in the full path to the startkde command? Probably /usr/local/bin/startkde

I'm not sure if it's necessary, but I always set my .xinitrc file to be executable with 'chmod +x ~/.xinitrc'

Using a normal user the same errors happens again... :-(

Please, how can I change the font size of the Xterm?

According to the man page for 'xterm' you can use the -font option to specify whatever font you want on the command line.

Did you try adding the full path to startkde to your .xinitrc file?

Cant find where startkde is :-(
When I run, as root, find / -iname 'startkde' it causes a segmentation fault...

Very unstable this freebsd :-(

I think you'll find that most people on these forums consider freebsd much more stable than most other operating systems :) It does, however, have a steeper learning curve than most.

Does /usr/local/bin/startkde exist? That's the location of the startkde script for KDE3.