It drops to mountroot I can not continue booting

for.ggame.playing

Member

Reaction score: 2
Messages: 83

(The Background)Several days ago I installed FreeBSD 12.1 Release amd 64 bit OS on VirtualBOX. I created virtual hard drive, mounted on the OS as a hard drive, made a backup and recovered it in real ssd external drive. It is essential hat you know there're other partition there with it's OSs installed in it. So, I installed grub set those settings (for freeBSD boot).
setparams 'freeBSD 12.0'
insmod ufs2
set root=(hd0,2)
kfreebsd /boot/loader
and system went on like I planned.


(The problem) The kernel loads as usual and I choose the first option of multiusers. Than it dropped down to mountroot demanding from me to choose root partition(or rather it droped to manual root filesystem specification).
I tried to do
ufs:/dev/ada1s1a
and some other bunch of compination out there with ada(x)s(y)a, and da(x)s(y)a
ufs:/dev/sdb2



Additionalinfo: I installed Freebsd solely on one partition. It didn't involve even swap area(although I will have to attach to it anyway, so if the problem solved please inform me how to do that too)

Wierd system response Report: When I press up arrow constantly the text "cursor" jumps up as though I am editing text.
 

T-Daemon

Daemon

Reaction score: 495
Messages: 1,039

Try: mountroot > ufs:/dev/adaXp2 ( replace X )

After you have determined the device node, and booted into multi user mode, edit /etc/fstab.

To avoid such device naming change complications in the future you can label the partitions with the following tutorial:

 
Top