LXDE Issues with logout and shutdown buttons in LXDE

dbdemon

New Member

Reaction score: 12
Messages: 17

Hello!

I've just installed LXDE (with Openbox, the default) on a Raspberry Pi 400 and am having some issues with the logout and shutdown buttons:

When I click the logout button the "logout session" menu disappears, but beyond that nothing happens.

The shutdown button does indeed shut down the computer. However, it then refuses to start again when I press the "Power On" key on the keyboard (F10)! I have to pull out the power cable and put it back in to make it start again.

Any ideas to how I can debug or fix these issues?
 

Alain De Vos

Daemon

Reaction score: 360
Messages: 1,345

Logout of X is in general not a problem.
Shutdown or reboot in your window-manager is , because you need "a higher level of power".
Isn't there a consolekit or polkit file to edit.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 11,241
Messages: 37,413

If you add your user to the operator group you can shutdown/reboot without requiring root access.
 
OP
dbdemon

dbdemon

New Member

Reaction score: 12
Messages: 17

This is usually a BIOS setting.

Pretty much every computer has a power button.
It shuts down normally with shutdown -h now. The LXDE Reboot button also works as expected. It is only when I click the LXDE Shutdown button that it shuts down so completely that it can't be started up without unplugging+replugging the power cable. The F10 key is the power button on the RPi 400. (You have to long-press it.)

If you add your user to the operator group you can shutdown/reboot without requiring root access.
I think this is only relevant for permissions to execute shutdown/reboot commands? I don't think it changes what kind of shutdown command is used? I was already a member of the wheel group, but have now also added myself to the operator group. It doesn't seem to help ...

Logout of X is in general not a problem.
Shutdown or reboot in your window-manager is , because you need "a higher level of power".
Isn't there a consolekit or polkit file to edit.
Yes, I've created a rules file at /usr/local/etc/polkit-1/rules.d/10-shutdown-reboot.rules - this is per the recommendation I got when I did pkg install lxde-meta:
JavaScript:
polkit.addRule(function (action, subject) {
  if ((action.id == "org.freedesktop.consolekit.system.restart" ||
      action.id == "org.freedesktop.consolekit.system.stop")
      && subject.isInGroup("wheel")) {
    return polkit.Result.YES;
  }
});
Without that rule I don't even see the Shutdown and Reboot buttons.
 
OP
dbdemon

dbdemon

New Member

Reaction score: 12
Messages: 17

I've managed to make the Logout button work.

I changed my ~/.xinitrc from:

Bash:
ck-launch-session dbus-launch --exit-with-session startlxde
exec startlxde
to:
Bash:
exec ck-launch-session startlxde

I have slim as my login manager, not sure if that matters.
 

Samuel Venable

Active Member

Reaction score: 97
Messages: 137

This is usually a BIOS setting.

Pretty much every computer has a power button.
I had trouble finding a power button on the Raspberry Pi 4 only to find on google you do in fact need to reconnect the power cable to turn the thing on. I couldn't believe it at first either, believe me... Can't speak for the 400, but it wouldn't surprise me if it worked the same.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 11,241
Messages: 37,413

Didn't notice it was a Raspberry, but yes, you need to unplug and plug the power back in for it to boot again. That's been the case with every Raspberry Pi.
 
Top