Issue with LAN connection

xsiick

Member


Messages: 28

Stay with me here, this might be a little difficult to explain upon:

Okay, two days ago I decided to restart fvwm because it had been up for a couple of days now. When I started fvwm, I opened up an xterm window and irssi wasn't connecting to any irc networks. I was unable to get opera connected to the internet, but my router says I'm connected to the internet.

I am able to SSH onto my mac from my bsd server, and vice versa, btu I can't get on the inernet on the server. I'm connected to the internet fine on my mac and am ssh'd into my server to access certain files.

Extra information:
I use the rum0 driver.
I think the problem is with my host[name]
Restarting my server does not work.
 

anomie

Aspiring Daemon

Reaction score: 120
Messages: 781

From the FreeBSD server:
  • Can you ping to your gateway?
  • Is your network's gateway set as your default router? % netstat -rn
  • Can you ping to IP addresses out past your gateway? (e.g. Try 69.147.114.224, which is one of Yahoo's hosts.)
  • Can you resolve names? Try: % dig yahoo.com
 
OP
OP
xsiick

xsiick

Member


Messages: 28

Code:
[xsiick@jakeserver ~]$ ping 70.146.40.25
PING 70.146.40.25 (70.146.40.25): 56 data bytes
ping: sendto: No route to host
Code:
[xsiick@jakeserver ~]$ netstat -rn
Routing tables

Internet:
Destination        Gateway            Flags    Refs      Use  Netif Expire
192.168.1.0/24     link#3             UC          0        0   rum0
192.168.1.94       00:1b:63:04:31:d0  UHLW        1      216   rum0   1048
192.168.1.97       192.168.1.97       UH          0        0    lo0
192.168.1.254      00:0f:db:7a:d3:bc  UHLW        1        8   rum0    452
Code:
[xsiick@jakeserver ~]$ ping 69.147.114.224
PING 69.147.114.224 (69.147.114.224): 56 data bytes
ping: sendto: No route to host
Code:
[xsiick@jakeserver ~]$ dig yahoo.com

; <<>> DiG 9.4.2-P2 <<>> yahoo.com
;; global options:  printcmd
;; connection timed out; no servers could be reached
 

phoenix

Administrator
Staff member
Administrator
Moderator

Reaction score: 1,260
Messages: 4,099

You don't have a default route listed. Something like route add default 192.168.1.x is needed, where x is the IP of the default gateway on your network.

Without a default route, the system doesn't know where to send packets for systems not on the local network (ie anything not on 192.168.1.0/24).
 

anomie

Aspiring Daemon

Reaction score: 120
Messages: 781

@xsiick, just add a default router, as mentioned.

# echo 'defaultrouter="192.168.1.1"' >> /etc/rc.conf

Then either restart networking or restart the box.

Once that's done, please run through the same tests (from my last post) again.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 8,021
Messages: 31,497

xsiisick do you use DHCP? If so, try using dhclient rum0 to get a new lease, this should also include a default gateway. If you still don't have a default gateway check your DHCP server configuration.
 
OP
OP
xsiick

xsiick

Member


Messages: 28

@SirDice thanks! dhclient worked for me. I guess my router doesn't like it when an IP is 192.168.1.97 lol...
 

phoenix

Administrator
Staff member
Administrator
Moderator

Reaction score: 1,260
Messages: 4,099

To make it permanent, don't forget to edit /etc/rc.conf and change any ifconfig_rum0 line to use DHCP instead of hard-coding in an IP.
 
Top