Solved 'Invalid argument' with 'mount'

My first post here..Probably very noob question (sorry :oops:)

I have a USB drive that has been initially imported and datasets created etc through the FreeNAS GUI and it contains important data. Info about the drive as below:

gpart show
=>      34  15155133  da1  GPT  (7.2G)
        34      1024    1  bios-boot  (512K)
      1058         6       - free -  (3.0K)
      1064  15154096    2  freebsd-zfs  (7.2G)
  15155160         7       - free -  (3.5K)

=>        34  3906963389  da2  GPT  (1.8T)
          34          94       - free -  (47K)
         128     4194304    1  freebsd-swap  (2.0G)
     4194432  3902768984    2  freebsd-zfs  (1.8T)
  3906963416           7       - free -  (3.5K)

=>       34  488397101  da0  GPT  (233G)
         34         94       - free -  (47K)
        128    4194304    1  freebsd-swap  (2.0G)
    4194432  484202696    2  freebsd-zfs  (231G)
  488397128          7       - free -  (3.5K)

ls /dev/da0*
 /dev/da0   /dev/da0p1   /dev/da0p2

I am trying to do the mounting/unmounting commands as part of a bigger shell script which is why I do not want to use the GUI. So first I detached the drive using the GUI, and while keeping the drive plugged in, I tried the following from the shell:

When I use mount /dev/da0p2 /wd250 I get 'Invalid argument' error.
When I use mount -t zfs /dev/da0p2 /wd250 I get 'No such file or directory' error.
When I use mount -t freebsd-zfs /dev/da0p2 /wd250 I get 'Operation not supported by device' error.

If I run fstyp /dev/da0p2 , I get 'filesystem not recognized' error?!?!

What am I missing here? :(
zfs mount worked! Thank you for answering my question :) and for also pointing out the link to know more about the FreeBSD Derivatives and where to properly ask questions about them :)