Intel ICH2

ikehack

New Member


Messages: 13

Hello all! I just installed FreeBSD 7 and Gnome on top of that. Everythings great and I love FreeBSD now, only problem is the sound isn't working. That is, it didn't detect any hardware / GStreamer plugins are bad (I fooled with that and it wasn't successful) I ran pciconf -vl and found my sound chipset in it:

Code:
pcm0@pci0:0:31:5:       class=0x040100 card=0x01151028 chip=0x24458086 rev=0x05 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82801BA/BAM (ICH2/ICH2-M) AC'97 Audio Controller'
    class      = multimedia
    subclass   = audio
I've looked on the web for a driver, fix, tutorial and things of that nature but have been unsuccessful. I was wondering if any of you know a way around this, if you do could you please share? :) Thanks in advanced.
 
OP
OP
I

ikehack

New Member


Messages: 13

Sorry for the double post, but I installed the OSS driver and during installation it detected Intel ICH2 and although the device is still listed as unknown, and the volume control icon on my Gnome taskbar has an X next to it, when I switched the plugin to OSS and tested the sound it worked.
 
OP
OP
I

ikehack

New Member


Messages: 13

Well in the pciconf output the information about my sound hardware said it is AC97, but regardless, it's working. One more thing though; I don't know if it's just me but the sound does seem a little bit low to me. None of the volume controls I've tried changed the volume level at all. Have I ran into another problem, or is it just my ears? :)
 
Top