• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Intel HD4000 Support

dohmniq

New Member

Thanks: 2
Messages: 12

#26
Hello Taka,

I am currently running 9.1-RC2 but I'm not sure that's much different.

On my laptop, intel_bufmgr.h is in /usr/local/include/libdrm/ so maybe something went wrong with the build of libdrm? Did you build & install libdrm before trying to make xf86-video-intel?

I've managed to build xf86-video-intel 2.21.2 and it works fine here.

Currently installed:

libdrm-2.4.31_1
libGL-8.0.5
libGLU-8.0.5
dri-8.0.5
dri2proto-2.6
xf86driproto-2.1.1
xf86-video-intel-2.21.2

I hope to reinstall soon so I can double-check the build instructions and get back to you.

Dom
 

Taka

New Member


Messages: 3

#27
Hello dohmniq,

This is Taka. Thank you for your reply. Yes. I did make & make reinstall for libdrm first. libdrm -> libGL -> libGLU -> dri -> video-intel

make atxf86-video-intel stops as follows.

Code:
In file included from intel.h:67,
                 from intel_batchbuffer.c:38:
/usr/local/include/intel_bufmgr.h:108: error: expected declaration specifiers or '...' before 'drm_clip_rect_t'
pkg info -l libdrm shows
Code:
/usr/local/include/libdrm/intel_bufmgr.h
and actually I have it there. However, strangely, /usr/local/include/intel_bufmgr.h is used.

I'll examine more.

Best, Taka
 

Taka

New Member


Messages: 3

#28
Hi dohmniq,

I could make xf86-video-intel successfully now! I removed the file /usr/local/include/intel_bufmgr.h. I don't know which program installed the file. Maybe, it was wrong that I installed libdrm over the old libdrm by using [cmd=]make reinstall[/cmd].

I will test the sna acceleration from now. Thanks!

Best, Taka
 

chatzki

New Member


Messages: 10

#29
It's been a third day I'm trying to build xorg-server. graphics/libGL fails with the following error:

Code:
gmake[4]: Entering directory `/usr/ports/graphics/libGL/work/Mesa-9.1.6/src/glsl/builtin_compiler'
  CXX      glsl_lexer.lo
  CXX      glsl_parser.lo
  CXX      ast_expr.lo
  CXX      ast_function.lo
In file included from ../../../src/glsl/glsl_types.h:31,
                 from ../../../src/glsl/ir.h:33,
                 from ../../../src/glsl/glsl_symbol_table.h:34,
                 from ../../../src/glsl/glsl_parser_extras.h:35,
                 from ../../../src/glsl/ast.h:30,
                 from ../../../src/glsl/ast_expr.cpp:24:
../../../src/mesa/main/mtypes.h:3420: error: 'GLDEBUGPROCARB' does not name a type
In file included from ../../../src/glsl/glsl_types.h:31,
                 from ../../../src/glsl/ir.h:33,
                 from ../../../src/glsl/glsl_symbol_table.h:34,
                 from ../../../src/glsl/ast_function.cpp:24:
../../../src/mesa/main/mtypes.h:3420: error: 'GLDEBUGPROCARB' does not name a type
In file included from ../../../src/glsl/glsl_types.h:31,
                 from ../../../src/glsl/ir.h:33,
                 from ../../../src/glsl/glsl_symbol_table.h:34,
                 from ../../../src/glsl/glsl_parser_extras.h:35,
                 from ../../../src/glsl/ast.h:30,
                 from glsl_parser.yy:29:
../../../src/mesa/main/mtypes.h:3420: error: 'GLDEBUGPROCARB' does not name a type
In file included from ../../../src/glsl/glsl_types.h:31,
                 from ../../../src/glsl/ir.h:33,
                 from ../../../src/glsl/glsl_symbol_table.h:34,
                 from ../../../src/glsl/glsl_parser_extras.h:35,
                 from ../../../src/glsl/ast.h:30,
                 from glsl_lexer.ll:27:
../../../src/mesa/main/mtypes.h:3420: error: 'GLDEBUGPROCARB' does not name a type
gmake[4]: *** [ast_expr.lo] Error 1
gmake[4]: *** Waiting for unfinished jobs....
In file included from ../../../src/mesa/main/imports.h:41,
                 from ../../../src/mesa/main/core.h:46,
                 from ../../../src/glsl/ast_function.cpp:28:
../../../src/mesa/main/errors.h:84: error: variable or field '_mesa_DebugMessageCallbackARB' declared void
../../../src/mesa/main/errors.h:84: error: 'GLDEBUGPROCARB' was not declared in this scope
../../../src/mesa/main/errors.h:85: error: expected primary-expression before 'const'
In file included from ../../../src/mesa/main/imports.h:41,
                 from ../../../src/mesa/main/context.h:52,
                 from glsl_parser.yy:32:
../../../src/mesa/main/errors.h:84: error: variable or field '_mesa_DebugMessageCallbackARB' declared void
../../../src/mesa/main/errors.h:84: error: 'GLDEBUGPROCARB' was not declared in this scope
../../../src/mesa/main/errors.h:85: error: expected primary-expression before 'const'
gmake[4]: *** [ast_function.lo] Error 1
gmake[4]: *** [glsl_parser.lo] Error 1
gmake[4]: *** [glsl_lexer.lo] Error 1
gmake[4]: Leaving directory `/usr/ports/graphics/libGL/work/Mesa-9.1.6/src/glsl/builtin_compiler'
gmake[3]: *** [all-recursive] Error 1
gmake[3]: Leaving directory `/usr/ports/graphics/libGL/work/Mesa-9.1.6/src/glsl'
gmake[2]: *** [all] Error 2
gmake[2]: Leaving directory `/usr/ports/graphics/libGL/work/Mesa-9.1.6/src/glsl'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/ports/graphics/libGL/work/Mesa-9.1.6/src'
gmake: *** [all-recursive] Error 1
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** [do-build] Error code 1
Stop in /usr/ports/graphics/libGL.
===>>> make failed for graphics/libGL
===>>> Aborting update
===>>> Killing background jobs
Terminated
===>>> You can restart from the point of failure with this command line:
       portmaster <flags> graphics/libGL
===>>> Exiting
Please, help! gcc-4.6.3, FreeBSD 9.2-RELEASE amd64.
 

chatzki

New Member


Messages: 10

#32
First, shame on me. From now on I solemnly swear blah-blah-blah. Second, where have you been at least three day ago, my wise advisor? ;)
 

zspider

Aspiring Daemon

Thanks: 111
Messages: 582

#33
drhowarddrfine said:
That's the tail wagging the dog. I don't see people saying "Maybe Microsoft will get Windows capable of dealing with XXX someday". If the vendor doesn't supply the driver then there's a ton of work FreeBSD needs to accomplish that same task.
Looking back, I think I understand where you're going with this now. I agree, FreeBSD is fine as it is now. Such luxuries are not a priority for an operating system like this and that's just fine. :) Sorry for not understanding, I see the light now.
 

chifuqi

New Member


Messages: 2

#35
Re:

dohmniq said:
There is this advice from the freebsd-x11 mailing list:

To get a more resent xorg distribution than the default in ports, please
add WITH_NEW_XORG to /etc/make.conf. That should give you support for
more recent intel graphics cards. You can also get the experimental
xorg repo using svn, see http://wiki.freebsd.org/Xorg for details. The
experimental xorg repo contains the latest xorg packages that has been
ported to FreeBSD, and should in general work, but as usual, no guarantees.
Regards!
--
Niclas Zeising
(Taken from http://lists.freebsd.org/pipermail/freebsd-x11/2012-October/012517.html)

As totally unsupported help, I can offer you the attached tar file which configures ports that work for me (also HD 4000).

Unpack tar into /usr/ports.

Don't forget to add this to your /etc/make.conf:

Code:
WITH_NEW_XORG="YES"
WITH_KMS="YES"
Rebuild order is (I think):

  1. graphics/libdrm
  2. graphics/libGL
  3. graphics/libGLU
  4. graphics/dri
  5. x11-drivers/xf86-video-intel

Doesn't seem like I needed to rebuild x11-servers/xorg-server after all?
(Still on version 1.10.6)

Included in my /etc/X11/xorg.conf I have:

Code:
Section "ServerFlags"
        Option          "DRI2"          "True"
        Option          "AIGLX"         "True"
EndSection
and in the "Device" section there is also:

Code:
        Option      "AccelMethod" "sna"
Dom
I followed by what you said, and it worked well on my computer, but I can't get console from GNOME. My /etc/X11/xorg.conf looks like this
Code:
Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"

##############################################
	Option 		"AutoAddDevices"    "true" 
#	Option		"AutoEnableDevice" "false"
##############################################

EndSection

Section "Files"
	ModulePath   "/usr/local/lib/xorg/modules"
	FontPath     "/usr/local/lib/X11/fonts/misc/"
	FontPath     "/usr/local/lib/X11/fonts/TTF/"
	FontPath     "/usr/local/lib/X11/fonts/OTF"
	FontPath     "/usr/local/lib/X11/fonts/Type1/"
	FontPath     "/usr/local/lib/X11/fonts/100dpi/"
	FontPath     "/usr/local/lib/X11/fonts/75dpi/"
	FontPath     "/usr/local/lib/X11/fonts/wqy"
EndSection

Section "Module"
	Load  "dbe"
	Load  "dri"
	Load  "dri2"
	Load  "extmod"
	Load  "record"
	Load  "glx"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/sysmouse"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
#	HorizSync    28-33
#	VertRefresh  43-72
	ModeLine     "1366x768" 69.3 1366 1398 1430 1470 768 771 776 786
	Option	     "DPMS"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "ShadowFB"           	# [<bool>]
        #Option     "DefaultRefresh"     	# [<bool>]
        #Option     "ModeSetClearScreen" 	# [<bool>]

##################################################
#	Option	    "FallbackDebug"	"True"
	Option	    "AccelMethod"     "sna"
##################################################


	Identifier  "Card0"
#	Driver      "vesa"
	Driver	    "intel"
	VendorName  "Intel Corporation"
	BoardName   "3rd Gen Core processor Graphics Controller"
	BusID       "PCI:0:2:0"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	SubSection "Display"
#		Viewport   0 0
#		Depth     24
		Depth	  16
	EndSubSection
EndSection
 
Section "ServerFlags"
	Option	"DRI2"	"True"
	Option	"AIGLX"	"True"
EndSection
Thank you!
 

tzoi516

Well-Known Member

Thanks: 12
Messages: 368

#37
wblock@ said:
As a general rule, posts more than a year old should be considered outdated.
Even though I think that's a great "general rule", I think it's hard to know when it applies since people still link to old posts.
 
Top