Intel chipset H110 (Asus H110T)

I just got this board with an Pentium G4400T (35w) to be used with pfsense/OPNsense(both build upon FreeBSD).
It has 2xlan (1xIntel and 1xRealtek), DC power, slim-ITX and CPU socket 1151 (the new 6th gen. Intel CPU). Price only 74$
Either Celeron G3900T or Pentium G4400T (42$ & 64$), they both have AES-NI!
I expected this to be a perfect firewall kit for a very good price.

BUT FreeBSD 10.3 and is TERRIBLE slow to boot from my installation USB (and so are also pfsense and OPNsense of course).
I tried ver. 11 and that solved the problem.....the booting goes lightning fast :)
But I assume it will take some time before 11 will move to stable and by that be implemented in pfsense/OPNsense.....what to do?

Booting from Debian and Win10 (USB install) is also fine...I only get this problem with the current stable version of FreeBSD :-(

Any suggestions on how to get 10.3 running.
I haven't tried to let the installation finish...maybe I should? But it will take hours :-(
I had the same problem with a FreeBSD installation on a USB stick. Using EFI boot fixed that problem for me.