Intel Centrino Advanced-N 6235 WiFi Driver

xmj

Member

Reaction score: 12
Messages: 37

It looks like you're using the old firmware (17.*) instead of the new one (18.*) -- check posts #4 and #17.
 

Uby

New Member


Messages: 1

Same problem I don't have wlan0

Hello I am really new to FreeBSD, and I am having the same problem as @Spike, I followed the instructions, I tried many times always from a fresh install of FreeBSD 9.2 but nothing I have iwn0 but WLAN doesn't come up. I really don't know what else to do, please if you have any suggestions, I already read the discussion many times but I don't think I am missing something...

Thanks in advance.
 
Last edited by a moderator:

Spike

New Member


Messages: 4

Solution? Rebuilding Kernel.
After patching files on 'iwn' directory, you have to rebuild the kernel.
Now, I'm currently browsing with my laptop and FreeBSD. :)

Thanks a lot to everyone.
 

petterk

New Member


Messages: 1

Is this merged into FreeBSD 10 yet? Or do I have to apply the patch and recompile for it to work on Fbsd FreeBSD 10?

I have a laptop which currently runs Linux and uses the intel Centrino 6235 chip.
 

schulzad

New Member


Messages: 1

petterk said:
Is this merged into FreeBSD 10 yet? Or do I have to apply the patch and recompile for it to work on Fbsd FreeBSD 10?

I have a laptop which currently runs Linux and uses the intel Centrino 6235 chip.
The firmware shows up in FreeBSD10:
Code:
root@blackbox:/usr/src/sys/contrib/dev/iwn # ls
LICENSE					iwlwifi-5000-8.83.5.1.fw.uu		iwlwifi-6000g2a-18.168.6.1.fw.uu	iwlwifi-6000g2b-6.ucode
iwlwifi-1000-39.31.5.1.fw.uu		iwlwifi-5150-8.24.2.2.fw.uu		iwlwifi-6000g2b-17.168.5.2.fw.uu	iwlwifi-6050-41.28.5.1.fw.uu
iwlwifi-2000-18.168.6.1.fw.uu		iwlwifi-6000-9.221.4.1.fw.uu		iwlwifi-6000g2b-18.168.6.1.fw.uu	iwnwifi-2030-18.168.6.1.fw.uu
iwlwifi-4965-228.61.2.24.fw.uu		iwlwifi-6000g2a-17.168.5.2.fw.uu	iwlwifi-6000g2b-18.168.6.1.fw.uu.orig
But the Makefile in /usr/src/sys/modules/iwnfw/iwn6000g2b/Makefile still points to the older version

I built the releng kernel without iwn() or iwn6000g2b. Install the kernel and loaded the modules manually and the device showed up. At this point I think all that's needed is the Makefile in iwnfw/iwn6000g2 to be updated.
 

wblock@

Beastie Himself
Developer

Reaction score: 3,649
Messages: 13,850

Code is frozen in 9-STABLE for the upcoming 9.3-RELEASE. But sometimes MFCs are forgotten, too, and filing a bug report can act as a reminder.
 

BSD--user

Member


Messages: 25

Any more tips anyone would care to add to this tutorial?
I've managed to muddle through the procedures but I seem to have only a partial solution. The interface iwn0 now shows up in ifconfig. I have the wireless network setup through wpa_supplicant. But running dhclient wlan0 reports no link....giving up or Network is down. wpa_supplicant also reports Device not configured.

1. I added:
Code:
{ 0x8086, 0x088e, "Intel Centrino Advanced-N 6235"              },
{ 0x8086, 0x088f, "Intel Centrino Advanced-N 6235"              },
to /usr/src/sys/dev/iwn/if_iwn.c

2. Altered /usr/src/sys/modules/iwnfw/iwn6000g2b/Makefile to read:
Code:
KMOD=   iwn6000g2bfw
IMG=    iwlwifi-6000g2b-18.168.6.1
3. Copied iwlwifi-6000g2b-6.ucode > /usr/src/sys/contrib/dev/iwn/iwlwifi-6000g2b-18.168.6.1.fw

4. Recompiled the kernel:
cd /usr/src
make buildkernel
make installkernel

5. Merged these firmware files in /usr/src/sys/contrib/dev/iwn/:
b64encode -o iwlwifi-6000g2b-18.168.6.1.fw.uu iwlwifi-6000g2b-6.ucode iwlwifi-6000g2b-18.168.6.1.fw.uu

6. Reboot


EDIT
It is working on FreeBSD-10-STABLE-r268038 (subject patching and recompiling if_iwn.c) and it is also working out of the box on FreeBSD-11-CURRENT-r267801.

This wireless adaptor supports dual 2.4GHz and 5GHz bands.
But the only caveat (seeing I was having problems earlier on) is that only the 2.4GHz works and not the 5GHz one.
Still need more firmware to use this adaptor properly!
 

BSD--user

Member


Messages: 25

Firmware is fine. There is a glitch somewhere, 5G doesn't work or is very unstable at best (barely connects).
 

balanga

Son of Beastie

Reaction score: 149
Messages: 3,146

I have just come across this thread and guess much of the discussion will also apply to the Intel Centrino Ultimate-N 6300, which, AFAICT is already supported in FreeBSD 10.0-STABLE which I am running. Having read through this thread I am a bit lost about what I need to do to get WiFi working. On boot up the WiFi adapter is recognised. It appears in dmesg. But when I run ifconfig iwn0 it shows the status as 'no carrier'.

In rc.conf, I have
Code:
ifconfig_iwn0="dhcp ssid xxx"
What else do I need?

One thing I couldn't figure out was where wlan0 comes into play. Could someone explain?
 

BSD--user

Member


Messages: 25

The interface wlan0 only comes into play when you make the reference in rc.conf. It's just a link to iwn0.

'no carrier' doesn't matter. Connect first and then, as is common with wifi access, you need to get a DHCP lease to connect to the outside www.

There are a number of good sources online to set up wifi under BSD.

I've gone back to Debian, so forgive me if I'm rusty again.
 

kpa

Beastie's Twin

Reaction score: 1,810
Messages: 6,318

The wlan0 is a cloned network interface created with ifconfig wlan0 create wlandev iwn0 from the real interface that corresponds to the detected hardware, in this case iwn0. The reason why the cloning is used and not the iwn0 interface directly is to support cards that support creation of multiple virtual WLANs with different SSIDs and operating modes. Using just the detected interface wouldn't work because one interface can have only one set of certain settings. The cloning procedure is explained in the handbook (section Infrastructure Mode->FreeBSD Clients->How to Find Access Points):

https://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/network-wireless.html
 

segfault

Active Member

Reaction score: 30
Messages: 135

Just tried installing using the snapshot named FreeBSD-11.0-CURRENT-amd64-20140918-r271779 on my zenbook UX31A and the wireless (Centrino 6235) is never detected, nor is it UEFI bootable out of the box. Is anyone else experiencing this?
 

adrian@

Member
Developer

Reaction score: 15
Messages: 33

Hi!

(Wow this is an old thread.)

FreeBSD -HEAD has updated support, including the 6235 support.

-a
 

Chris2000SP

New Member


Messages: 8

Hello,
i'm new to FreeBSD and have installed 11.0 Release.

I have read all here, and have try to compile kernel with here posted tips. Nothing worked.

Here my dmesg:
# dmesg | grep 'iwn0'
Code:
iwn0: <Intel Centrino Advanced 6235> mem 0xf2400000-0xf2401fff irq 17 at device 0.0 on pci3
iwn0: adapter type id : 0x088f sub id :0x5260 rev 11 not supported (subdevice)
iwn0: could not attach device, error 45
device_attach: iwn0 attach returned 45
I wonder about 'subdevice' meaning the Bluetooth part i think.

# grep -i '6235' /usr/src/sys/dev/iwn/if_iwn.c
Code:
    { 0x8086, IWN_DID_6035_1, "Intel Centrino Advanced 6235"       },
   { 0x8086, IWN_DID_6035_2, "Intel Centrino Advanced 6235"       },
   { 0x8086, 0x088f, "Intel Centrino Advanced-N 6235"           },
               sc->limits = &iwn6235_sensitivity_limits;
               sc->base_params = &iwn_6235_base_params;
I am a newbie, not only on FreeBSD but also to UNIX OS's for all.
I have some experience with Ubuntu and Arch Linux.
I hope that's clear now.

I found a couple days ago somthing on mailing list but i didn't found the link any more. Maybe ill find it later by searching in my Browser history.

So finaly i couldn't get a device in ifconfig.

Please help.
C.

EDIT:
Fix grep copy paste issue

EDIT:
I realize that FreeBSDs hardware support is not as high like Linux (For Desktop). I think that i simply wait for support and use Linux.
 
Last edited:
Top