Solved Installation Question about mountroot

Why am I falling into mountroot having to specify ufs:ufsid/myidhere
I did install from usb to usb with:
I am not yet skille to paste the dmesg.boot but it says
Code:
trying to mount root from ufs:/dev/da1p2 rw
mountroot: waiting ..
mounting from ufs:/dev/da1p2 failed with error 19.

I did partition it with gpt wizard having boot ufs and swap. Falling back to mountroot I issue
ufs:ufsid/myid which is the only ufsid listed in all the diskid gptid output from ?. Doing so I can finally log in.
How to get around this error in the first place.

https://forums.freebsd.org/threads/56568/#post-322114
 

Attachments

  • Scanned_20160619-1530.pdf
    314.7 KB · Views: 217
Add this to your /boot/loader.conf and see if it fixes the problem:

Code:
kern.cam.boot_delay="10000"

USB devices are sometimes slow to initialize and the kernel "jumps the gun" when it tries to mount the root system, that loader.conf(5) setting helps in most of the cases.
 
Does not help, but it got solved as I tried to mount another USB stick. I played around with:
Code:
# dmesg | grep da1      % display the system message buffer
# camcontrol devlist    % nice and structured
# sysctl kern.geom.disk
# sysctl kern.disks
and found out the /etc/fstab did use the wrong device, which was the device showing up during the ugen1.4 message in the system console. Also when mounting the USB stick it told me it was already mounted on root. So switching from da1p* to da0p* solved the problem in the fstab file.
  • Still I am wondering why there are only two entries da0p2 and da0p3 as swap and ufs, but no da0p1.
  • Also there is now slice showing up like da0s1p1, probably due to the fact there is only one slice on the USB stick right?
(also how to mark this thread as solved?)
 
The first partition on a GPT disk is usually used for bootcode. It is small and has nothing useful during runtime, so there is no entry for it in /etc/fstab.
 
The partition holding the bootcode has no filesystem either because it's written to disk as raw data, there is no way to mount it.
 
Back
Top