Solved i3 Installation

Is there a good resource on installing x11-wm/i3 on FreeBSD? I have used it and love it on Linux, but this is my first time using FreeBSD, and I cannot figure it out. I used pkg install i3 then added a line to .xinitrc - exec /usr/local/bin/i3

When I started it I got an error within i3. So I searched and then installed x11/i3status. Now when I run startx I just get a complete black screen. Any help would be greatly appreciated. Thanks!
I'm not familiar with i3, but generally, you can look in /var/log/Xorg.0.log for errors which might give a clue. Or if you type startx and it goes back to the console screen, is there any useful information there? Putting the error message that you saw might help.

Other guesses, if you've mixed ports and packages, there might be some library or shared object missing, or having its name changed. If you have used ports on the machine, you might try installing it through the port and seeing if that helps, but the first is to post the error messages you saw within i3.
I am not saying there is not anything wrong, but had you installed dmenu, etc.? Otherwise you really will have just a black screen, but you should be able to start a terminal with meta+return/enter.

You need to use, i.e. sysutils/nitrogen or something to setup wallpaper, x11-wm/compton for composite/transparency, etc.

However when you start i3 for the first time it run a script to configure the meta button. Was that script worked?

I hope you stored your old config you used on Linux!
sidetone as far I know i3 do not have wallpaper ability, it is quite more simple than Fluxbox on this meaning. Even the bar, i3status, is a separated package.
No offense to anyone here, but we need more information from the OP before we start making suggestions. I was an i3 user when I switched from Linux, and all I did was copy over my $HOME directory. After just installing the package everything worked fine.

Without knowing whether jjuel is using a new or old configuration, how i3 is being started, what is meant by "blank screen" or what the error message mentioned in the OP said, any suggestion is just a dart thrown over the shoulder while blindfolded.
Apparently I was just confused. I am used to the i3bar showing up by default, and even dmenu being installed by default. Still need to figure out how to get the i3bar to show up, but hopefully that won't be a problem.

Just need to use mod+enter to get a screen to come up. Quite a bit more configuration is necessary. Thank you everyone for your help, and hopefully next time I can be more helpful with what the specific problem is.
If you feel it's solved, you can mark it as such. You edit the thread title and there's an option for solved. Glad you've gotten it working.