I Can´t load. Have problem with XINIT

juancarlos

New Member


Messages: 10

I Can´t load. Have problem with XINIT

Helo, i am new in this, and i need some help.
I want to install XFCE4 in my oldo pc and i have a problem.
(first: i follow this post link)

When I make all that, and resumption the machine. It does not begin to run xfce4 (or rather XDM) Segui so all the steps what and nothing happen.
Formatie and installs everything of clean 2 times but it follows to me without initiating.
But then, session places in one standard (not the one of root) the command:

Code:
startxfce4
and it leaves the following error to me.

Code:
/usr/local/bin/startxfce4: starting x server
Exec: xinit not found
Segui which also says handbook (Link) and as much places following as Usuary the Normal thing (in group wheel) like in Root user

Code:
echo "/usr/X11R6/bin/startxfce4" > ~/.xinitrc
and it does not work either.

They can say step by step to me that I must do? or that I am failing?
It is that he is new this for my and I do not understand much. From already thank you very much.
Greetings from Uruguay!



P.S.: Him escribi to the author of post where it removes the information of this same forum but also is new in this and it does not know to explain to me. I am thankful for any aid.
 
OP
J

juancarlos

New Member


Messages: 10

I do not work either installing “xinit”.
But at least, now it gives another different error me and it says:

Code:
xinit: No such file or directory (errno 2): No server "X" in path
use the -- option, or make sure that /usr/local/bin is in your path and that "X" is a program or a link to the right type of server for your display. possible server name include:
xorg    common x server for most display
xvfb    virtual frame buffer
xfake   kdriver-based virtual frame buffer
xnest   xserver nested in a windows on another x server
xephyr  kdriver-base nestex Xserver


giving up.
xinit: No such file or directory (errno 2): Unable to connect to xserver
xinit: No such process (errno 3): server error
P.S.: i logme in a normal account and i do this:
Code:
vi .xsession
and I had to return to write

Code:
echo "#!/bin/sh" > ~/.sexxion
echo "/usr/local/bin/startxfce4" >> ~/.xsession
chmod +x > ~/.xsession
because with the installation, erase the content of the file .xsession
 
OP
J

juancarlos

New Member


Messages: 10

if, thus he is jaja never it installs Xorg.
Esque when probe installing Gnome2 of ports, I put gnome_enable= " YES " in rc, conf and only start of one.
When it installs xfce4 (because much was labeled to me gnome) pense that installed also it when it installed sfce4 from ports.
Now I am going to install xord. (I imagine that sera pkg_add - r xorg) asique I am going away to install it and I come to cualqueir small thing to warn as it were to me.
Very many grancias good gentleman
 
OP
J

juancarlos

New Member


Messages: 10

thousands of thanks!
To worked perfectly… but it seems that I have a magnet for the errors.
Because now it loads xorg and xdm, but I put name and password of a normal account or root and disappears everything, the black screen is put, and returns to appear the screen of beginning from session.
I have qualified hald_enable and also dbus_enable in the file rc.conf.
Some idea because to me it can continue passing bad luck?

but anyway very many thanks already for the great aid that you do dice to me.
 

rokpa92

Active Member

Reaction score: 8
Messages: 131

juancarlos said:
thousands of thanks!
now it loads xorg and xdm, but I put name and password of a normal account or root and disappears everything, the black screen is put, and returns to appear the screen of beginning from session.
the truth that not, solves yo9 it putting
hald_enable= " YES "
dbus_enable= " YES "
in the file rc.conf

The truth that not because I do not work to you beam I throw if it of a clean installation.
It remembers that I have the same or less knowledge than you, and does not have idea like ayudarte.
I hope that somebody can help it.
 
OP
J

juancarlos

New Member


Messages: 10

i enter in rood modo and put this

Code:
/usr/local/etc/cr.d/dbus start
/usr/local/etc/cr.d/hald start
But...
When i put the first say this:

Code:
/usr/local/etc/cr.d/dbus start
dbus is already run? (pid=730)
and when put the second say me:
Code:
/usr/local/etc/cr.d/hald start
starting hald.
and nothing more.
i can´t login with my account in the xdm login interface because re-start the login screen
 

Beastie

Daemon

Reaction score: 532
Messages: 2,272

juancarlos said:
and nothing more.
What were you expecting?


juancarlos said:
i can´t login with my account in the xdm login interface because re-start the login screen
Do you have a valid ~/.xsession file?

Is it executable?

Have you enabled XDM in /etc/ttys?

Can you clarify what you mean by "because re-start the login screen"?
 

rokpa92

Active Member

Reaction score: 8
Messages: 131

Dear beastie:

I do this steps in a virtual machine Link and have the same problem than "JuanCarlos"


1) Start the computer
2) log on as "root"
i write:
Code:
pkg_add -r xfce4
them
Code:
pkg_add -r xdm
and
Code:
pkg_add -r xorg
3)finish the install.
Code:
cd .. (go to the root of directory)
cd etc
vi ttys
4)i change this
Code:
ttyv8   "/usr/local/bin/xdm -nodaemon"  xterm   off secure
for this
Code:
ttyv8   "/usr/local/bin/xdm -nodaemon"  xterm   on secure
5) i put "exit" and go to a regular account
6) i write:
Code:
vi .xsession
and put this

Code:
echo "#!/bin/sh" > ~/.xsession
echo "/usr/local/bin/startxfce4" >> ~/.xsession
chmod +x ~/.xsession
7) them i put "exit" and enter again as root mode
i put
Code:
cd ..
cd ..
cd ..
cd etc
vi rc.conf
and put:
Code:
hald_enable="YES"
dbus_enable="YES"
8) and restart de pc:
Code:
reboot
I start the pc, load the login screen (picture) i put my regular account, my password, the screen turn black (less than a second) and apear againt the login screen. If i login againt, it returns to happen the same

Why it passes this to us?
Is the same problem
 

Attachments

OP
J

juancarlos

New Member


Messages: 10

If exactly that!
Him escibi to Rokpa92 so that it helps to describe me what it happens to me and he is that exactly!
The same steps the same error.
That it can be?
 

Beastie

Daemon

Reaction score: 532
Messages: 2,272

Then the problem has nothing to do with XDM. Xorg itself is simply not working.

1. Login as root and create a new xorg.conf.new: # Xorg -configure
2. Test xorg.conf.new: # X -config xorg.conf.new

What happens when you do the last operation?
 
OP
J

juancarlos

New Member


Messages: 10

Dear Beatie:

when i put:
Xorg -configure

say me:

Code:
Fatal server error:
Server is already active for display 0
       if this server is no longer running, remove /tmp/.x0-lock
       and start again.


Please consult the The X.Org Foundation support
       at http://wiki.x.org
for help

and when i put:
X -conf xorg.conf.new

say me:
Code:
[Much information that I cannot see because it passes express the letters and not that they say]
-pointer name		specify the core pointer inputDevice name
-nosilk			disable silken mouse
-flipPixels		swap default black/white Pixel values
-disableVidMode		disable mode adjustments with xdivtune
-allowNonLocalXvidtune	allos xvidtune to be run as a non-local client
-alloMouseOpenFail	start server even if the moyse can´t be initialized
-ignoreABI		make module ecen if the mouse can´t be initialized
-isolateDevice bus_id	restrict device resets to bus_id (PCI only)
-version		show the server version
-showDefaultModulePath	show the server default module path
-showDefaultLibPath	show the server default library path
vtXX			use the specified VT number (1-12)
-sharevts		share VTs with anoter X server
-keeptty		don´t detach controlling tty (for debugging only)


Fatal server error:
Unrecognized option -conf



Please consult the The X.Org Foundation support
       at http://wiki.x.org
for help

That I can make Sir?
 

Beastie

Daemon

Reaction score: 532
Messages: 2,272

juancarlos said:
when i put:
Xorg -configure

say me:

Code:
Fatal server error:
Server is already active for display 0
       if this server is no longer running, remove /tmp/.x0-lock
       and start again.
[...]
The "Server is already active" error means you are *already* running X. Shut it down.

/tmp/.x0-lock is usually created when you are already running X or the last time you used it it crashed. Just do as it says and remove the file.


juancarlos said:
and when i put:
X -conf xorg.conf.new

say me:
Code:
[Much information that I cannot see because it passes express the letters and not that they say]

[...]

Fatal server error:
[b][u]Unrecognized option -conf[/u][/b]
Read my last post again. Carefully.

Also, I should've made this clear: the first command must be successful before you try the second one.
 
OP
J

juancarlos

New Member


Messages: 10

I did what you said Sir to me, but follows without initiating.
The only thing that now it changes, does not say to me just like before when I key: X - cofig xorg.conf.new
now it says to me:

Code:
Fatal server error:
Server is already active for display 0
       if this server is no longer running, remove /tmp/.x0-lock
       and start again.


Please consult the The X.Org Foundation support
       at http://wiki.x.org
for help

I clarify that it installs in “minimal” format asique by the doubts, formatie I have installs in format “user+x” by the doubts, and it leaves to me in same error, so what.


P.S.:
/tmp/.x0-lock tries eliminating the file and executing startxfce4 and again it passes the same. I login, but returns to request that logme againt.
Also it tries eliminating that file, and reinitiating the PC, but it initiates and it happens the same.
 

Beastie

Daemon

Reaction score: 532
Messages: 2,272

Okay, since I have no clear idea what is running on your computer and how it is running...

If you have XDM enabled in /etc/ttys, disable it (ttyv8 ... off ...), then run # kill -HUP 1.

Press alt+F9.
If the screen is completely black with no keyboard cursor and you can't type anything, then press ctrl+alt+backspace.

Press alt+F1.
If there's no keyboard cursor, press ctrl+c.
If you can type, remove /tmp/.x0-lock if it still exists and retry the 2 operations from my last post.
If they fail again, reboot and retry the 2 operations (always make sure /tmp/.x0-lock does not exist before trying).

Also, does % whereis xinit return xinit: /usr/local/bin/xinit ... or xinit:?
 
OP
J

juancarlos

New Member


Messages: 10

No, nothing of that I work.
Everything follows equal.

the only form to start xfce4 is put OFF in ttys and reboot, i start the pc, login with my account (without graphic mode) them i put startxfce4 and start Xfce4.
with some error. say me:
Code:
Could not look up inernet addres for juanBSD.
This will prevent xfce from operatin correctly.
if may be posibile to correct the problem by adding JuanBSD to the file /etc/hosts on your system
but i have internet correctly. without problems.



Beastie said:
Also, does % whereis xinit return xinit: /usr/local/bin/xinit ... or xinit:?
say me: Not found.


P.S.:
an important data (nose if it is important or not) but that it forgets to say to me: I am utilziando version AMD64(FreeBSD 8.0 Beta).
Perhaps for that reason?
 

Beastie

Daemon

Reaction score: 532
Messages: 2,272

juancarlos said:
No, nothing of that I work.
On the contrary. It's all much clearer now. You're telling me both Xorg and Xfce are working fine. At least we know what works, now we can fix what doesn't.

You never replied to my questions:
* Do you have a valid ~/.xsession file?
* Is it executable?
Post the ~/.xsession file and the output of % ll ~/.xsession.


juancarlos said:
with some error. say me:
Code:
Could not look up inernet addres for juanBSD.
This will prevent xfce from operatin correctly.
if may be posibile to correct the problem by adding JuanBSD to the file /etc/hosts on your system
but i have internet correctly. without problems.
This has nothing to do with Xorg. You're probably missing a definition for your host that Xfce needs. Post your /etc/hosts file.
 
OP
J

juancarlos

New Member


Messages: 10

Dear Beastie.
Thanks for all. Here is the information your ask me:

Beastie said:
You never replied to my questions:
* Do you have a valid ~/.xsession file?
* Is it executable?
is the step (6) of my question? It is:
Code:
echo "#!/bin/sh" > ~/.xsession
echo "/usr/local/bin/startxfce4" >> ~/.xsession
chmod +x > ~/.xsession


Beastie said:
Post the ~/.xsession file and the output of % ll ~/.xsession.
dont apear nothing when i put ll ~/.xsession


Beastie said:
Post your /etc/hosts file.
Code:
# $FreeBSD: src/etc/hosts,v 1.16.32.1 2009/04/15 03:14:26 kensmith Exp $
#
# Host Database
#
# This file should contain the addresses and aliases for local hosts that
# share this file.  Replace 'my.domain' below with the domainname of your
# machine.
#
# In the presence of the domain name service or NIS, this file may
# not be consulted at all; see /etc/nsswitch.conf for the resolution order.
#
#
::1                     localhost localhost.my.domain
127.0.0.1               localhost localhost.my.domain
#
# Imaginary network.
#10.0.0.2               myname.my.domain myname
#10.0.0.3               myfriend.my.domain myfriend
#
# According to RFC 1918, you can use the following IP networks for
# private nets which will never be connected to the Internet:
#
#       10.0.0.0        -   10.255.255.255
#       172.16.0.0      -   172.31.255.255
#       192.168.0.0     -   192.168.255.255
#
# In case you want to be able to connect to the Internet, you need
# real official assigned numbers.  Do not try to invent your own network
# numbers but instead get one from your network provider (if any) or
# from your regional registry (ARIN, APNIC, LACNIC, RIPE NCC, or AfriNIC.)
#
 

Beastie

Daemon

Reaction score: 532
Messages: 2,272

juancarlos said:
is the step (6) of my question? It is:
Code:
echo "#!/bin/sh" > ~/.xsession
echo "/usr/local/bin/startxfce4" >> ~/.xsession
chmod +x > ~/.xsession
No wonder it's failing.
The first line should give you an "Event not found" error since the "!" is a special character (in the C shell), so you must escape it for the first line to work. And in the last line, you are overwriting ~/.xsession through piping with chmod +x's stdout (which is absolutely nothing).
You should understand commands before copy/pasting them and applying them to your system or you could do a lot of harm with root privileges.
Try the following:
% echo "#\!/bin/sh" > ~/.xsession
% echo "/usr/local/bin/startxfce4" >> ~/.xsession
% chmod +x ~/.xsession


juancarlos said:
dont apear nothing when i put ll ~/.xsession
... which means you don't have any ~/.xsession file, which explains why XDM never worked.
If you don't already know this, the tilde (~) replaces your home directory and the dot (.) means .xsession is hidden from normal directory listing.
After executing the above commands, pratice UNIX commands: try % cd ~ and % ls -a. .xsession should be listed. Then try % cat .xsession. This will display its contents.


juancarlos said:
Code:
::1                     localhost localhost.my.domain
127.0.0.1               localhost localhost.my.domain
Comment these lines out (put a # before them). At the end of the file, add 127.0.0.1 XYZ XYZ.local localhost and replace XYZ with your computer's hostname. I guess you haven't defined one, so edit /etc/rc.conf and add hostname="XYZ", again replacing XYZ with the appropriate value.

Now log out of Xfce, enable XDM in /etc/ttys again and execute # kill -HUP 1.
 
Top