1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HP LaserJet P1102

Discussion in 'Peripheral Hardware' started by bahman, Jan 26, 2011.

  1. bahman

    bahman New Member

    Thanks Received:
    I have a HP LaserJet P1102. I am trying to get it to work on FreeBSD 8.1 (either 64-bit or 32-bit archs) but I have not been successful at all. I have installed HPLIP 3.10.9 from the ports collection but there are two problems:
    1.Once I open HP Device Manager from Applications>Accessories in GNOME, it is closed automatically just the moment it is opened. I do not know why. I have installed FreeBSD and HPLIP many times (both x86 and x86_64 archs) but the problem seems to be a bug.
    2.HP P1102 has been supported by HPLIP since 3.10.9 but when I connect the printer and turn it on it is recognized on the USB bus (checked with usbconfig) but /dev/ulpt0 does not appear. Besides, none of HP tools (tried them all from command-line) recognizes the printer.
    What do you think I should do to make it work?
  2. plamaiziere

    plamaiziere New Member

    Thanks Received:
    You don't need ulpt, HPLIP uses directly the printer (via libusb).
    To print, hplib is called by cups and cups runs on the user account "cups", so the ugen entries should be readable and writable by this user.

    If you want to use the hp tools (hp-setup, ...), the user must have read/write permissions on these devices nodes too (I use a hplip group for this):

    For my printer I have these permissions:
    crw-rw----  1 cups  hplip       0, 108 28 oct 03:24 /dev/usb/2.2.0
    crw-rw----  1 cups  hplip       0, 112 28 oct 03:24 /dev/usb/2.2.1
    crw-rw----  1 cups  hplip       0, 113 28 oct 03:24 /dev/usb/2.2.2
    crw-rw----  1 cups  hplip       0, 114 28 oct 03:24 /dev/usb/2.2.4
    crw-rw----  1 cups  hplip       0, 115 28 oct 03:24 /dev/usb/2.2.5
    crw-rw----  1 cups  hplip       0, 116 28 oct 03:24 /dev/usb/2.2.6
    crw-rw----  1 cups  hplip       0, 117 28 oct 03:24 /dev/usb/2.2.7
    crw-rw----  1 cups  hplip       0, 118 28 oct 03:24 /dev/usb/2.2.8
    crw-rw----  1 cups  hplip       0, 131 28 oct 03:24 /dev/usb/2.2.9

  3. bahman

    bahman New Member

    Thanks Received:
    Very Important Note on HP LaserJet P1102 (WORKAROUND)

    Hello FreeBSD fans all over the world,

    Just a quarter ago I figured out the solution to one of my problems. As the solution can be useful to many people I think I better post it here. I do not want other FreeBSD fans to suffer this pain.

    The printer HP LaserJet P1102 has a virtual CD-ROM (a fake USB CD drive). I mean when you connect it to your PC, it shows up as a USB CD drive not an actual printer. The fake CD-ROM contains Windows drivers for the printer. Because of this, the printer will not actually be recognized AS A PRINTER but will be recognized as a USB CD-DRIVE. That's why /dev/ulpt0 will not show up, that's why HPLIP doesn't recognize it.

    If you wish to use your HP LaserJet P1102 on FreeBSD, you should take this workaround:
    1-Connect the printer to a Windows PC (unfortunately you have to use Windows, that's too bad) and turn it on. The fake CD-ROM appears on Windows.
    2-Insert the original Driver CD that ships with the printer (I mean the actual physical Driver CD-ROM not this fake one).
    3-Run SIUtility.exe or SIUtility64.exe from the UTIL folder and COMPLETELY DISABLE THIS "HP SMART INSTALL" FEATURE.
    4-Get back to FreeBSD. Printer is recognized and /dev/ulpt0 shows up.

    I have not been able to actually print anything on FreeBSD so far but I will keep on trying and post it here when I find a good solution!!!

    Good Luck
    Bahman Kahinpour
  4. bahman

    bahman New Member

    Thanks Received:
    Instructions on Installing HP LaserJet P1102 on FreeBSD 8 (SOLVED)

    After going through a hard time on installing HP LaserJet P1102 on FreeBSD 8.1, I decided to write this.

    *** Installing HP LaserJet P1102 on FreeBSD 8.1 ***

    Note: HPLIP 3.10.9 doesn't work for this printer.

    ** PART ONE: Disable the fake CD-ROM feature **

    The printer has a built-in fake CD-ROM feature which prevents it from working correctly on non-Windows PCs. Once it is connected to a Windows PC, a CD-ROM appears containing Windows drivers. In order for HP LaserJet P1102 to work correctly on a FreeBSD PC, you must disable this feature.

    1. Connect the printer to a Windows PC. (Unfortunately you have to connect it to a Windows PC which is too bad.)
    2. Insert the original driver CD. (The physical CD-ROM that ships with the product, NOT THIS FAKE CD-ROM).
    3. Run SIUtility.exe or SIUtility64.exe from UTIL folder to disable this fake CD feature. (It's called “HP Smart Install”)

    Now, life becomes easier. Connect your HP LaserJet P1102 to your FreeBSD PC. Printer should be recognized and /dev/ulpt0 appears.


    1. Update your Ports Collection tree.
    2. Install Common Unix Printing System (CUPS).

    # cd /usr/ports/print/cups
    # make install clean

    3. Add
    to /etc/rc.conf

    # ee /etc/rc.conf

    4. Start CUPS now. (You do not need to restart your FreeBSD)

    # /usr/local/etc/rc.d/cupsd start

    5. Install Foomatic Filters.

    # cd /usr/ports/print/foomatic-filters
    # make install clean

    ** PART THREE: Install FOO2ZJS from FOO2ZJS.RKKDA.COM **

    foo2zjs in the Ports Collection is a little old and it does not work with HP LaserJet P1102. (Checked Jan 29,2011) Go to foo2zjs.rkkda.com
    and download http://foo2zjs.rkkda.com/foo2zjs.tar.gz.

    # cd ~
    # wget http://foo2zjs.rkkda.com/foo2zjs.tar.gz
    # gzip -dc foo2zjs.tar.gz | tar -xvf -
    # cd foo2zjs
    # gmake
    # gmake install
    # gmake install-hotplug
    # ./freebsd-install

    Please note that you do not need any firmware download for this printer. (Any of these ./getweb stuff) Now restart the CUPS.

    # gmake cups

    Now, make sure that your printer is recognized on your FreeBSD system. Check dmesg and verify that printer is recognized. Make sure that
    /dev/ulpt0 exists.

    Plug out your printer and plug it in again. (In order for the permission in the devfs to be correct. They should be writable for the
    printer nodes in the /dev)

    Now, open your browser and goto http://localhost:631. Click on the Administration and Add Printer. Your printer should be recognized and also there is a special filter (driver) for that in the next pages.

    Use /dev/ulpt0 as the URI.

    Good Luck
    Bahman Kahinpour
  5. meyh

    meyh New Member

    Thanks Received:
    The model number HP Laserjet P1102 does not seem to be correct.

    Method 1:
    You may refer to the below links and use the troubleshooters. Check if it lists and helps resolve any issues: Open the Printer troubleshooter:

    Method 2:
    You may check if you have the latest drivers installed for the device. You may refer to the below link for getting the latest drivers and check.
    HP Laserjet P1102 Driver

    Good Luck.