• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

HP EliteBook 2540p installation problem

chiqui

New Member

Thanks: 1
Messages: 17

#26
Hello everybody, I successfully installed FreeBSD and boot up cleanly after installation. The only thing that I have done is to change AHCI to IDE in the BIOS. I dont know why honestly, but it worked. Thanks Juha.

However at this point I have a few problems:

1) The computer shows my battery status correctly just after restarting which means that during the normal run if the power cable is plugged it just shows it is plugged and the latest battery level. If I unplug it it doesnt show that I have unplugged the cable and even if I use the computer an hour it still show the same power level until I restart the computer and then it shows the correct level. But then it doesnt show again either plugging the cable or battery status in real time until I restart again. So basically it doesnt respond real time.

2) The second problem is that before starting the X (KDE, XFCE etc) the screen show this message below:
Code:
iwn0: null_update_chw: need callback
Any idea what this is and how to get rid of this message?

3) When I start my KDE or I tried for XFCE as well, I cant see the wireless manager (or network manager) on my task bar. I am guessing it doesnt come up as default setting with the KDE or any other X interface. But the question is that is there any way to put that network or wireless manager on my task bar so I can see all the wirelesses networks on around me?

4) The last question is how to start a wireless manually? I looked at the handbook but I couldnt find a command to start the wireless manually. I am looking for a command such as
"command password wireless_name connect "
Is there any command like that?

I am sorry for long questions but these are the urgent questions and deadly important to me at this moment. And please answer the questions respectively.

Kind regards,

PC,
 

Juha Nurmela

Well-Known Member

Thanks: 121
Messages: 401

#27
Battery status is stuck in Probook 6550b too. I guess this model is not supported by the acpi_hp(4) module.

Maybe your's is. /boot/loader.conf and acpi_hp_load="YES", perhaps also acpi_wmi(4), acpi_video(4), acpi_dock(4) ...

I think you have to edit rc.conf and wpa_supplicant.conf. There are examples in the Handbook, section 31.3 wireless networking.

Juha
 
Last edited by a moderator:

shirian

New Member

Thanks: 1
Messages: 1

#28
I also had an issue with a HP 8440p. Would just reboot after the first ticker (the one just before it says BTX loader). I did what chiqui also did, which is set the mode from being AHCI to IDE. Just thought I'd share it here.
 
Top