Solved How to install i3?

Minbari

Well-Known Member

Thanks: 117
Messages: 250

#2
Code:
pkg install i3 i3status i3lock dmenu
or from ports
Code:
 cd /usr/ports/x11-wm/i3/
make install clean

cd /usr/ports/x11/i3status/
make install clean

cd /usr/ports/x11/i3lock/
make install clean


cd /usr/ports/x11/dmenu/
make install clean
 
OP
OP
A

Alex Mondale

New Member


Messages: 6

#3
T
Code:
pkg install i3 i3status i3lock dmenu
or from ports
Code:
 cd /usr/ports/x11-wm/i3/
make install clean

cd /usr/ports/x11/i3status/
make install clean

cd /usr/ports/x11/i3lock/
make install clean


cd /usr/ports/x11/dmenu/
make install clean
I have followed your steps and installed it. Now what should I do to run it?
 

Minbari

Well-Known Member

Thanks: 117
Messages: 250

#4
Copy xinitrc in your user folder (eg.: cp /usr/local/etc/X11/xinit/xinitrc ~/.xinitrc) then at the final of that file add: exec i3.
 
OP
OP
A

Alex Mondale

New Member


Messages: 6

#7
Yes, you need them for keyboard and mouse under Xorg.
I did this
Code:
#pkg install xorg
#pkg install i3 i3status i3lock dmenu
#echo "dbus_enable=\"YES\"" >> /etc/rc.conf
#echo "hald_enable=\"YES\"" >> /etc/rc.conf
%echo "exec /usr/local/bin/i3" > ~/.xinitrc
#shutdown -r now
%startx
and got the messeges to choose i3 config and $mod key but after entering that all I see is a blank screen with a mouse pointer, and $mod+enter also does not work.
 

Minbari

Well-Known Member

Thanks: 117
Messages: 250

#8
I think that it is important to start by saying very clearly that i3 is not intended for beginning, inexperienced, average, or even 'normal' Unix-like users. Yes, that means exactly what it says -- the vast majority of Unix-like users are not going to find i3 useful, or even very interesting.


I did this
Code:
#pkg install xorg
#pkg install i3 i3status i3lock dmenu
#echo "dbus_enable=\"YES\"" >> /etc/rc.conf
#echo "hald_enable=\"YES\"" >> /etc/rc.conf
%echo "exec /usr/local/bin/i3" > ~/.xinitrc
#shutdown -r now
%startx
and got the messeges to choose i3 config and $mod key but after entering that all I see is a blank screen with a mouse pointer, and $mod+enter also does not work.
That's a standard i3 config, from this point on you need to configure i3 as you desire, what terminal to use, which keys, etc. The documentation on how to customize i3 is here or you could use a config from someone else:http://dotshare.it/category/wms/i3/
 
OP
OP
A

Alex Mondale

New Member


Messages: 6

#9
I think that it is important to start by saying very clearly that i3 is not intended for beginning, inexperienced, average, or even 'normal' Unix-like users. Yes, that means exactly what it says -- the vast majority of Unix-like users are not going to find i3 useful, or even very interesting.



That's a standard i3 config, from this point on you need to configure i3 as you desire, what terminal to use, which keys, etc. The documentation on how to customize i3 is here or you could use a config from someone else:http://dotshare.it/category/wms/i3/
But I thought $mod+enter would bring up the terminal, even with the standard config.
Anyway I am going with XFCE. That will be best for me. Thanks for your advice and help. :)
 

scottro

Daemon

Thanks: 422
Messages: 1,242

#10
I haven't looked at i3 for awhile, but it may be that its default terminal is one that you don't have installed. For example, I _think_ that dwm's default configuration now looks for the st terminal instead of xterm, but the package and/or port don't install st by default.

There are various i3 tutorials around, the ArchLinux wiki has one. https://wiki.archlinux.org/index.php/i3 if you decide to play with it again.
 

Minbari

Well-Known Member

Thanks: 117
Messages: 250

#11
But I thought $mod+enter would bring up the terminal, even with the standard config.
Anyway I am going with XFCE. That will be best for me. Thanks for your advice and help. :)
FreeBSD is a barebone install which need user intervention. To use $Mod+Enter you need to copy the standard config of i3 to your user folder (eg: cp /usr/local/etc/i3/config ~.config/i3). In some GNU/Linux distribution that config file is added in the .config/i3 folder by the package manager but that's not the case with FreeBSD.
 

Trihexagonal

Daemon

Thanks: 526
Messages: 1,038

#12
Unless there is some reason you haven't specified that you have your heart set on using x11-wm/i3, why not give x11-wm/fluxbox a try?

It's easy to configure, there are several nice styles to choose from (I can provide you with a few) and I've never had the trouble setting it up you seem to be having with x11-wm/i3.

Add the terminal you want to use to your ~.xinitrc file with fluxbox exec as the last entry and add your programs to the x11-wm/fluxbox menu in your usr directory.

It's all I've used for years and wouldn't change for anything.
 
OP
OP
A

Alex Mondale

New Member


Messages: 6

#13
FreeBSD is a barebone install which need user intervention. To use $Mod+Enter you need to copy the standard config of i3 to your user folder (eg: cp /usr/local/etc/i3/config ~.config/i3). In some GNU/Linux distribution that config file is added in the .config/i3 folder by the package manager but that's not the case with FreeBSD.
 

Attachments

ANOKNUSA

Aspiring Daemon

Thanks: 371
Messages: 675

#14
Yes, you need [HAL and DBus] for keyboard and mouse under Xorg.
This hasn't been true in years.

But I thought $mod+enter would bring up the terminal, even with the standard config.
It will, provided you have one of the terminals listed in i3-sensible-terminal(1) installed. Really, installing and using i3 in FreeBSD is the same as installing it anywhere else; the only thing that's different is the package manager you use.
 

tobik@

Daemon
Developer

Thanks: 1,346
Messages: 1,909

#15
FreeBSD is a barebone install which need user intervention. To use $Mod+Enter you need to copy the standard config of i3 to your user folder (eg: cp /usr/local/etc/i3/config ~.config/i3). In some GNU/Linux distribution that config file is added in the .config/i3 folder by the package manager but that's not the case with FreeBSD.
This is a long standing bug of i3 on FreeBSD and not some kind of weird philosophical decision to differentiate it from Linux. On FreeBSD i3's initial config wizard generates an incomplete config file and as a result some key definitions are missing from it. See PR 208069 and https://github.com/i3/i3/issues/2141. Copying the config from /usr/local/etc/i3/config is a usable workaround if you remove the last line from it that starts the wizard afterwards. :)
 

chrbr

Aspiring Daemon

Thanks: 231
Messages: 640

#16
The patches in PR 208069 have matched to the previous version of x11-wm/i3. I have not tried them with the newest release. I have tried to bring the patches upstream but it was not successful because of at least two reasons.
  1. I have been sure that the Web interface of github is good enough to provide all functions. This does not seem to be so, especially not for a github newcomer as myself.
  2. The i3 development branches are taken from next and not from master which is recommended by github. Due to that master has lagged heavily and I did not manage to rebase and merge the things. This was my fault. I have been told that others noticed thas been unhappy about the activities because of the trouble. Therefore I have stopped that.
But the i3 people have been very friendly all the time and have tried to help me as much as possible to get the merge done. I think my repository has been a mess from the beginning which was not the fault of the i3 team. The patches are very small, therefore I encourage everybody with some git knowledge to bring them upstream.
 

Minbari

Well-Known Member

Thanks: 117
Messages: 250

#17
To be frankly I never use the default config of i3, I have my own config which I share on multiple OS's. The only thing I do at that config is to edit the restart/shutdown procedure so it fit the needs of that system.
 

Jerome___

New Member


Messages: 3

#18
Ok, someone on IRC freebsd channel see that in ~/.config/i3/config file, bincode function word is wrong, it has to be "bindsym", for all the bind keys. No more bindcode.
(Yes, the config file is inside ~/.config/i3/config and not .config/i3 as Minbari said, defiitly)
 
Last edited:
Top