How to get PPPoE on FreeBSD 8.0 to run on startup?

dude

New Member


Messages: 3

Hello,

I have FreeBSD 8.0-STABLE installed but I can't seem to get my PPPoE connection to execute automatically on startup. I read the PPP/PPPoE instructions from the Freebsd handbook. (http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/pppoe.html) and added the configuration lines to the /etc/rc.conf.

When I run the following command manually at startup # /etc/rc.d/ppp start a connection is made and works perfectlly. I'm also running ipfw firewall and named for NAT on the machine. Though, the problem still exists if using ppp's internal NAT instead.

Also, I noticed by reading the script /etc/rc.d/ppp file that in order to work the configuration in the /etc/rc.conf file should be ppp_{PROFILE_NAME}_mode instead of ppp_mode as indicated in the handbook. This is why my configuration below looks the way it does.

Here is my current configuration:
$ uname -a
Code:
FreeBSD www 8.0-STABLE FreeBSD 8.0-STABLE #3: Wed Feb 24 01:01:51 EST 2010     root@www:/usr/obj/usr/src/sys/SERVER  amd64
# cat /etc/rc.conf
Code:
hostname="www"
ifconfig_em0="inet 192.168.2.99  netmask 255.255.255.0"
ifconfig_re0=up
ifconfig_tun0=
keymap="us.iso"

# setup firewall first
firewall_enable="YES"   # enable FreeBSD firewall
firewall_script="/etc/ipfw.rules"
firewall_logging="YES"  # enable firewall logging
natd_enable="YES"       # enable NAT daemon, external connections appear from 1 interface
natd_interface="tun0"   # external interface
natd_flags="-dynamic -m"
gateway_enable="YES"    # enable routing functionality

# internet connection
ppp_enable="YES"
ppp_mode="ddial"
ppp_profile="teksavvy"
ppp_teksavvy_mode="ddial"
ppp_teksavvy_nat="NO"

# Servers / Daemons
named_enable="YES"      # start dns service
ntpdate_enable="YES"    # enable ntpdate, i.e. set time on startup
ntpdate_hosts="0.pool.ntp.org"
ntpd_enable="YES"       # enable ntpd, daemon to keep time constant
sshd_enable="YES"       # secure shell
samba_enable="YES"      # samba support
nmbd_enable="YES"       # netbios (with samba)

mysql_enable="YES"      # database server
apache22_enable="YES"   # webserver

dbus_enable="YES"       # required for hal, below
hald_enable="YES"       # for getting keyboard/mouse to work on X
# cat /etc/ppp/ppp.conf
Code:
default:
  set log Phase Chat LCP IPCP CCP tun command
  set speed sync
  set mtu 1492
  set mru 1492
  #set ctsrts off

teksavvy:
  set device PPPoE:re0:
  set ifaddr 10.0.0.1/0 10.0.0.2/0 255.255.255.0 0.0.0.0
  set authname  ***[username]***
  set authkey ***[password]***
  set dial
  set login
  add! default HISADDR                  # Add a (sticky) default route
Any help would be appreciated. I looked around the forum but couldn't find any other questions about this same situation.
 
OP
OP
D

dude

New Member


Messages: 3

I should have mentioned that I can't find any references to ppp in the dmesg output.

But to double-check, I ran the command recommend # dmesg -a | grep ppp... and it didn't return anything.
 
OP
OP
D

dude

New Member


Messages: 3

thanks sniper! mpd5 worked once configured and reconnected when the computer was restarted.
 

knarf

Member

Reaction score: 9
Messages: 88

dude said:
Also, I noticed by reading the script /etc/rc.d/ppp file that in order to work the configuration in the /etc/rc.conf file should be ppp_{PROFILE_NAME}_mode instead of ppp_mode as indicated in the handbook. This is why my configuration below looks the way it does.
No, ppp_mode is just the default for all ppp_profiles.

So you can write for example:

Code:
ppp_profile="isp1 isp2 isp3"
ppp_nat="YES"
ppp_isp3_nat="NO" # isp1 and isp2 is still "YES"
The line in your rc.conf saying ifconfig_tun0= is not needed and is _maybe_ the problem, ppp(8) creates tun0. Switch on console.log in /etc/syslog.conf, reboot and check that log file.

But as you gave up and switched to another software we will probably never find out what your problem was. :)
 

SIFE

Well-Known Member

Reaction score: 17
Messages: 472

w Would you pls please post your mpd.conf configuration, Mr dude.
 
Top