How to burn jpg's to cd ??

xman73

New Member


Messages: 12

Like the title says: Trying to burn a directory of jpg's (photos) to cd.

burncd -f /dev/acd0 -s 4 -e data /usr/home/Me/photos fixate didn't work.

I then read that I would need to create a file of type iso.

mkisofs -r -o <path/outputfile.iso> <input directory> definately wrote something on the cd and it would mount. However ls /cdrom indicated no files on the cd, at least no readable ones.

Using Liteon DVD writer - no trouble burning downloaded iso files.

Can't seem to find an answer to this. Any help is appreciated.
 
OP
OP
X

xman73

New Member


Messages: 12

killasmurf,

It's been interesting. First, I hope no one thought I had tried to burn with mkisofs as my post read. I meant that after doing mkisofs, and then burning, the cd could not be read.

I have two computers, each running FreeBSD 7.0, installed from the same cd. One has a newer LiteOn DVD drive and the other has a very old cdrom.

Using your first instructions, I was able to burn something to the cd, but neither machine would read anything from it.

With your second instructions, machine with newer DVD drive, I did mkisofs and burncd. On this machine, I could do ls and see the jpg filenames. I could also view them with gwview; however, 6 jpg's were corrupted, and when moving from pic to pic the machine would sometimes hang.

The cd would not work on the other machine. I could not even see the files; it was like the cd was empty. This is the older cdrom. I'm reminded of an old IBM laptop I had that would decide which cd's to read and which ones not to.

Fwiw - jpg photos - sometimes my camera will not display pics, from the mem card, that have been altered with Gimp. Sometimes pics that are otherwise okay will not print at the pharmacy print kiosk.

Thank you so much for taking time to help.
 

graudeejs

Son of Beastie

Reaction score: 692
Messages: 4,615

how did you mount your cd?
you need to be root if you haven't modified /etc/devfs.conf (as in my howto)

Code:
$ su
$ mount -t cd9660 /dev/acd0 /mnt
or you can use sudo

if you have modified /etc/devfs.conf and you can mount cd as user

Code:
$ mkdir ~/mnt
$ mount -t cd9660 /dev/acd0 ~/mnt
you can check iso file you have created with
(again as root, if you haven't modified system to allow user to do this)

Code:
$ mdconfig -a -u 0 -t vnode -f /path/to/photos.iso
$ mount -t cd9660 /dev/acd0 /mnt
remember that user can only mount CD's if admin allowed it, and user can only mount cd's to directory, he owns and has permissions to read

that's why user can mount cd (if allowed) to /home/username/somedir [let it be /home/usr/mnt for example]

if this doesn't work, let me know.... it should..
btw commands i wrote work fine for me, yesterday i burned few cd's to make sure :)

also if you have more than 1 cdrom/dvdrom in any conbination, then you need specify correct drive to use for burning cd's (but i know, you know that)
 
OP
OP
X

xman73

New Member


Messages: 12

killasmurf,

Turns out there were two problems.

1 - Solved - After replacing the ancient cdrom in computer #2 with a newer dvd drive, it now reads the cd I created with computer #1.

2 - As I said previously, after doing mkisofs and then burncd, as you instructed, I get a cd with all of the jpg's except that six of them are corrupted. It turns out that the corrupted jpg's are those in which I have inserted text with the Gimp and then renamed. I should make it clear that the jpg's in question are okay as they reside in the computer. It is in the iso file created by mkisofs where they become corrupt. Apparently, mkisofs cannot deal with these jpg's either because of the filenames I have given them (yes with .jpg extension) or else because of something Gimp has done to them.

Actually, I use a card reader to transfer pics from camera to computer, no iso files involved, but the reader died and I wanted a hard copy of the pics. I have ordered a new reader and an extra memory card.

Thanks again for your help, especially for your how to.
 

graudeejs

Son of Beastie

Reaction score: 692
Messages: 4,615

1) i can't be sure about your computer knowledge, that's why some of my post maight sound silly.

2) i don not believe mkisofs is responsible for corrupting files... however filenames with non-latin character names may cause problems.

3) Why would mkisofs treat jpegs (even gimp altered ones) as some sort of special files??? It should treat all files as binary files.... it will not read them and search for some stuff... if you can't access these files on cdrom, there is something else we're missing....

can you open those corrupted files on HDD? can you open files on CD and HDD with gimp... and are they bough looking same?

anyway if it's solved, then solved it is. :D
happy new year
 
OP
OP
X

xman73

New Member


Messages: 12

My bad, should have looked closer at the files I had burned. There was a sub directory that contained some jpg's and also a directory gqview had made some time ago. That directory, titled "New Folder," was empty so I deleted it. I then copied the jpg's from the good sub directory to a temporary directory, and deleted that sub surectory and it's files. I was then left with only the jpg's on the main directory, on the hard drive. I did mkisofs and burncd on it and all went well except:

I can now view all jpg's with gqview, and the machine no longer hangs up. But, although they can be viewed, those six jpg's do not produce thumbnails on the gqview screen. Right now gqview is running a slide show off /cdrom, the cd I burned, on the other computer.

It appears that the problem is fully solved. Thanks once more for your help. A happy new year to you too.
 
Top