Help needed for BCM 4311 WiFi card in Dell INSPIRON 6400 Laptop

Vlatiha

New Member

Reaction score: 1
Messages: 9

Hi,

this is my first post here, so don't kill me immediately if my post is against the rules.

I have an older DELL Laptop, an INSPIRON 6400 with a BCM 4311 WiFi card. I installed FreeBSD-13.0 on a blank, new ssd and the kernel identified the driver for the wifi card as a bci driver. With the freebsd handbook it was very easy to bring the laptop online in my wpa-secured home network. But: The connection is not stable. When I download bigger files (> 1 MB) the wifi led goes off and on again and it takes several seconds to continue the download for a few more MBs. So, it works, but with a lot of iterruptions. Next I updated the ports tree and installed the firmware for bwi and bwn. But the result remained the same, no difference.

This is my /boot/loader.conf:
Code:
bwi_v3_ucode_load="YES"
if_bwi_load="YES"
wlan_ccmp_load="YES"
wlan_tkip_load="YES"

My /etc/rc.conf looked like this:
Code:
clear_tmp_enable="YES"
hostname="inspiron"
create_args_wlan0="country DE"
sshd_enable="YES"
ntpd_enable="YES"
dbus_enable="YES"
wlans_bwi0="wlan0"
ifconfig_wlan0="WPA SYNCDHCP"
wpa_supplicant_enable="YES"

The error message appearing on the screen everytime the wlan led goes off is

Code:
bwi0: bwi_intr: intr PHY TX error
bwi0: bwi_restart bwgin, help!
bwi0: firmware rev 0x0127, patch level 0x000e
wpa_supplicant: Failed to add supported operating classes IE
bwi0: need multicast update callback
bwi0: need multicast update callback

So I consulted the driver specifications of bwi and bwn and found out, that allthough the kernel loaded the bwi driver, the bwn driver would be the right one. So I replaced all occurences of bwi in both files by bwn and the firmware file bwi_v3_ucode_load by bwn_v4_lp_ucode_load.

/boot/loader.conf:
Code:
bwi_v4_lp_ucode_load="YES"
if_bwn_load="YES"
wlan_ccmp_load="YES"
wlan_tkip_load="YES"

But now things even got worse: The driver can't find it's firmware files!
Code:
bwn0: ucode fw: ucode5
bwn_v4_ucode5: could not load firmware image, error 2
bwn0: the fw file(bwn_v4_ucode5) not found
bwn0: ucode fw: ucode5
bwn-open_v4_ucode5: could not load firmware image, error 2
bwn0: the fw file(bwn-open_v4_ucode5) not found
.................... giving up

So I have no wifi at all with the bwn driver. But: During the make install of the bwn driver in the ports tree I could see, that these files had been built and hopefully linked inside the driver.

Where's my mistake?

Thanks in advance
Vlatiha
 
OP
Vlatiha

Vlatiha

New Member

Reaction score: 1
Messages: 9

Only the firmware is, not the driver. The driver (bwn(4)) is included with FreeBSD.


Wrong one? Shouldn't this be bwn_v4_ld_ucode_load?
You're right. Typo here in the post as I can't write on the freebsd laptop due to the connection errors.

So, the "make install" in net/bwn-firmware-kmod copied a lot of drivers in /boot/modules and among that bwn_v4_lp_ucode.ko but no ucode5 or something. Where do I get that from?

Thanks
Vlatiha
 
OP
Vlatiha

Vlatiha

New Member

Reaction score: 1
Messages: 9

What does pkg info -l bwn-firmware-kmod output?
Code:
# pkg info -l bwn-firmware-kmod
bwn-firmware-kmod-0.1.2:
             /boot/modules/bwn_v4_lp_ucode.ko
             /boot/modules/bwn_v4_n_ucode.ko
             /boot/modules/bwn_v4_ucode.ko
#
 
Top