HAL - anyone had luck with automount large usb drive 250GB's

gr1ml0ck

Member

Reaction score: 37
Messages: 32

Hi,

was not sure where to post this one... but meh..

I have HAL automounting my cd's, dvd's and mmc's without issue.

What I DO want is be able to mount my large usb drive in the same fashion.

At the moment I am forced to use the command line:

Code:
mount -t msdosfs -o large /dev/da0s1 /media/usbhd
Has anyone had any luck mounting this kind of USB drive using HAL?

Any feedback would be appreciated..... while I keep trawling through man pages, doc's and FAQ's. x(
 

vermaden

Son of Beastie

Reaction score: 1,176
Messages: 2,763

These options seem to be here:
Code:
$ [color="Blue"]gconftool-2 --get /system/storage/default_options/vfat/mount_options[/color]
[shortname=mixed,uid=,utf8,umask=077,exec,flush]
 
OP
OP
gr1ml0ck

gr1ml0ck

Member

Reaction score: 37
Messages: 32

thanks dude..

I'm not sure that it matters that I'm running KDE and not Gnome for the gconf stuff?

Never the less.. I will look into this and check out the gconf man pages.

I will post how I go with it.

:stud
 
OP
OP
gr1ml0ck

gr1ml0ck

Member

Reaction score: 37
Messages: 32

I think your right dude!!

On using your gconf command I'm getting the result:

Code:
No value set for /system/storage/default_options/vfat/mount_options
So I guess that I need a rule set to whack in there somehow. I think you have pointed me in the right direction thanks.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,751
Messages: 30,832

Gconf is only used by Gnome so it doesn't do anything for KDE. I don't have KDE so I cannot check it's equivalent.

If you google for a solution don't google for anything freebsd specific. Most of these problems plague linux users too and the solution is usually the same.
 

papanyanz

New Member


Messages: 19

i don't know but... maybe there is a way to add to /etc/fstab mount point and OPTIONS for drive . check out "%man fstab", but i'm unsure
 

vermaden

Son of Beastie

Reaction score: 1,176
Messages: 2,763

gr1ml0ck said:
What I DO want is be able to mount my large usb drive in the same fashion.

Try creating file /usr/local/etc/hal/fdi/policy/preferences.fdi with this content:
Code:
<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
 
  <device>
    <match key="volume.fstype" string="vfat">
      <match key="volume.size" compare_ge="128000000000">
        <merge key="volume.policy.mount_option.large" type="bool">true</merge>
      </match>
    </match>
  </device>

</deviceinfo>
 
Top