gschema.override not holding

broozar

Member

Reaction score: 13
Messages: 35

Hello everyone,

I have set up a FreeBSD desktop machine and would like to port all the desktop settings to a new machine. Above that, I would like my settings to become the default for every (new) user.

I dumped my settings via:
dconf dump /org/mate/

To make new defaults, you can store those dumps as overrides in the /usr/local/share/glib-2.0/schemas/ folder and then call:
glib-compile-schemas /usr/local/share/glib-2.0/schemas/

Unfortunately, this does not appear to work for me. I get no errors along the way, but the modified theme is simply not applied.

My theme.gschema.override file has sections that look like this:
Code:
[org/mate/panel/objects/clock/prefs]
show-date=false
format='24-hour'
custom-format=''

Thanks for any suggestions.
 

olivierd

Active Member

Reaction score: 80
Messages: 127

Personally I prefer to create "dconf profile".

mkdir -p /usr/local/etc/dconf/profile
mkdir -p /usr/local/etc/dconf/db/mate.d


Copy user file into /usr/local/etc/dconf/profile/ directory. It contains these following lines:

Code:
user-db:user
system-db:mate

Then create keyfile settings (e.g., theme-settings) with your own settings (and copy it into /usr/local/etc/dconf/db/mate.d/ folder:

Code:
[org/mate/panel/objects/clock/prefs]
show-date=false
format='24-hour'
custom-format=''

And finally create the "dconf database": dconf update (of course in root). Before to run this command, you must remove previous database rm -Rf ~/.config/dconf/).
 
OP
B

broozar

Member

Reaction score: 13
Messages: 35

thank you very much, worked on my first try!
It's for a desktop installer script I am working on, will be posting in a few days.
 
Top