Gnome Photos/Documents application and local files

BSDPeta

New Member


Messages: 12

I am not sure I am right with my request here. If not - sorry... :)

I have a problem with using the Gnome Photos and Documents applications. Both applications do not find local files in my user folder. The search via "Activities" works (indexing/searching via Settings > Search is activated).

In both applications there doesn't seem to be a path to a local directory, because if I right-click on "pictures folder" in photos and copy the link, the link is file://(null)

Same with Documents.

Can anybody help me?
 

Sevendogsbsd

Daemon

Reaction score: 603
Messages: 1,055

Sorry you haven't gotten an answer yet - there are more than likely not very many Gnome users on this forum. I can do a little research later and post back if I find something - probably not FreeBSD specific, I don't think anyway.
 
OP
B

BSDPeta

New Member


Messages: 12

I just got to see what the content of the file ~/.config/user-dirs.dirs is and found out that it doesn't exist at all.

Via pkg search xdg I found the package xdg-user-dirs-0.17 and installed xdg-user-dirs-0.17 via pkg install xdg-user-dirs-0.17. After a re-login of my user the ~/.config/user-dirs.dirs was available.

The content of ~/.config/user-dirs.dirs is without having made a change

cat ~/.config/user-dirs.dirs
# This file is written by xdg-user-dirs-update
# If you want to change or add directories, just edit the line you're
# interested in. All local changes will be retained on the next run.
# Format is XDG_xxx_DIR="$HOME/yyy", where yyy is a shell-escaped
# homedir-relative path, or XDG_xxx_DIR="/yyy", where /yyy is an
# absolute path. No other format is supported.
#
XDG_DESKTOP_DIR="$HOME/Schreibtisch"
XDG_DOWNLOAD_DIR="$HOME/Downloads"
XDG_TEMPLATES_DIR="$HOME/Vorlagen"
XDG_PUBLICSHARE_DIR="$HOME/Öffentlich"
XDG_DOCUMENTS_DIR="$HOME/Dokumente"
XDG_MUSIC_DIR="$HOME/Musik"
XDG_PICTURES_DIR="$HOME/Bilder"
XDG_VIDEOS_DIR="$HOME/Videos"


Photo/documents still do not display any files. At least the folders are now recognized and can be searched directly from the application.

The test files I put into the corresponding folders are not exotic formats, but are not recognized.

Hmmm…:what:
 

twllnbrck

Well-Known Member

Reaction score: 202
Messages: 274

Add the line
Code:
xdg-user-dirs-update &
to your ~/.xinitrc and restart your X server.
 
OP
B

BSDPeta

New Member


Messages: 12

Adding
Code:
xdg-user-dirs-update &
to ~/.xinitrc and restart does not fix the problem.:'‑(
 

twllnbrck

Well-Known Member

Reaction score: 202
Messages: 274

Mmh. I don't use gnome on FreeBSD. Anyway, do you start your gnome session, via startx or do you use a DM like x11/gdm? If you use gdm, does ~/.config/autostart directory exist in your users home folder?
 
OP
B

BSDPeta

New Member


Messages: 12

Gnome session is started via GDM. There is no ~/.config/autostart directory in my home folder.
 

twllnbrck

Well-Known Member

Reaction score: 202
Messages: 274

Then create the directory and a desktop entry for xdg-user-dirs
Code:
%    mkdir -p ~/.config/autostart
%    touch ~/.config/autostart/xdg-user-dirs.desktop
and add these lines to ~/.config/autostart/xdg-user-dirs.desktop
Code:
[Desktop Entry]
Type=Application
Name=xdg-user-dirs
Exec=/usr/local/bin/xdg-user-dirs-update
Terminal=false
X-Gnome-Autostart=true
This should hopefully update your user dirs at the start of your next session.
Run xdg-user-dirs-update --force to update them dynamically.
 
OP
B

BSDPeta

New Member


Messages: 12

I created ~/.config/autostart and edited ~/.config/autostart/xdg-user-dirs.desktop as recommended but this also does not fix the problem.

I think the problem seems to be somewhere else. Gnome-document app online help refers to the tracker service but to be honest I don't have any plan what and how to check that...:what:

Maybe I should give a try to a different DE for me as a bloody FreeBSD noob…^^
 

twllnbrck

Well-Known Member

Reaction score: 202
Messages: 274

Ok. But was worth a try.. as far as I know tracker is an indexer for the Gnome search tool. I think Gnome also manages user directories via xdg-user-dirs.
Maybe it is an issue with your localization settings. As I saw above you use german folder names.
Whats the output of locale -a?

Maybe I should give a try to a different DE for me as a bloody FreeBSD noob…^^

May not a bad idea :). The dev teams of Gnome or KDE keep company with Linux and don't care much about *BSD. Personaly I prefer lightweight windowmanagers. Actually Im quite happy with x11-wm/openbox.
 

Sevendogsbsd

Daemon

Reaction score: 603
Messages: 1,055

Gnome has heavy systemd deps as well so not sure what was gutted when ported to FreeBSD. Maybe nothing that's related, just thought I'd mention.

Agree with Lanakus - If you need a DE, check out xfce4 - fairly light and has good functionality. Never used it on FreeBSD though.
 
Top