gnome is starting to SUCK

On my FreeBSD 6.3 install, gnome2-2.20.1 installs and runs fine.

Now the current version 2.24? won't install or at least the metaport won't install it stops in graphics/cario.

The only reason I went to 2.24 because in 2.23 when a user accesses a mounted samba share inside their home directory the crash buddy pops up and says the open folder application has crashed. Does it every single time. The root can mount inside his home dir and it does not crash. Does not crash in kde.

Anyway in /graphics/cairo I'm getting configure: error: mandatory image surface backend feature could not be enabled

Can anybody help with this?
Maybe one of these from /usr/ports/UPDATING

  AFFECTS: users of devel/glib20 and future users of devel/gio-fam-backend

  In order to update to glib 2.16 or higher, you must first update the
  glib20 port on its own or you will get a failure trying to install
  devel/gio-fam-backend saying it cannot find -lgio-2.0. Portmaster users
  can do:

        portmaster glib-2\*

  or, if you're using portupgrade:

        portupgrade glib-2\*


  AFFECTS: users of graphics/cairo, graphics/poppler*, and future users of www/firefox3

  The poppler* ports have been updated to 0.8.3 and the shared libraries
  have changed.  Firefox 3.0 has been added to the tree as www/firefox3.
  These changes require that all dependent ports be updated.  You can do
  this in one of two ways:

        # portmaster pixman\*
        # portmaster \*cairo\*
        # portmaster -r poppler-0.\*


        # pkgdb -Ff
        # portupgrade pixman\* \*cairo\*
        # portupgrade -r poppler-0.\*
Thanks for your reply. In my case, I had an old version of pixman installed. When I got that taken care of, then cairo took off and installed. I installed xorg from the ports off of the cd. Then I noticed that it was still the same gnome that I had problems with mounting samba shares inside a user's home. Well I downloaded the current ports tarball, and deleted the prior ports that were there and untarred. Well, cairo did not like that because of the old pixman. I'm again doing a fresh install. Starting over again. Going to use the ports off of the CD for now. I may post here again just for reference to see if xorg and gnome compile off the CD without any issues.

(I get a little gruff at times with computers. I can't help it as MicroSoft made me neurotic many years ago. I don't boot into Winblows unless I have to; mostly for CAD.)
By the way: If you want to upgrade to the newest version of ports again, it's probably faster to do portsnap fetch extract, and this also sets you up to do further updates with the quicker portsnap fetch update, if you should want that.
I always like to build with the CD ports. Then I keep the distfiles so that I can reinstall someday if I don't have an internet connection. I do the portsnap stuff after I get the basics from the CD ports. Then I keep track of the newer distfiles that are downloaded. I know all I have to is keep the tarball of the new ports, but I am somewhat new; getting braver all of the time.

Would it be crazy to try and download all of the distfiles for a single snap shot of the ports. I wonder how many GBytes that is?
ter2007 said:
I'm again doing a fresh install. Starting over again.

FreeBSD's base system and Ports are fully separated, just remove all ports and you will be just like after clean install, remove them like that: [cmd=]# pkg_delete -f -a; rm -rf /var/db/pkg /usr/local[/cmd]

Now you can start over, update your Port with [cmd=]# portsnap fetch extract[/cmd] and then install anything you need.
You'd probably just of to run [cmd=portmaster]-a[/cmd] or [cmd=portupgrade]-a[/cmd] to get your system into a consistent state. Some people just don't know that they mustn't mix new ports with outdated ones.
SirDice said:
2.24? What am I missing here?

Mentions 2.24 but as far as I can tell it's not in the ports tree yet?
I've tried csupping from a dutch, german and the main cvs servers...
Is it only on the marcuscsv still?
You can check by yourself here
Probably you are using not updated mirrors.
BTW, have you ever heard about portsnap? :)

I've updated on the week-end.
I think that we will have some protests about gdm...
Yes, I've heard of portsnap, I've been using fbsd for about 10 years now, I'm kind of used to cvsup/csup ;)

Found out what the problem is though.. Gnome2-lite was still at 2.22 while gnome2 was at 2.24, this seems to have been corrected in the mean time :e