Other Glusterfs

Hi all!
I have been testing glusterfs on FreeBSD 11.0 for a while and letting my users test it as well.
It all works fine except for one thing.
If I run a program that is placed on the gluster server from my client twice the second instance of program will not start until the firt has finished.
Example: Gluster server is exporting /volume and in volume I have /volume/program
I mount volume on client, on say, /mnt/exp.
I run program /mnt/exp/program &
and a second time /mnt/exp/program
The second instance does not start until the first process has finished.

I have tried the same thing with same client and gluster server on a Cent OS 7 and there the programs execute in parallel.

FreeBSD server again:
I have removed installed glusterfs package and installed version 3.9.0 from ports.
It still have the same behavior.

I made an nfs share on my FreeBSD and tried to run my program twice from the same client and that works fine. Programs execute in parallel.

So there is something happening in glusterfs on FreeBSD.
Can you please help me with this problem.

Many thanks in advance!