Solved GLIBCXX_3.4.11 not found

kAldown

Active Member

Reaction score: 4
Messages: 121

Hello.

I've got a problem with missing GLIBCXX.
Code:
% strings /usr/lib/libstdc++.so.6 | grep GLIBC
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_FORCE_NEW
I have a new GCC.

Code:
% pkg_info -xc gcc49\*
Information for gcc47-4.7.4.20131130:

Comment:
GNU Compiler Collection 4.7

Information for gcc49-4.9.0.20131208:

Comment:
GNU Compiler Collection 4.9
and
Code:
% cat /etc/libmap.conf
# $FreeBSD: release/9.2.0/etc/libmap.conf 254357 2013-08-15 08:12:16Z jlh $
includedir /usr/local/etc/libmap.d
libgcc_s.so.1   gcc49/libgcc_s.so.1
libgomp.so.1    gcc49/libgomp.so.1
libobjc.so.3    gcc49/libobjc.so.2
libssp.so.0     gcc49/libssp.so.0
libstdc++.so.6  gcc49/libstdc++.so.6
What am I doing wrong when trying to run?
Code:
% download/Sublime\ Text\ 2/sublime_text 
download/Sublime Text 2/sublime_text: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by download/Sublime Text 2/sublime_text)
download/Sublime Text 2/sublime_text: /lib/libc.so.6: version `GLIBC_2.11' not found (required by download/Sublime Text 2/sublime_text)
By the way: sudo pkgdb -fu && pkgdb -F has already been done.

Thanks for any help.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,299
Messages: 29,745

What exactly are you trying to run?
 
OP
OP
kAldown

kAldown

Active Member

Reaction score: 4
Messages: 121

What do you mean? There is the last code field - sublime_text.
 
OP
OP
kAldown

kAldown

Active Member

Reaction score: 4
Messages: 121

There is a 32 bit Linux binary. http://www.sublimetext.com/ I didn't ask for what binary capability, be sure. I ask, why, when I have GCC 4.9, and make all updates as the handbook tells me to do, I still have a missed GLIBC?

But thanks.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,299
Messages: 29,745

Linux binaries use Linux libraries. Those are installed in /compat/linux/*. You installed the native FreeBSD libraries.

The emulators/linux_base-f10 only has 3.4.10 so you would need a newer linux_base based on a more recent Fedora Core.

Code:
root@molly:~ # strings /compat/linux/usr/lib/libstdc++.so.6 | grep GLIBCXX
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_3.4.10
GLIBCXX_FORCE_NEW
GLIBCXX_DEBUG_MESSAGE_LENGTH
 
OP
OP
kAldown

kAldown

Active Member

Reaction score: 4
Messages: 121

But I checked libraries from /usr/lib/, not from /compat/linux/, or is that what you are talking about? And I haven't got libstdc++.so.6 in /compat/linux/lib/.
 

kpa

Beastie's Twin

Reaction score: 1,801
Messages: 6,318

You're supposed to place the Linux libraries under the /compat/linux hierarchy because that's where the linux(4) compatibility layer expects them to be. You can't install the Linux libraries in FreeBSD's own /usr/lib or /lib directories because they won't be available for the Linux binaries from there.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,299
Messages: 29,745

kAldown said:
And I haven't libstdc++.so.6 in /compat/linux/lib/
Read the handbook about installing the Linux compatibility layer. You need, at the very least, emulators/linux_base-f10.

And, this seems to trip up most new users, FreeBSD is NOT a Linux. It's an entirely different beast.
 
OP
OP
kAldown

kAldown

Active Member

Reaction score: 4
Messages: 121

Ok.

I searched the Internet for solving my problem, and noticed that John (the developer of sublimetext) doesn't want to port his program on to FreeBSD. And still, one day I got the same issue while trying to install /usr/ports/audio/clementine-player. After updating to GCC 4.9 it finally worked.

P.S. I want to install /usr/ports/audio/clementine-player to reach my iPod touch 1G, which still seems to be useless in plugging, even with libraries that present /usr/ports/audio/gtkpod. Sad story :\ .
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,299
Messages: 29,745

kAldown said:
And still, one day I got the same issue while trying to install /usr/ports/audio/clementine-player. After updating to GCC 4.9 it finally worked.
The audio/clementine-player port should work fine with the default Clang or GCC 4.2 compiler.
 
Top