g_vfs_done() Error GEOM Disk Encryption

I keep getting g_vfs_done() errors when using GEOM disk encryption. I have tried it on big drives and little drives (per some reading that I have done). I have tried different frag sizes etc. I have tried it on a secondary hard drive controller (Promise Ultra 66) and with the on board controller. I am giving up and calling it broke. No errors occur until the drive is getting near full. It complains about offset.

I ran GEOM encryption with FreeBSD on a Samba server a couple of years ago with no problems, but I may not have filled up the hard drives enough. Something is wrong.

Any comments please.
Many Posts on the Internet

Many posts about this on the internet. Not necessarily with gbde encryption. The one common thing is that most of the complaints include rediculous offsets. VERY rediculous.
Ignore It

Yea ignoring it might work because I have yet to discover that it causes any harm, but it puts my machine into a panic. It just sits there and gives that warning over and over. Then I do a shutdown -r now and the machine won't shutdown right away. Gives a message about buffers not clearing or something. Then when it reboots, my disks are not clean (all of them) and I have to do a checkdisk. No real errors ever indicated.

I am using an older machine, but that should not make any difference, and it doesn't because I see people having this problem with newer machines. I am not having this problem on my FreeBSD workstations, but I am not filling up their harddrives and they are not under heavy I/O load.

I don't know. This is a real problem though.
Will this ever get fixed? Seems like there has been problems with it for quite a while. If I were up to me, all development on everything else would stop and concentrate on this until it if explained and fixed. What good is anything if you can't even write to the hard drive?