• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

FreeBSD boot aborts on RPi2

balanga

Daemon

Thanks: 60
Messages: 1,962

#1
After creating a 32GB FreeBSD Micro-SD card from
https://download.freebsd.org/ftp/re....1/FreeBSD-11.1-RELEASE-arm-armv6-RPI2.img.xz

it boots up but a login prompt never appears.

In trying to investigate the cause, I hook a USB/serial connector and start up cu which reveals the following captured using script:-

Code:
Script started on Wed Dec 27 12:22:55 2017
You have mail.^M
root@FreeBSD:~ # cu -l /dev/cuaU0 -s 115200^M^M
Connected^M
^@^@^@^@^@^@^@^@^@^@^@^@^@

U-Boot 2015.04 (Jul 21 2017 - 14:05:38)

DRAM:  944 MiB
WARNING: Caches not enabled
RPI 2 Model B
MMC:   bcm2835_sdhci: 0
reading uboot.env

** Unable to read "uboot.env" from mmc0:1 **
Using default environment

In:    serial
Out:   lcd
Err:   lcd
Net:   Net Initialization Skipped
No ethernet found.
Hit any key to stop autoboot:  2 ^H^H^H 1 ^H^H^H 0
Booting from: mmc 0 ubldr
reading ubldr
287325 bytes read in 217 ms (1.3 MiB/s)
## Starting application at 0x02000098 ...
Consoles: U-Boot console  ^M^M
Compatible U-Boot API signature found @0x3ab4b4c8^M^M
^M^M
FreeBSD/armv6 U-Boot loader, Revision 1.2^M^M
(Fri Jul 21 14:21:18 UTC 2017 root@releng2.nyi.freebsd.org)^M^M
^M^M
DRAM: 944MB^M^M
Number of U-Boot devices: 1^M^M
U-Boot env: loaderdev='mmc 0'^M^M
Found U-Boot device: disk^M^M
  Checking unit=0 slice=<auto> partition=<auto>... good.^M^M
Booting from disk0s2a:^M^M
|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-^H\^H|^H/^H-
^M^M
Hit [Enter] to boot immediately, or any other key for command prompt.^M^M
^MBooting [/boot/kernel/kernel] in 9 seconds... ^MBooting [/boot/kernel/kernel]
Using DTB provided by U-Boot at address 0x100.^M^M
^M|^H/^H-^H\^HKernel entry at 0x2200100...^M^M
Kernel args: (null)^M^M
Copyright (c) 1992-2017 The FreeBSD Project.^M
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994^M
        The Regents of the University of California. All rights reserved.^M
FreeBSD is a registered trademark of The FreeBSD Foundation.^M
FreeBSD 11.1-RELEASE #0 r321309: Fri Jul 21 14:27:25 UTC 2017^M
    root@releng2.nyi.freebsd.org:/usr/obj/arm.armv6/usr/src/sys/RPI2 arm^M
FreeBSD clang version 4.0.0 (tags/RELEASE_400/final 297347) (based on LLVM 4.0.0
VT: init without driver.^M
CPU: ARM Cortex-A7 r0p5 (ECO: 0x00000000)^M
CPU Features: ^M
  Multiprocessing, Thumb2, Security, Virtualization, Generic Timer, VMSAv7,^M
  PXN, LPAE, Coherent Walk^M
Optional instructions: ^M
  SDIV/UDIV, UMULL, SMULL, SIMD(ext)^M
LoUU:2 LoC:3 LoUIS:2 ^M
Cache level 1:^M
 32KB/64B 4-way data cache WB Read-Alloc Write-Alloc^M
 32KB/32B 2-way instruction cache Read-Alloc^M
Cache level 2:^M
 512KB/64B 8-way unified cache WB Read-Alloc Write-Alloc^M
real memory  = 989851648 (943 MB)^M
avail memory = 956784640 (912 MB)^M
FreeBSD/SMP: Multiprocessor System Detected: 4 CPUs^M
random: entropy device external interface^M
kbd0 at kbdmux0^M
ofwbus0: <Open Firmware Device Tree>^M
simplebus0: <Flattened device tree simple bus> mem 0x3f000000-0x3fffffff on ofwb
local_intc0: <BCM2836 Interrupt Controller> mem 0x40000000-0x400000ff on simpleb
intc0: <BCM2835 Interrupt Controller> mem 0xb200-0xb3ff irq 4 on simplebus0^M
generic_timer0: <ARMv7 Generic Timer> irq 0,1,2,3 on ofwbus0^M
Timecounter "ARM MPCore Timecounter" frequency 19200000 Hz quality 1000^M
Event timer "ARM MPCore Eventtimer" frequency 19200000 Hz quality 1000^M
bcmwd0: <BCM2708/2835 Watchdog> mem 0x10001c-0x100027 on simplebus0^M
gpio0: <BCM2708/2835 GPIO controller> mem 0x200000-0x2000af irq 5,6,7,8 on simpl
gpio0: read-only pins: 46,48-53.^M
gpio0: reserved pins: 48-53.^M
gpiobus0: <OFW GPIO bus> on gpio0^M
gpioc0: <GPIO controller> on gpio0^M
iichb0: <BCM2708/2835 BSC controller> mem 0x205000-0x20501f irq 9 on simplebus0
iicbus0: <OFW I2C bus> on iichb0^M
iic0: <I2C generic I/O> on iicbus0^M
iichb1: <BCM2708/2835 BSC controller> mem 0x804000-0x80401f irq 10 on simplebus0
iicbus1: <OFW I2C bus> on iichb1^M
iic1: <I2C generic I/O> on iicbus1^M
spi0: <BCM2708/2835 SPI controller> mem 0x204000-0x20401f irq 11 on simplebus0
spibus0: <OFW SPI bus> on spi0^M
bcm_dma0: <BCM2835 DMA Controller> mem 0x7000-0x7fff,0xe05000-0xe05fff irq 12,13
mbox0: <BCM2835 VideoCore Mailbox> mem 0xb880-0xb8bf irq 25 on simplebus0^M
sdhci_bcm0: <Broadcom 2708 SDHCI controller> mem 0x300000-0x3000ff irq 26 on sim
mmc0: <MMC/SD bus> on sdhci_bcm0^M
uart0: <PrimeCell UART (PL011)> mem 0x201000-0x201fff irq 27 on simplebus0^M
uart0: console (115200,n,8,1)^M
vchiq0: <BCM2835 VCHIQ> mem 0xb800-0xb84f irq 28 on simplebus0^M
vchiq: local ver 8 (min 3), remote ver 8.^M
pcm0: <VCHIQ audio> on vchiq0^M
bcm283x_dwcotg0: <DWC OTG 2.0 integrated USB controller (bcm283x)> mem 0x980000-
usbus0 on bcm283x_dwcotg0^M
cpulist0: <Open Firmware CPU Group> on ofwbus0^M
cpu0: <Open Firmware CPU> on cpulist0^M
bcm2835_cpufreq0: <CPU Frequency Control> on cpu0^M
cpu1: <Open Firmware CPU> on cpulist0^M
cpu2: <Open Firmware CPU> on cpulist0^M
cpu3: <Open Firmware CPU> on cpulist0^M
fb0: <BCM2835 VT framebuffer driver> on ofwbus0^M
fbd0 on fb0^M
VT: initialize with new VT driver "fb".^M
fb0: 656x416(656x416@0,0) 24bpp^M
fb0: fbswap: 1, pitch 1968, base 0x3daac000, screen_size 818688^M
gpioled0: <GPIO LEDs> on ofwbus0^M
cryptosoft0: <software crypto>^M
Timecounters tick every 1.000 msec^M
usbus0: 480Mbps High Speed USB v2.0^M
ugen0.1: <DWCOTG OTG Root HUB> at usbus0^M
uhub0: <DWCOTG OTG Root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus0^M
mmcsd0: 34GB <SDHC  0.0 SN 000003DE MFG 02/2015 by 0 0x0000> at mmc0 41.6MHz/4bi
bcm2835_cpufreq0: ARM 600MHz, Core 250MHz, SDRAM 400MHz, Turbo OFF^M
Release APs^M
Trying to mount root from ufs:/dev/ufs/rootfs [rw]...^M
warning: no time-of-day clock registered, system time will not be set accurately
uhub0: 1 port with 1 removable, self powered^M
Growing root partition to fill device^M
mmcsd0s2 resized^M
ugen0.2: <vendor 0x0424 product 0x9514> at usbus0^M
uhub1 on uhub0^M
uhub1: <vendor 0x0424 product 0x9514, class 9/0, rev 2.00/2.00, addr 2> on usbus
uhub1: MTT enabled^M
mmcsd0s2a resized^M
growfs: requested size 31GB is not larger than the current filesystem size 31GB
/etc/rc: WARNING: hostid: unable to figure out a UUID from DMI data, generating
uhub1: 5 ports with 4 removable, self powered^M
ugen0.3: <vendor 0x0424 product 0xec00> at usbus0^M
smsc0 on uhub1^M
smsc0: <vendor 0x0424 product 0xec00, rev 2.00/2.00, addr 3> on usbus0^M
smsc0: chip 0xec00, rev. 0002^M
miibus0: <MII bus> on smsc0^M
ukphy0: <Generic IEEE 802.3u media interface> PHY 1 on miibus0^M
ukphy0:  none, 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto^M
ue0: <USB Ethernet> on smsc0^M
ue0: Ethernet address: b8:27:eb:2c:a6:39^M
Setting hostuuid: 1ac54306-6e21-11e7-a585-b827eb2ca639.^M
Setting hostid: 0xb01904cb.^M
ugen0.4: <SIGMACHIP USB Keyboard> at usbus0^M
ukbd0 on uhub1^M
ukbd0: <SIGMACHIP USB Keyboard, class 0/0, rev 1.10/1.10, addr 4> on usbus0^M
kbd1 at ukbd0^M
Starting file system checks:^M
Warning! Some of the devices might not be available; retrying^M
Restarting file system checks:^M
Unknown error 3; help!^M
ERROR: ABORTING BOOT (sending SIGTERM to parent)!^M
Jul 21 14:30:12 init: /bin/sh on /etc/rc terminated abnormally, going to single
Enter full pathname of shell or RETURN for /bin/sh: ^M
# gpart  a^H^[[Kshow^M
=>      63  65535937  mmcsd0  MBR  (31G)^M
        63    102375       1  !12  [active]  (50M)^M
    102438  65433562       2  freebsd  (31G)^M

=>       0  65433562  mmcsd0s2  BSD  (31G)^M
         0        90            - free -  (45K)^M
        90  65433472         1  freebsd-ufs  (31G)^M

=>      63  65535937  diskid/DISK-000003DE  MBR  (31G)^M
        63    102375                     1  !12  [active]  (50M)^M
    102438  65433562                     2  freebsd  (31G)^M

=>       0  65433562  diskid/DISK-000003DEs2  BSD  (31G)^M
         0        90                          - free -  (45K)^M
        90  65433472                       1  freebsd-ufs  (31G)^M

# ~^M
[EOT]^M
root@FreeBSD:~ # exit^M^M
exit^M

Script done on Wed Dec 27 12:25:22 2017
Any ideas why I get this?
Code:
Warning! Some of the devices might not be available; retrying^M
Restarting file system checks:^M
Unknown error 3; help!^M
 

grzesyou

New Member

Thanks: 1
Messages: 2

#2
Is your root partition (and EFI partition) clean?
Do you have any fsck related entries in rc.conf?
Are you mount something by /etc/fstab - I had some hangs with late mounts of flash drives on RasbBSD-12.
Try to avoid mount during boot.

Cheers
grzes
 

balanga

Daemon

Thanks: 60
Messages: 1,962

#3
It seems the above error only occurs when I install on a 32GB card... just tried with a 16GB card and it just boots up OK on my first boot.
 

balanga

Daemon

Thanks: 60
Messages: 1,962

#5
I've tried using a 64GB card for both FreeBSD and Raspbian and neither appears to do anything even the LEDs blip for a moment.

Raspbian boots up OK on a 32GB card, but FreeBSD boots but then aborts with the error I posted. I'm using different cards so it may be a problem with the card, but I can't figure what FreeBSD is trying to do when it stops.
 
Top