Freebsd-7.1 X11 - Synaptics amd64 - newbie

armandrix

New Member


Messages: 4

Hi everybody !!

I'm linux user and decide to give a try to Freebsd into my notebook, an aspire-5102wlmi, so I took a 14GB partition and installed it a week ago.

"Uau.. it's fast"

almost every thing just went fine until X-11. (my ati xpress 200m is using radeon driver, by Xorg -configure. soon will try out 3d).

The annoying issue is the touchpad, it's just lazy and sticking, after I follow some directions to configure it out.

I did:

- pkg_add synaptics
- disabled mouse daemon
- loader.conf -> hw.psm.synaptics_support="1"
- rc.conf -> enable_moused="no"
- pkg_add ksynaptics (wich doesn't work w/o shm)

then, the rest of this week i was trying on xorg.conf:

- synaptics corepointer
- no mouse entry
- psm0 port driver
- protocol: psm, auto-dev
- shm: on, off (seems to make no difference)
- many options on/off i.e. tapping, borders, etc

I googled a lot, read the related parts of handbook and edited xorg.conf hundreds of times, based on many directions but always the same.

Some xorg.log:
- fcntl(9, O_async): inapropriate ioctl for device
or pages of:
- synaptics and sync issues

So, my question is: Can anyone tell me where i can find some tutorial for synaptics and amd-64 ??

or post one ???

thanks in advance
 

guro

New Member

Reaction score: 2
Messages: 14

In /boot/loader.conf add these lines:
#Synaptics Touchpad
hw.psm.synaptics_support="1"
debug.psm.loglevel="4"

Here my xorg.conf in case which may play some role:

Code:
Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0
        [B][color="Red"]#InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Synaptics_Touchpad" "CorePointer"[/color][/B]
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "ServerFlags"
        Option          "AllowEmptyInput"
EndSection

Section "Files"
        RgbPath      "/usr/local/share/X11/rgb"
        ModulePath   "/usr/local/lib/xorg/modules"
        FontPath     "/usr/local/lib/X11/fonts/misc/"
        FontPath     "/usr/local/lib/X11/fonts/TTF/"
        FontPath     "/usr/local/lib/X11/fonts/OTF"
        FontPath     "/usr/local/lib/X11/fonts/Type1/"
        FontPath     "/usr/local/lib/X11/fonts/100dpi/"
        FontPath     "/usr/local/lib/X11/fonts/75dpi/"
EndSection

Section "Module"
        Load  "dbe"
        Load  "dri"
        Load  "extmod"
        Load  "glx"
        Load  "record"
        Load  "xtrap"
        Load  "freetype"
        Load  "type1"
        [B][color="Red"]Load  "synaptics"[/color][/B]
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
EndSection

[B][color="Red"]Section "InputDevice"
        Identifier  "Synaptics_Touchpad"        # "Mouse0"
        Driver      "synaptics"                 # "mouse"
        Option      "Protocol" "psm"            # "auto"
        Option      "Device" "/dev/psm0"        # "/dev/sysmouse"
        # Option            "ZAxisMapping" "4 5 6 7"
        Option          "LeftEdge"              "1700"
        Option          "RightEdge"             "5300"
        Option          "TopEdge"               "1700"
        Option          "BottomEdge"            "4200"

        Option          "FingerLow"             "25"
        Option          "FingerHigh"            "30"

        Option          "MaxTapTime"            "180"
        Option          "MaxTapMov"             "220"

        Option          "VertScrollDelta"       "100"
        Option          "HorizScrollDelta"      "100"

        Option          "MinSpeed"              "0.06"
        Option          "MaxSpeed"              "0.06"
        Option          "AccelFactor"           "0.0010"

        Option          "ScrollButtonRepeat"    "100"
        Option          "UpDownScrolling"       "on"
        Option          "UpDownRepeat"          "on"
        Option          "LeftRightScrolling"    "on"
        Option          "LeftRightRepeat"       "on"
EndSection[/color][/B]
....
This is certainly not a tutorial, but i fix the same problem reading (xorg.conf)'s.Maybe helps.
 
OP
OP
A

armandrix

New Member


Messages: 4

Hi! Guru...

Thanks for your answer...

I did.. add this log level change, (where I can read this log??)
and edited the xorg.conf as of yours..

guro said:
<NO edit Button?>

Section "ServerFlags"
Option "AllowEmptyInput"
that's how it ruled:
Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
#InputDevice "Mouse0" "CorePointer"
InputDevice "Synaptics_Touchpad" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "ServerFlags"
Option "AllowEmptyInput"
EndSection

Section "Files"
RgbPath "/usr/local/share/X11/rgb"
ModulePath "/usr/local/lib/xorg/modules"
FontPath "/usr/local/lib/X11/fonts/misc/"
FontPath "/usr/local/lib/X11/fonts/TTF/"
FontPath "/usr/local/lib/X11/fonts/OTF"
FontPath "/usr/local/lib/X11/fonts/Type1/"
FontPath "/usr/local/lib/X11/fonts/100dpi/"
FontPath "/usr/local/lib/X11/fonts/75dpi/"
EndSection

Section "Module"
Load "GLcore"
Load "dbe"
Load "dri"
Load "extmod"
Load "glx"
Load "record"
Load "xtrap"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

#Section "InputDevice"
# Identifier "Mouse0"
# Driver "mouse"
# Option "Protocol" "auto"
# Option "Device" "/dev/sysmouse"
# Option "ZAxisMapping" "4 5 6 7"
#EndSection

Section "InputDevice"
Identifier "Synaptics_Touchpad" # "Mouse0"
Driver "synaptics" # "mouse"
Option "Protocol" "psm" # "auto"
Option "Device" "/dev/psm0" # "/dev/sysmouse"
# Option "ZAxisMapping" "4 5 6 7"
Option "LeftEdge" "1700"
Option "RightEdge" "5300"
Option "TopEdge" "1700"
Option "BottomEdge" "4200"

Option "FingerLow" "25"
Option "FingerHigh" "30"

Option "MaxTapTime" "180"
Option "MaxTapMov" "220"

Option "VertScrollDelta" "100"
Option "HorizScrollDelta" "100"

Option "MinSpeed" "0.06"
Option "MaxSpeed" "0.06"
Option "AccelFactor" "0.0010"

Option "ScrollButtonRepeat" "100"
Option "UpDownScrolling" "on"
Option "UpDownRepeat" "on"
Option "LeftRightScrolling" "on"
Option "LeftRightRepeat" "on"
EndSection

Section "Monitor"
#DisplaySize 330 210 # mm
Identifier "Monitor0"
VendorName "CMO"
ModelName "1526"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "NoAccel" # [<bool>]
#Option "SWcursor" # [<bool>]
#Option "Dac6Bit" # [<bool>]
#Option "Dac8Bit" # [<bool>]
#Option "BusType" # [<str>]
#Option "CPPIOMode" # [<bool>]
#Option "CPusecTimeout" # <i>
#Option "AGPMode" # <i>
#Option "AGPFastWrite" # [<bool>]
#Option "AGPSize" # <i>
#Option "GARTSize" # <i>
#Option "RingSize" # <i>
#Option "BufferSize" # <i>
#Option "EnableDepthMoves" # [<bool>]
#Option "EnablePageFlip" # [<bool>]
#Option "NoBackBuffer" # [<bool>]
#Option "DMAForXv" # [<bool>]
#Option "FBTexPercent" # <i>
#Option "DepthBits" # <i>
#Option "PCIAPERSize" # <i>
#Option "AccelDFS" # [<bool>]
#Option "DDCMode" # [<bool>]
#Option "IgnoreEDID" # [<bool>]
#Option "DisplayPriority" # [<str>]
#Option "PanelSize" # [<str>]
#Option "ForceMinDotClock" # <freq>
#Option "ColorTiling" # [<bool>]
#Option "VideoKey" # <i>
#Option "RageTheatreCrystal" # <i>
#Option "RageTheatreTunerPort" # <i>
#Option "RageTheatreCompositePort" # <i>
#Option "RageTheatreSVideoPort" # <i>
#Option "TunerType" # <i>
#Option "RageTheatreMicrocPath" # <str>
#Option "RageTheatreMicrocType" # <str>
#Option "ScalerWidth" # <i>
#Option "RenderAccel" # [<bool>]
#Option "SubPixelOrder" # [<str>]
#Option "ShowCache" # [<bool>]
#Option "DynamicClocks" # [<bool>]
#Option "VGAAccess" # [<bool>]
#Option "ReverseDDC" # [<bool>]
#Option "LVDSProbePLL" # [<bool>]
#Option "AccelMethod" # <str>
#Option "DRI" # [<bool>]
#Option "ConnectorTable" # <str>
#Option "DefaultConnectorTable" # [<bool>]
#Option "DefaultTMDSPLL" # [<bool>]
#Option "TVDACLoadDetect" # [<bool>]
#Option "ForceTVOut" # [<bool>]
#Option "TVStandard" # <str>
#Option "IgnoreLidStatus" # [<bool>]
#Option "DefaultTVDACAdj" # [<bool>]
#Option "Int10" # [<bool>]
Identifier "Card0"
Driver "radeon"
VendorName "ATI Technologies Inc"
BoardName "RS485 [Radeon Xpress 1100 IGP]"
BusID "PCI:1:5:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
result:

mouse don't move...

what else may I do??? you don't know how hard is to surf this way..

thanks
 
OP
OP
A

armandrix

New Member


Messages: 4

************ uau ++++++++++

yeah! i forgot the "load synaptics", redone and it start to work..

without tapping or scrolling but it's now in use..

thanks...

really couldn't catch the difference but that xorg.conf with that "load" section brought it at servicing way..

that's a lot for me .. tx again
 
OP
OP
A

armandrix

New Member


Messages: 4

ok.. Done!!

Freebsd have many things really different from linux, and I must be aware of all of them..

The case is..

After an complete reboot, synaptics is working perfect with this xorg.conf.


Now, again, thank you
 
Top