FreeBSD 7.1 Installation (/: write failed filesystem is full)

blu3fire

New Member


Messages: 8

Hello everyone!

As a really bored linux user, today I decided to try something different... the FreeBSD. I downloaded and burned 7.1-RELEASE-amd64-bootonly.iso and started installation. When sysinstall should start installing FreeBSD I get "/: write failed filesystem is full" error. Don't know what is going on. I prepared 4,9GB partition. Firstly I let the sysinstall slice partition automatically-error showed. Then I sliced partition manually and... yeah error showed again. I tried installing with ACPI disabled, but installer hangs on.

I'll be very thankgull if anyone could help me.
 
OP
B

blu3fire

New Member


Messages: 8

Thank you for the reply.

I downloaded that version firstly, but when I chose media source for "CD/DVD" the installer said that he can't find any CD/DVD drive. So I begun installing from FTP.
 

vermaden

Son of Beastie

Reaction score: 1,843
Messages: 3,143

So you do not need amd64, strange that it can't find it, what hardware do you have?
 
OP
B

blu3fire

New Member


Messages: 8

I've 64bit Dual Core Intel CPU, 2048GB of ram, P35 motherboard chipset, ati x1950 graphic card.

But Nevermind. Problem is solved. I arranged bigger 9GB partition and successfully I've installed FreebS. This post is written under FreeBSD :)
 

robertclemens

Member

Reaction score: 9
Messages: 39

It's sounding to me like you aren't assigning other partitions for the various userland directories?
/
/usr
/var
/tmp
/home
swap

It's usually a good idea to create seperate partitions for each area so that filling one up doesn't bring the system to a complete standstill (it also provides other functions but I won't get into those).

So if you are only creating / and installing everything there then that is your problem as you did not allot enough space to begin with. I suppose if you are only just testing and have no plans to run it this way then you are probably fine. It just makes for bad practice IMO. I'd recommend always using a decent partition setup for the practice and habit as well as it's many useful functions and safety precautions. No reason not to since you have to allot enough space for all the partitions within a single partition anyway.

Just a suggestion and summation of the problem experienced and how to avoid it along with "best practice" advice.
 

DutchDaemon

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 3,237
Messages: 11,441

Still weird that OP couldn't install in a 4.9 GB slice, partitioned or not.

My entire laptop installation (all sources included, plus ~500 packages) isn't even 4 GB in size.
 

robertclemens

Member

Reaction score: 9
Messages: 39

It's possible he included multiple or all packages by default. Most people wouldn't incur such a large install but it isn't out of the realm of possibility so it's wise to make it inclusive in the problem analysis.
 
OP
B

blu3fire

New Member


Messages: 8

Indeed I installed freebsd first time just for a test. I didn't install all packages but only:base,kernel,doc,x.org+openbox+lxde. The problem was that slice for / automatically created by installer was too small (~320MB)
 

randux

Active Member

Reaction score: 4
Messages: 131

DutchDaemon said:
Still weird that OP couldn't install in a 4.9 GB slice, partitioned or not.

My entire laptop installation (all sources included, plus ~500 packages) isn't even 4 GB in size.

If you select auto partitioning the root is too small. You can easily blow up installing with the default.
 

DutchDaemon

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 3,237
Messages: 11,441

Right. I missed the part about auto-partitioning inside that slice. I thought there was just a / partition (of 4.9 GB).
 

tangram

Aspiring Daemon

Reaction score: 77
Messages: 523

Simply choose the auto defaults and read the Handbook recommendations if you want to create your own partition scheme (do use /, tmp, /var and /usr partitions). Imho the auto defaults provides sane results.

I have a desktop with a / of 496Mb and only 138Mb are used. The contents of / are pretty much stale.
 
Top