Solved FreeBSD 11 install reboots after Boot Loader Menu - Supermicro Xeon motherboard

I have a server that is currently running FreeBSD 10.2. I am trying to do a fresh install of FreeBSD 11.0-RELEASE using a memory stick. The stick boots with no issue until displaying the Boot Loader Menu. If I let it boot to multi user, the server reboots a few seconds later after it displays "Booting" with the blue background and a couple of lines after that. Booting to single user mode is fine.

I am affected by the pmap_activate() bug so per the errata, I typed set vm.pmap.pcid_enabled=0 before boot. It did not correct the issue.

I installed previous releases (9.0 and 10.1) the same way with no problem.
Last edited:
I would check the bios to see if you have a CSM/legacy bios module. If you do enable it. This is for computers with UEFI bios. Basically run in old style bios mode instead of UEFI.
Worth a try. Easy to eliminate as a cause of the trouble.
I could not find a setting to use a legacy bios mode. I tried to download the image again and used another stick with the same results.
I did download the image for 10.3 uefi and I can get to the installation screens with no issue. From what I can see with the 10.3 boot sequence, the 11.0 install reboots just before it would clear the screen and display the startup messages in bright white letters.
Would installing 10.2 then performing an upgrade to 11 be a successful workaround?
I also want to mention that I am using a Supermicro Xeon X9SCL+-F motherboard.
This is probably an EFI issue now that I look at it. I just had a similar problem on a board. Bsdinstaller ran fine, found my disk no problem but on reboot it bombed(GPT). No bootable disk found. It is a bad EFI bios on this board and I can't find a newer bios. Silly as it sounds I used an i386 install and it is working fine. Just for kicks see if an 32 bit installer memstick image boots up. There is no EFI on 32bit. That will narrow down the culprit.

There are also loader tweaks you can use for console video. That is what you need to try for amd64.
The EFI video mode is different than legacy. That is (probably) where your bug is. Maybe try some of the console tweaks:

Does this board use the BMC controller for VGA output?
I also had endless crash/reboot loops upon multiuser boot on an older Xeon platform (Intel S5000PHB) after upgrading from 10.3 to 11.0. AS it turned out the PCIe hotplugging was buggy/not fully supported by the BIOS. Setting hw.pci.enable_pcie_hp=0 in /boot/loader.conf solved the problem.

Also see the last paragraph under 7.1 in the release notes for 11.0:

The Supermicro X9 are a much more recent platform than this S5000 though, and I'm running a X9DRi-LN4F+ in our storage system without any issues; but It might be worth a try...

You might also try to connect to the serial console and redirect its output into a text file. This way I figured out PCIe-hp was the culprint on the Intel machine, as this was the last entry before the machine rebooted. The output on the screen was way too slow (or gone too fast upon crashing) to even get a glimpse of the last few lines...
I tried multiple combinations and the results are inconsistent and different from what I experienced earlier.
I could not get the 11 image to work (it now hangs instead of rebooting). Forcing textmode or disabling PCIe hotplugging did not help.
I tried the 10.3 UEFI again and it had the same issue (I had tried it back in January with success). For this installation, forcing textmode worked but I ended up with an error 19. The 10.3 non-UEFI image still worked with no issue.
Is there a way to force non-UEFI for 11?

I am on BIOS version 1.0b. The latest is 2.2. Supermicro does not publish changelogs and discourages BIOS updates if your system is working fine. I'm reluctant to upgrade and potentially end up with a different issue. What is the BIOS version of your X9DRi-LN4F+?
Couple things I have learned to try. On install escape to #3 for boot loader prompt at startup and I have to add set kern.vty=sc for good video to proceed. Then at post install shell I add to /etc/rc.conf kern.vty=sc so on first boot it works.

I have been fighting an Advantec Pico board with similar UEFI symptoms. I have learned how to install on this platform.
First I must go into the bios and go to boot list. There under setting for hard disk priority it lists my FreeBSD install memstick twice as UEFI USB drive or PMAP USB drive. If I boot up with UEFI preferred it fails like yours, if I pick PMAP USB drive it boots into a different mode for the installer(non-EFI) And works fine. When I get to the disk partitioning scheme it uses MBR instead of GPT. In UEFI mode it only takes GPT and mine won't boot after installer finishes. Fails.
By picking PMAP USB drive at boot the FreeBSD installer has the dark blue curses setup screen versus the light blue screen of the bsdinstaller in EFI mode. This could be my sysconsole setting rather than EFI mode.

Sorry for the rambling but I was glad to see 64bit OS on these boards. I had fallen back to 32 bit install as it has no EFI.

So in summary to force a non-UEFI install you must tell the bios to boot from a legacy USB hard disk(memstick) not UEFI(memstick).
The FreeBSD 11 memstick image can do both modes and uses whatever the bios calls for and does this style install.
  • Thanks
Reactions: fcn
and that did it... I had to change the hard disk boot order and then another menu to force a one time USB boot. I was just about to update my bios. I can now get all the way to the install menu.
To make sure I understand:
An install using the legacy USB hard disk will install FreeBSD to always boot using non-UEFI, correct?
Can I still partition my ssd with GPT? I am using this guide:
Yup it will do GPT with legacy bootloader..

root@MIO5:~ # gpart show
=> 40 46905184 ada0 GPT (22G)
40 1024 1 freebsd-boot (512K)
1064 46137344 2 freebsd-ufs (22G)
46138408 766816 - free - (374M)

This is an mSATA drive in a pico board. Installed FreeBSD11 Release amd64 memstick.
I noticed even with boot order as PMAP first it was going to UEFI mode. I actually have to do boot override and pick -PMAP USB device.
I also had to set kern.vty=sc
  • Thanks
Reactions: fcn