Solved FreeBSD 11.1 - signed size_t?

I recently upgraded to FreeBSD 11.1 from FreeBSD 11.0 and I am encountering an error that states that size_t is signed when trying to compile the Ruby programming language (I have tried versions 2.3.3, 2.3.4, and 2.4.1). I did not encounter this issue when compiling Ruby on FreeBSD 11.0. I am using ruby-build and rbenv (installed using pkg) to manage and install different versions of the Ruby programming language. Has anyone else encountered an error involving a signed size_t (it's not supposed to be signed: on FreeBSD 11.1?

The following is the error log from running the command rbenv install 2.4.1:

Last 10 log lines:
checking for __atomic builtins... yes
checking for __sync builtins... yes
checking for __builtin_unreachable... yes
checking for exported function attribute... __attribute__ ((__visibility__("default")))
checking for function name string predefined identifier... __func__
checking if enum over int is allowed... yes
checking whether sys_nerr is declared... yes
checking whether getenv is declared... yes
checking for size_t... yes
configure: error: size_t is signed
I fixed this issue that by reinstalling all my packages with the command: pkg upgrade -f

After reinstalling my packages, I was able to compile Ruby without any issues.