Solved FreeBSD 11.1-RELEASE login error

  • Thread starter Deleted member 30996
  • Start date

Deleted member 30996

While not officially released, I snapped up the amd64 and i386 versions as soon as I saw them on the server tonight and proceeded to build it from scratch on 2 of my boxen. On both the install process goes fine and I've done this at least 50 times.

However, after rebooting and landing at the terminal neither my user or root account password is recognized on either machine. At first I thought maybe I mistyped it on the dinky keyboard of my X61, even though it went though alright at the install screen, so I rebuilt it. Same problem. I even hooked up my Logitech USB keyboard and got the same error. I used the default US keyboard map like always. Caps Lock is not on.

I used the memstick.img on both versions and three slightly versions of the dd commands to try and troubleshoot:

# dd if=FreeBSD-11.1-RELEASE-amd64-memstick.img of=/dev/da0 bs=1m conv=sync
736+1 records in
737+0 records out
772800512 bytes transferred in 62.804631 secs (12304833 bytes/sec)

# dd if=FreeBSD-11.1-RELEASE-amd64-memstick.img of=/dev/da0 bs=1m
736+1 records in
736+1 records out
772208128 bytes transferred in 63.215834 secs (12215423 bytes/sec)

# dd if=FreeBSD-11.1-RELEASE-amd64-memstick.img of=/dev/da0 bs=512k
736+1 records in
736+1 records out
772208128 bytes transferred in 63.215834 secs (12215423 bytes/sec)

Same problem with each command.

However, when plugging the USB stick into the X61 while it was booted up I got the following error on each stick:

da0: quirks=0x2(NO_6_BYTE)
GEOM: da0: the secondary GPT header is not in the last LBA

Using BSD labels instead of GPT gives the same Login: incorrect error and GPT header error. I burned the amd64-disk1.iso and get the same login error.
The GPT warning is normal. The image is typically smaller than the stick you're writing it to. So the secondary GPT is never at the end of the disk. It's difficult to create an image that exactly fits, some sticks are slightly larger than indicated, others slightly smaller. So the image is created as small as possible so it always fits.
It's my fault for not waiting till it was officially released and take full responsibility. I saw it scheduled for release today and thought I'd get it since it was up.

I've just never had this happen before and didn't know why.
To fix that GPT error drop to the LiveCD mode of the memstick installer and run
gpart recover da0
This will push the secondary GPT to the last sector of the disk.

Edit: You need to first run growfs / to fill the device for the secondary GPT to be in last sector.
Thanks, I do appreciate it, but I think I'll just wait till the official release. I've been using the same 1GB USB sticks that came in a pair to build FreeBSD for ages and never had a problem. The disk1.iso didn't work either so something's not right.

My FreeBSD Gateway still runs and I have a spare FreeBSD 11.0-RELEASE HDD that will slip right into my X61 in less than a minute. My Sony can take a well deserved rest.
The login error disappeared with the official release of FreeBSD 11.1-RELEASE and is no longer an issue. Building ATM.