FreeBSD 10.x USB bootable UEFI not showing proper installation steps

Hello, I'm new here. Thanks to admin for accepted my account.

Well, I just want to ask to you guys for my problem. I'm sorry for my bad english or grammatically wrong of this post, or not properly using Formatting Guidelines.

Here the problem.

My Goal :
I'm trying to use triple boot on my laptop Lenovo G400-5010 with current BIOS version 2.03( latest from Lenovo Official Site obtained information in msinfo32). I've worked for dual boot Windows 8.1 and Kali Linux 2016.1 inside GPT/UEFI, using Grub2 from Kali Linux. Both OS's works well. All installation going through UEFI mode and Secure Boot Disabled. Unused Space are ready for FreeBSD.

I've downloaded FreeBSD-10.1-RELEASE-amd64-uefi-memstick.img and FreeBSD-10.3-RELEASE-amd64-uefi-memstick.img.

I've tried both of file to make USB Bootable by reading Handbook instruction and using Win32DiskImager, also dd in Kali Linux 2016.1. Both of them can boot via UEFI.

But, those after Boot Loader Menu (Figure 2.1) and the process goes through booting the kernel, correct me if i'm wrong, should goes to the Welcome Menu (Figure 2.3). Yes, its shows the blue-background-like. But, it not showing properly.

When the Welcome Menu shows up, its looks like my screen split to two side, upper and bottom. Those screen being split while the kernel is booting. So when the Boot Loader Menu transition to booting the kernel, it shows like this at the bottom screen ( not at the edge ) :
/boot/kernel/kernel/ text=0xfe2da8 data=0x129430+0x207f90 syms=[0x8+0x146f40+0x8+
Start @ 0xffffffff802e25f0 ...
EFI framebuffer information :
addr, size     0xc0000000, 0x2000000
dimensions  640 x 480
stride          640
masks         0x00ff0000, 0x0000ff00, 0x000000ff, 0xff000000

and so the booting kernel process that loads such file ( I have no idea what it calls ), it's stacked at upper of the screen and can't be read. And the Welcome Menu shows at the upper screen. It's not showing at my full screen size. I can't figure where the button to do the installation because it was really unreadable and the code I've said before still at my bottom of the screen.

But, after I switch my BIOS Boot Option to Legacy Support (CSM) and boot up my laptop from USB Media ( not the UEFI ), the screen just works fine. No split screen or unreadable Welcome Menu.

If I remember correctly, I also have tried to install using Legacy Support Mode. I'm using Guided Partition Steps (Figure 2.12) and choose Partition Step (Figure 2.14). The installation finished but after reboot I goes through UEFI Boot Option and choose my Legacy Hard Drive, and it just pass-through to the Grub2. And the Grub2 didn't show any FreeBSD option although I've done update-grub in Kali Linux.
And I also have tried installing using UEFI mode, made Unused Space via GParted in Kali Linux, and following the steps like I've done on CSM ( I've captured the steps ). It's done and gone reboot my laptop and I choose to go UEFI Boot Option because there is no option in Grub2 Menu (IIRC, I have not done update-grub). FreeBSD can boot, but the screen still separate.

I'm sorry if I give you wrong information because I've done various way to install FreeBSD.

So, there is any possibilities to install FreeBSD and the screen works normal?