Solved FreeBSD 10.3 can't update

Hello everyone.
Fresh install FreeBSD 10.3 but I can't update.
In my case freebsd-update fetch install:
Code:
mirrors none found
public key failed
No mirrors remaining, giving up.
 
Nikolis, if you feel like posting the output of these commands, I'd be happy to eyeball everything and try to help.

uname -a
cat /etc/rc.conf
cat /etc/resolv.conf
ifconfig -a
netstat -rn
env | grep -i http_proxy
host www.freebsd.org
telnet www.freebsd.org 80
telnet www.freebsd.org 443

If the last two commands succeed, you should see output as follows (as you know, to enter ^], hold the <Ctrl> key and hit ]).

Code:
% telnet www.freebsd.org 80
Trying 8.8.178.110...
Connected to wfe0.ysv.freebsd.org.
Escape character is '^]'.
^]
telnet> q
Connection closed.
Happiness to you, Friend.
 
uname -a
Code:
FreeBSD bsd 10.3-RELEASE FreeBSD 10.3-RELEASE #0 r297264: Fri Mar 25 02:10:02 C 2016 root@eleng1.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC amd64

cat /etc/rc.conf
Code:
hostmane="bsd"
ifconfig_em0="DHCP"
local_unbound_enable="YES"
sshd_enable="YES"
moused_enable="YES"
ntpd_enable="YES"
powerd_enable"YES"
dumpdev="AUTO"
zfs_enable="YES"

cat /etc/resolv.conf
Code:
nameserver 192.168.1.1
nameserver 127.0.0.1
options edns0

Thank you Robroy !
 

Attachments

  • Untitled1.jpg
    Untitled1.jpg
    128.2 KB · Views: 223
  • Untitled2.jpg
    Untitled2.jpg
    61.7 KB · Views: 230
  • Untitled3.jpg
    Untitled3.jpg
    37.4 KB · Views: 216
You're welcome Nikolis; thanks for all the information you've posted.

A couple of ideas come to mind. Once something works, the DHCP client may have to be configured to prevent it from un-fixing things in the future.

  1. Run ping -n 192.168.1.1, and make sure you get responses (I think you will).
  2. Try disabling the unbound local caching resolver:
    • in /etc/rc.conf, comment out the local_unbound_enable="YES" line
    • in /etc/resolv.conf, comment out all lines except nameserver 192.168.1.1
    • reboot your computer--if you'd rather avoid rebooting, run service netif stop; service local_unbound onestop; service netif start
    • try host www.freebsd.org
  3. Try resolving through Google's public DNS:
    • in /etc/resolv.conf, comment out all lines, then add nameserver 8.8.8.8
    • try host www.freebsd.org
 
I had the same issue. I was enabling 'localunbound' during post install, and also not editing the 'resolv.conf'. Causing failure of updates and pkg utility as the only symptom after a new install.

I edited the /etc/resolv.conf .

After clean install unedited:
Code:
# Generated by resolvconf
search localdomain
# nameserver 192.168.###.###

nameserver 127.0.0.1
options edns0

Changed to:
Code:
# Generated by resolvconf
search localdomain
nameserver 192.168.###.###

nameserver 127.0.0.1
options edns0
 
Don't enable local_unbound unless you have a really good reason to do so, including it and offering it as an installation option was one of the ill thought decisions by the FreeBSD release engineering team. It often doesn't work as intended and breaks your system just like you witnessed and the only real use case for it is on a single server (running services that need to do a whole lot of DNS lookups constantly) that is directly connected to the internet without a router/firewall in front of it that would normally run a caching DNS resolver.
 
Back
Top