Solved Firefox package not found

I'm trying to install www/firefox, but the package is not found.

$ sudo pkg install -y firefox
Updating FreeBSD repository catalogue...
FreeBSD repository is up-to-date.
All repositories are up-to-date.
The following 1 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
        firefox: 50.1.0_6,1

Number of packages to be installed: 1

The process will require 126 MiB more space.
44 MiB to be downloaded.
pkg:,1.txz: Not Found

I can install other packages without a problem. I don't have much of anything in my /etc/hosts file.

I'm not sure whether this is relevant, but I had locked firefox to a specific version. I tried unlocking and upgrading and ran into some problems that I don't remember now, so I removed the package.

The other firefox packages (www/firefox-esr, www/firefox-i18n, and www/firefox-esr-i18n) all fail in the same way.

Can others install the firefox package? Anybody know what the issue might be?
That was it, thanks SirDice!

I had already tried pkg update, but I hadn't tried using the -f option. Do you know (or can you guess) why my repository data could have gotten out of date such that -f was necessary?
Not sure how it happens, but I had it a few times too. For some reason it thinks it doesn't need to refresh it and it'll keep the 'old' data.