Firefox 3 and Plugins

ninjaslim

Member


Messages: 51

I was happily using Firefox 3.0.1. Then, I decided to update to 3.0.4, and now Firefox won't detect any of my plugins, which include swfdec, java, and mplayer-plugin. I had this issue with 3.0.2 and 3.0.3, which is why I keep rolling back to 3.0.1 from my Portmaster backups. Versions 3.0.1 and earlier from 3 and 2 branch work as advertised. Anything after that will not detect plugins. Could someone tell me what's going on? I've asked in IRC and searched to no avail. All help is appreciated!
 

aragon

Daemon

Reaction score: 280
Messages: 2,029

I've experienced this as well. Not sure what the deal is, but my solution was to create plugin symlinks to each plugin in /usr/local/lib/firefox3/plugins. It's as if firefox ignores the contents of /usr/local/lib/browser_plugins.

Anyone know why this is happening?
 

manolis@

Member
Developer

Reaction score: 27
Messages: 37

aragon said:
Anyone know why this is happening?
Well, yes the /usr/local/lib/browser_plugins directory is intended for Firefox 2.x plugins. Some of them (still) crash Firefox 3, so it was decided to keep them separate for the moment. You are right, the recommended way is to symlink those you want to the new directory. At the moment with Firefox 3.0.4 I have no problems.
 

VictorVG

New Member

Reaction score: 1
Messages: 1

ninjaslim

Thats remove FireFox??? Just run command (as root:wheel) on Terminal/Konsole:

pkg_deinstall -f <firefox pakege> && cd $home && rm -fR mozilla/<FireFox profile>/* && exit

I don't build FireFox 2/3 for FreeBSD 7.1 - I test this Windows native build - in very bad idea.:) I some hours manually recovery Registry on test system use backup copy, manuals, knowledge and professional recover tools - this build is remove "only" ~ 19000 Registry entry's. I recovery this systems? but my todo for build FireFox for my friends is terminated.:) Just use SeaMonkey 1.1.13 - this suite don't have many errors.:)
 

lizzard

New Member


Messages: 4

Hmmm, my Firefox 3.0.4 crashes with www/flashplugin-mozilla when i trying to play flash rolics.
 

Kitche

Member

Reaction score: 5
Messages: 59

www/flashplugin-mozilla is not meant to work with firefox it's actually shouldn't be used unless you use seamonkey. at least that's what I was told on irc one day.
 
Top