Finished: CALL FOR TESTERS Intel wireless 5100/5300 iwn(4) driver for FreeBSD

thuglife

Active Member

Reaction score: 42
Messages: 160

Code:
Nov  9 20:00:08 optimus dhclient: New Subnet Mask (wlan0): 255.255.255.0
Nov  9 20:00:08 optimus dhclient: New Broadcast Address (wlan0): 192.168.0.255
Nov  9 20:00:08 optimus dhclient: New Routers (wlan0): 192.168.0.1

...

Nov  9 20:25:01 optimus kernel: nfs server megatron:/usr/local/samba/share: not responding
Nov  9 20:25:04 optimus last message repeated 2 times
Nov  9 20:25:30 optimus dhclient[1820]: send_packet: Host is down
Nov  9 20:28:05 optimus dhclient[1820]: send_packet: Host is down
Nov  9 20:28:56 optimus last message repeated 4 times
Nov  9 20:29:49 optimus kernel: drm0: [ITHREAD]
Nov  9 20:30:14 optimus kernel: iwn0: need multicast update callback
Nov  9 20:30:14 optimus kernel: iwn0: need multicast update callback
Nov  9 20:30:34 optimus login: ROOT LOGIN (root) ON ttyv0
Nov  9 20:31:26 optimus kernel: drm0: [ITHREAD]
Nov  9 20:31:46 optimus kernel: wlan0: link state changed to DOWN
Nov  9 20:31:46 optimus dhclient[1786]: connection closed
Nov  9 20:31:46 optimus dhclient[1786]: exiting.
Nov  9 20:31:51 optimus kernel: ifa_add_loopback_route: insertion failed
Nov  9 20:33:49 optimus kernel: ifa_add_loopback_route: insertion failed
Nov  9 20:33:51 optimus kernel: wlan0: link state changed to UP
Nov  9 20:34:40 optimus dhclient[2016]: connection closed
Nov  9 20:34:40 optimus dhclient[2016]: exiting.
Nov  9 20:35:05 optimus shutdown: reboot by root:
Second try.

Code:
1257795184.405635: Initializing interface 'wlan0' conf '/etc/wpa_supplicant.conf' driver 'bsd' ctrl_interface 'N/A' bridge 'N/A'
1257795184.405710: Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
1257795184.405725: Reading configuration file '/etc/wpa_supplicant.conf'
1257795184.405794: Line: 1 - start of a new network block
1257795184.405822: ssid - hexdump_ascii(len=8):
     4c 69 61 73 6b 6f 73 32                           Liaskos2        
1257795184.405842: PSK (ASCII passphrase) - hexdump_ascii(len=8): [REMOVED]
1257795184.456526: PSK (from passphrase) - hexdump(len=32): [REMOVED]
1257795184.456567: Priority group 0
1257795184.456575:    id=0 ssid='Liaskos2'
1257795184.456581: Initializing interface (2) 'wlan0'
1257795184.463033: Own MAC address: 00:21:6a:6e:3d:b6
1257795184.463044: wpa_driver_bsd_set_wpa: enabled=1
1257795184.463050: wpa_driver_bsd_set_wpa_internal: wpa=3 privacy=1
1257795184.463066: wpa_driver_bsd_del_key: keyidx=0
1257795184.463170: wpa_driver_bsd_del_key: keyidx=1
1257795184.463255: wpa_driver_bsd_del_key: keyidx=2
1257795184.463341: wpa_driver_bsd_del_key: keyidx=3
1257795184.463426: wpa_driver_bsd_set_countermeasures: enabled=0
1257795184.463435: wpa_driver_bsd_set_drop_unencrypted: enabled=1
1257795184.463443: RSN: flushing PMKID list in the driver
1257795184.463471: Setting scan request: 0 sec 100000 usec
1257795184.483850: EAPOL: SUPP_PAE entering state DISCONNECTED
1257795184.483859: EAPOL: KEY_RX entering state NO_KEY_RECEIVE
1257795184.483864: EAPOL: SUPP_BE entering state INITIALIZE
1257795184.483871: EAP: EAP entering state DISABLED
1257795184.483882: Added interface wlan0
1257795184.566072: State: DISCONNECTED -> SCANNING
1257795184.566082: Starting AP scan (broadcast SSID)
1257795184.566087: Trying to get current scan results first without requesting a new scan to speed up initial association
1257795184.566172: Received 0 bytes of scan results (0 BSSes)
1257795184.566180: Scan results: 0
1257795184.566202: Cached scan results are empty - not posting
1257795184.566209: Selecting BSS from priority group 0
1257795184.566214: Try to find WPA-enabled AP
1257795184.566219: Try to find non-WPA AP
1257795184.566225: No suitable AP found.
1257795184.566232: Setting scan request: 0 sec 0 usec
1257795184.566255: Starting AP scan (broadcast SSID)
1257795185.488751: EAPOL: disable timer tick
1257795269.118856: CTRL-EVENT-TERMINATING - signal 2 received
1257795269.118872: Removing interface wlan0
1257795269.118878: State: SCANNING -> DISCONNECTED
1257795269.118885: No keys have been configured - skip key clearing
1257795269.118892: EAPOL: External notification - portEnabled=0
1257795269.118901: EAPOL: External notification - portValid=0
1257795269.118907: wpa_driver_bsd_set_wpa: enabled=0
1257795269.118912: wpa_driver_bsd_set_wpa_internal: wpa=0 privacy=0
1257795269.119054: Failed to disable WPA in the driver.
1257795269.119060: wpa_driver_bsd_set_drop_unencrypted: enabled=0
1257795269.119071: wpa_driver_bsd_set_countermeasures: enabled=0
1257795269.119079: No keys have been configured - skip key clearing
1257795269.119568: Cancelling scan request
1257795269.119577: Cancelling authentication timeout
1257795269.133995: wpa_driver_bsd_set_wpa_internal: wpa=0 privacy=0
ELOOP: remaining socket: sock=4 eloop_data=0x800e0b1c0 user_data=0x800e070f0 handler=0x41fb29
Code:
Nov  9 21:34:29 optimus kernel: wlan0: stop running, 1 vaps running
Nov  9 21:34:29 optimus kernel: wlan0: ieee80211_new_state_locked: SCAN -> INIT (nrunning 0 nscanning 0)
Nov  9 21:34:29 optimus kernel: wlan0: down parent iwn0
Nov  9 21:34:29 optimus kernel: wlan0: ieee80211_newstate_cb: SCAN -> INIT arg -1
Nov  9 21:34:29 optimus kernel: wlan0: sta_newstate: SCAN -> INIT (-1)
Nov  9 21:34:29 optimus kernel: wlan0: node_reclaim: remove 0xffffff80006c6000<00:21:6a:6e:3d:b6> from station table, refcnt 1
Nov  9 21:34:29 optimus kernel: wlan0: ieee80211_alloc_node 0xffffff8000854000<00:21:6a:6e:3d:b6> in station table
Nov  9 21:34:29 optimus kernel: wlan0: [00:21:6a:6e:3d:b6] ieee80211_alloc_node: inact_reload 2
Nov  9 21:34:29 optimus kernel: wlan0: ieee80211_scan_flush
Nov  9 21:34:39 optimus kernel: wlan0: _ieee80211_crypto_delkey: NONE keyix 65535 flags 0x3 rsc 0 tsc 0 len 0
Nov  9 21:34:39 optimus last message repeated 3 times
Nov  9 21:34:39 optimus kernel: wlan0: start running, 0 vaps running
Nov  9 21:34:39 optimus kernel: wlan0: ieee80211_start_locked: up parent iwn0
Nov  9 21:34:40 optimus kernel: iwn0: iwn5000_send_calibration: could not send calibration result, error 35
Nov  9 21:34:40 optimus kernel: iwn0: iwn_init_locked: could not initialize hardware, error 35
Nov  9 21:34:41 optimus kernel: wlan0: start running, 1 vaps running
 

bschmidt

Well-Known Member

Reaction score: 39
Messages: 298

Weird.. On first glance I can't say for sure whats going on there. Seems like the re-init issued by net80211 doesn't work correctly. I look into that.
 

dinoex@

Member
Developer

Reaction score: 8
Messages: 21

Levnovo N500 crash when connecting to accespoint.

After it worked on a friends laptop (diffrent hardware)
I build the driver from svn.

Trying on amd64 I get a panic when "Raidio" is on after a few seconds.

Cash does not happen when "Radio" is off.
When "Radio" is off on loading if_iwn the firmware is not loaded.

If the Accesspoint is off, no crash.

crashdump was not written in 7 out of 8 times.
further panics in bufwrite, diffrent errors while writing dump.

$ kldunload if_iwn

Code:
if_delmulti_locked: detaching ifnet instance 0xffffff00024ef800
if_delmulti_locked: detaching ifnet instance 0xffffff00024ef800
if_delmulti_locked: detaching ifnet instance 0xffffff00024ef800
if_delmulti_locked: detaching ifnet instance 0xffffff00024ef800
if_delmulti_locked: detaching ifnet instance 0xffffff00024ef800
if_delmulti_locked: detaching ifnet instance 0xffffff00024ef800
if_delmulti_locked: detaching ifnet instance 0xffffff00024ef800
lock order reversal:
 1st 0xffffff00024efbc8 if_afdata (if_afdata) @ /usr/src/sys/net/if.c:912
 2nd 0xffffffff80e0c120 mld_mtx (mld_mtx) @ /usr/src/sys/netinet6/mld6.c:569
ifaddr cache = 0xffffff00040e2700  is deleted
if_delmulti_ifma: ifnet 0xffffff00040c9000 disappeared
if_delmulti_ifma: ifnet 0xffffff00040c9000 disappeared
if_delmulti_ifma: ifnet 0xffffff00040c9000 disappeared
if_delmulti_ifma: ifnet 0xffffff00040c9000 disappeared
iwn0: detached

ReLoading with "Radio" on is sucessful:

Code:
iwn0: <Intel(R) PRO/Wireless 5100> mem 0xf4700000-0xf4701fff irq 18 at device 0.0 on pci4
pcib3: iwn0 requested memory range 0xf4700000-0xf4701fff: good
iwn0: attempting to allocate 1 MSI vectors (1 supported)
msi: routing MSI IRQ 256 to local APIC 1 vector 52
iwn0: using IRQ 256 for MSI
iwn0: MIMO 1T2R, MoW, address 00:21:6b:a9:e4:22
[MPSAFE]
[ITHREAD]
iwn0: 11a rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
iwn0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
iwn0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
iwn0: 11na MCS: 15Mbps 30Mbps 45Mbps 60Mbps 90Mbps 120Mbps 135Mbps 150Mbps 30Mbps 60Mbps 90Mbps 120Mbps 180Mbps 240Mbps 270Mbps 300
Mbps
iwn0: 11ng MCS: 15Mbps 30Mbps 45Mbps 60Mbps 90Mbps 120Mbps 135Mbps 150Mbps 30Mbps 60Mbps 90Mbps 120Mbps 180Mbps 240Mbps 270Mbps 300
Mbps
pci5: driver added
pci7: driver added
pci8: driver added
wlan0: bpf attached
wlan0: bpf attached
wlan0: Ethernet address: 00:21:6b:a9:e4:22

iwn0: need multicast update callbackif_delmulti_locked: detaching ifnet instance 0xffffff0003edc800

if_delmulti_locked: detaching ifnet instance 0xffffff0003edc800
iwn0: need multicast update callbackif_delmulti_locked: detaching ifnet instance 0xffffff0003edc800

if_delmulti_locked: detaching ifnet instance 0xffffff0003edc800
if_delmulti_locked: detaching ifnet instance 0xffffff0003edc800
if_delmulti_locked: detaching ifnet instance 0xffffff0003edc800
iwn0: need multicast update callbackif_delmulti_locked: detaching ifnet instance 0xffffff0003edc800

if_delmulti_locked: detaching ifnet instance 0xffffff0003edc800
if_delmulti_locked: detaching ifnet instance 0xffffff0003edc800
if_delmulti_locked: detaching ifnet instance 0xffffff0003edc800
if_delmulti_locked: detaching ifnet instance 0xffffff0003edc800
iwn0: need multicast update callbackExpensive timeout(9) function: 0xffffffff8060c4e0(0) 0.016176217 s

firmware: 'iwn5000fw' version 0: 353240 bytes loaded at 0xffffffff812bb0b0
 wpa_supplicant[2005]: CTRL-EVENT-SCAN-RESULTS
 wpa_supplicant[2005]: Trying to associate with 00:23:08:4e:07:08 (SSID='dinoex-hbw2' freq=2472 MHz)

Code:
# kldstat
Id Refs Address            Size     Name
 1   30 0xffffffff80100000 f1e358   kernel
 2    1 0xffffffff8101f000 55f0     acpi_ibm.ko
 4    1 0xffffffff81222000 223e     nullfs.ko
 5    1 0xffffffff81225000 1d1e7    linux.ko
 6    1 0xffffffff81243000 a8ca     fuse.ko
 7    1 0xffffffff8124e000 13846    snd_hda.ko
 8    1 0xffffffff81262000 40204    sound.ko
 9    1 0xffffffff812a3000 3fa7     sdhci.ko
10    1 0xffffffff812a7000 13af7    if_iwn.ko
11    1 0xffffffff812bb000 5658a    iwn5000fw.ko
from pciconv -lv
Code:
iwn0@pci0:4:0:0:        class=0x028000 card=0x12118086 chip=0x42378086 rev=0x00 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Intel (R) WiFi Link 5100 AGN (5100 AGN)'
    class      = network
FreeBSD 8.0-PRERELEASE #1: Sun Nov 15 13:01:02 CET 2009 amd64 GENERIC


Code:
$ tail /boot/loader.conf
if_iwn_load="yes"

$ tail /etc/rc.conf
wlans_iwn0="wlan0"
ifconfig_wlan0="country DE WPA DHCP"
Code:
Fatal trap 12: page fault while in kernel mode
cpuid = 0; apic id = 00
fault virtual address   = 0xffffff8000424000
fault code              = supervisor read data, page not present
instruction pointer     = 0x20:0xffffffff80691921
stack pointer           = 0x28:0xffffff8000037af0
frame pointer           = 0x28:0xffffff8000037ba0
code segment            = base 0x0, limit 0xfffff, type 0x1b
                        = DPL 0, pres 1, long 1, def32 0, gran 1
processor eflags        = interrupt enabled, resume, IOPL = 0
current process         = 12 (swi4: clock)
trap number             = 12
panic: page fault
cpuid = 0
Uptime: 8m56s
Physical memory: 4041 MB
Dumping 1477 MB: 1462 1446 1430 1414 1398 1382 1366

Fatal trap 12: page fault while in kernel mode
cpuid = 1; apic id = 01
fault virtual address   = 0x6de
fault code              = supervisor read instruction, page not present
instruction pointer     = 0x20:0x6de
stack pointer           = 0x28:0xffffff8074898b00
frame pointer           = 0x28:0xffffff8074898b30
code segment            = base 0x0, limit 0xfffff, type 0x1b
                        = DPL 0, pres 1, long 1, def32 0, gran 1
processor eflags        = interrupt enabled, resume, IOPL = 0
current process         = 12 (irq19: uhci4+)
trap number             = 12
Code:
(kgdb) bt
#0  doadump () at pcpu.h:223
#1  0xffffffff805b1ea5 in boot (howto=260) at /usr/src/sys/kern/kern_shutdown.c:416
#2  0xffffffff805b232c in panic (fmt=0xffffffff8095ec54 "%s") at /usr/src/sys/kern/kern_shutdown.c:579
#3  0xffffffff80893378 in trap_fatal (frame=0xffffff00024f1720, eva=Variable "eva" is not available.
) at /usr/src/sys/amd64/amd64/trap.c:857
#4  0xffffffff808936dd in trap_pfault (frame=0xffffff8000037a40, usermode=0) at /usr/src/sys/amd64/amd64/trap.c:773
#5  0xffffffff80894020 in trap (frame=0xffffff8000037a40) at /usr/src/sys/amd64/amd64/trap.c:499
#6  0xffffffff8087a583 in calltrap () at /usr/src/sys/amd64/amd64/exception.S:224
#7  0xffffffff80691921 in ieee80211_tx_mgt_timeout (arg=0xffffff8000424000) at /usr/src/sys/net80211/ieee80211_output.c:2476
#8  0xffffffff805c4748 in softclock (arg=Variable "arg" is not available.
) at /usr/src/sys/kern/kern_timeout.c:411
#9  0xffffffff8058cfa5 in intr_event_execute_handlers (p=Variable "p" is not available.
) at /usr/src/sys/kern/kern_intr.c:1165
#10 0xffffffff8058dbf2 in ithread_loop (arg=0xffffff00024dc6c0) at /usr/src/sys/kern/kern_intr.c:1178
#11 0xffffffff8058b47a in fork_exit (callout=0xffffffff8058db40 <ithread_loop>, arg=0xffffff00024dc6c0, frame=0xffffff8000037c80)
    at /usr/src/sys/kern/kern_fork.c:843
#12 0xffffffff8087aa5e in fork_trampoline () at /usr/src/sys/amd64/amd64/exception.S:561
#13 0x0000000000000000 in ?? ()
#14 0x0000000000000000 in ?? ()
#15 0x0000000000000001 in ?? ()
#16 0x0000000000000000 in ?? ()
#17 0x0000000000000000 in ?? ()
#18 0x0000000000000000 in ?? ()
#19 0x0000000000000000 in ?? ()
#20 0x0000000000000000 in ?? ()
#21 0x0000000000000000 in ?? ()
#22 0x0000000000000000 in ?? ()
#23 0x0000000000000000 in ?? ()
#24 0x0000000000000000 in ?? ()
#25 0x0000000000000000 in ?? ()
#26 0x0000000000000000 in ?? ()
#27 0x0000000000000000 in ?? ()
#28 0x0000000000000000 in ?? ()
#29 0x0000000000000000 in ?? ()
#30 0x0000000000000000 in ?? ()
#31 0x0000000000000000 in ?? ()
#32 0x0000000000000000 in ?? ()
#33 0x0000000000000000 in ?? ()
#34 0x0000000000000000 in ?? ()
#35 0x0000000000000000 in ?? ()
#36 0x0000000000000000 in ?? ()
#37 0x0000000001070000 in ?? ()
#38 0x0000000000000000 in ?? ()
#39 0xffffffff80c4a200 in affinity ()
#40 0xffffffff80c4a200 in affinity ()
#41 0xffffff000270cab0 in ?? ()
#42 0xffffff8000037320 in ?? ()
#43 0xffffff80000372d8 in ?? ()
#44 0xffffff00024f1720 in ?? ()
#45 0xffffffff805d5160 in sched_switch (td=0xffffff00024dc6c0, newtd=0xffffffff8058db40, flags=Variable "flags" is not available.
) at /usr/src/sys/kern/sched_ule.c:1858
Previous frame inner to this frame (corrupt stack?)
 

lubber

New Member


Messages: 13

I've upgrade my laptop to 8.0-RC3, should I apply iwn-20091024.tar.gz first then apply iwn_merge_20081028.diff.bz2, or apply iwn_merge_20081028.diff.bz2 directly? Thanks.
 

bschmidt

Well-Known Member

Reaction score: 39
Messages: 298

lubber said:
I've upgrade my laptop to 8.0-RC3, should I apply iwn-20091024.tar.gz first then apply iwn_merge_20081028.diff.bz2, or apply iwn_merge_20081028.diff.bz2 directly? Thanks.
Use the SVN version if possible.
 

bschmidt

Well-Known Member

Reaction score: 39
Messages: 298

dinoex@ said:
After it worked on a friends laptop (diffrent hardware)
I build the driver from svn.

Trying on amd64 I get a panic when "Raidio" is on after a few seconds.

Cash does not happen when "Radio" is off.
When "Radio" is off on loading if_iwn the firmware is not loaded.
Radio button is something I have to rely on your Input.. I do not have one that is working.

dinoex@ said:
If the Accesspoint is off, no crash.

crashdump was not written in 7 out of 8 times.
further panics in bufwrite, diffrent errors while writing dump.
There is an issue with null data frames leading to memory corruption, actually bus_dmamap*(). I do have a fix for that which I will commit during the next couple of days.

Thanks for testing!
 

lubber

New Member


Messages: 13

Get compile error after checkout code from SVN
Code:
awk -f /usr/src/sys/tools/acpi_quirks2h.awk /usr/src/sys/dev/acpica/acpi_quirks
./aicasm -nostdinc  -I. -I/usr/src/sys -I/usr/src/sys/contrib/altq -I/usr/src/sys/contrib/ipfilter -I/usr/src/sys/contrib/pf -I/usr/src/sys
/dev/ath -I/usr/src/sys/dev/ath/ath_hal -I/usr/src/sys/contrib/ngatm -I/usr/src/sys/dev/twa -I/usr/src/sys/gnu/fs/xfs/FreeBSD -I/usr/src/sys
/gnu/fs/xfs/FreeBSD/support -I/usr/src/sys/gnu/fs/xfs -I/usr/src/sys/contrib/opensolaris/compat -I/usr/src/sys/dev/cxgb -I/usr/src/sys
/cam/scsi -I/usr/src/sys/dev/aic7xxx -o aic7xxx_seq.h -r aic7xxx_reg.h -p aic7xxx_reg_print.c -i /usr/src/sys/dev/aic7xxx/aic7xxx_osm.h 
/usr/src/sys/dev/aic7xxx/aic7xxx.seq
./aicasm: 880 instructions used
./aicasm -nostdinc  -I. -I/usr/src/sys -I/usr/src/sys/contrib/altq -I/usr/src/sys/contrib/ipfilter -I/usr/src/sys/contrib/pf -I/usr/src/sys
/dev/ath -I/usr/src/sys/dev/ath/ath_hal -I/usr/src/sys/contrib/ngatm -I/usr/src/sys/dev/twa -I/usr/src/sys/gnu/fs/xfs/FreeBSD -I/usr/src/sys
/gnu/fs/xfs/FreeBSD/support -I/usr/src/sys/gnu/fs/xfs -I/usr/src/sys/contrib/opensolaris/compat -I/usr/src/sys/dev/cxgb -I/usr/src/sys
/cam/scsi -I/usr/src/sys/dev/aic7xxx -o aic79xx_seq.h -r aic79xx_reg.h -p aic79xx_reg_print.c -i /usr/src/sys/dev/aic7xxx/aic79xx_osm.h 
/usr/src/sys/dev/aic7xxx/aic79xx.seq
./aicasm: 826 instructions used
awk -f /usr/src/sys/tools/miidevs2h.awk /usr/src/sys/dev/mii/miidevs
awk -f /usr/src/sys/tools/pccarddevs2h.awk /usr/src/sys/dev/pccard/pccarddevs
make: don't know how to make /usr/src/sys/teken/gensequences. Stop
*** Error code 2

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.
What should I do now?
 

lubber

New Member


Messages: 13

No. I checked out code and copied to /usr/src/sys, and then build kernel. I'll follow #16 soon.
 

lubber

New Member


Messages: 13

Thank you, ha, the wireless NIC is recognized, but has not result of scan.

1. dmesg | grep iwn0
Code:
iwn0: <Intel(R) PRO/Wireless 5300> mem 0xd8100000-0xd8101fff irq 17 at device 0.0 on pci3
iwn0: MIMO 3T3R, MoW, address 00:21:6a:11:84:7e
iwn0: [ITHREAD]
iwn0: 11a rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
iwn0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
iwn0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
iwn0: 11na MCS: 15Mbps 30Mbps 45Mbps 60Mbps 90Mbps 120Mbps 135Mbps 150Mbps 30Mbps 60Mbps 90Mbps 120Mbps 180Mbps 240Mbps 270Mbps 300Mbps
iwn0: 11ng MCS: 15Mbps 30Mbps 45Mbps 60Mbps 90Mbps 120Mbps 135Mbps 150Mbps 30Mbps 60Mbps 90Mbps 120Mbps 180Mbps 240Mbps 270Mbps 300Mbps
2. ifconfig iwn0 (the mac address is masked)
Code:
iwn0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 2290
	ether xx:xx:xx:xx:xx:xx
	media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
	status: no carrier
3. ifconfig iwn0 scan
Code:
ifconfig: unable to get scan results
4. wpa_supplicant -i iwn0 -c /etc/wpa_supplicant.conf
Code:
ioctl[SIOCG80211, op 98, len 32]: Invalid argument
Failed to initialize driver interface
ELOOP: remaining socket: sock=4 eloop_data=0x28406140 user_data=0x2840d040 handler=0x8069f40
 

bschmidt

Well-Known Member

Reaction score: 39
Messages: 298

There have been some changes in 8.0, you now have to use wlan0 instead of iwn0.
Code:
ifconfig wlan0 create wlandev iwn0
ifconfig wlan0 scan
 

lubber

New Member


Messages: 13

It works perfect if has no security setting or using WPA, connection drops frequently if using WPA2
 

MellowCat

New Member


Messages: 8

How frequently?

I was wondering the same - how can we debug dropped connections?

(Is it just a matter of turning on a sysctl debug switch?)
 

bschmidt

Well-Known Member

Reaction score: 39
Messages: 298

I would start using wpa_supplicant with verbose logging something like # wpa_supplicant -Dbsd -iwlan0 -c/etc/wpa_supplicant.conf -d. If that does not yield any useful information, the next one will be net80211 debuging # wlandebug 0xffffffff.

Do you get any firmware errors? If not, I'm not sure whether debuging messages of iwn do help.

Were your connections idle or active at that point?
 

bschmidt

Well-Known Member

Reaction score: 39
Messages: 298

FYI: I just committed another bunch of changes which should address most of the reported issues (commit log).

Please let me know whether those stuff gets closer to a stable driver. I will spend the next couple of days with stability tests myself.

Thanks.
 

oliverh

Aspiring Daemon

Reaction score: 38
Messages: 557

Rev 7 is rather unstable for me. I'm using FreeBSD 8.0 RC3 AMD64 (Dualcore, 4G of memory) and while using csup a sudden reset took place. I try it again with a freshly compiled stable today.
 

bschmidt

Well-Known Member

Reaction score: 39
Messages: 298

Unstable as in? There has been yet another commit fixing something related to 5GHz channels.
 

jonsen

New Member

Reaction score: 1
Messages: 4

Thank very much! I can use the AGN5100 now.
but have some question:
ONLY: 54M

Code:
iwn0: <Intel(R) PRO/Wireless 5100> mem 0xf2500000-0xf2501fff irq 17 at device 0.0 on pci3
iwn0: MIMO 1T2R, MoW, address 00:22:fa:61:93:8e
iwn0: [ITHREAD]
iwn0: 11a rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
iwn0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
iwn0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
My laptop: Lenovo X200
system:
Code:
% uname -a
FreeBSD x200.isyi.com 8.0-PRERELEASE FreeBSD 8.0-PRERELEASE #12: Thu Nov 12 15:57:34 CST 2009     ymm@x200.isyi.com:/usr/obj/usr/src/sys/MYX200  i386
pciconfig -vl:
Code:
iwn0@pci0:3:0:0:        class=0x028000 card=0x12118086 chip=0x42378086 rev=0x00 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Intel (R) WiFi Link 5100 AGN (5100 AGN)'
    class      = network
 

oliverh

Aspiring Daemon

Reaction score: 38
Messages: 557

bschmidt said:
Unstable as in? There has been yet another commit fixing something related to 5GHz channels.
Mmh I don't know, I'm just using the default configuration. My Fritz Box uses 2.4GHz (802.11b+g ; n is possible but not configured) at the moment. Unstable so far just by fetching the FreeBSD source with csup.
 

oliverh

Aspiring Daemon

Reaction score: 38
Messages: 557

Some data:

pciconf -lv

Code:
iwn0@pci0:5:0:0:      class=0x028000 card=0x13018086 chip=0x42328086 rev=0x00 hdr=0x00
vendor    = 'Intel Corporation'
device    = 'Carte Intel WiFi Link 5100 AGN (Intel WiFi Link 5100)'
class     = network
uname -a

Code:
FreeBSD skarabrae 8.0-PRERELEASE FreeBSD 8.0-PRERELEASE #0: Wed Nov 18 03:40:49 CET 2009     acheron@skarabrae:/usr/obj/usr/src/sys/GENERIC  amd64
I'm using WPA2 for encryption.
 

oliverh

Aspiring Daemon

Reaction score: 38
Messages: 557

So after some testing with rev 8 and FreeBSD 8 stable (prerelease) it didn't change much. Sometimes a sudden reset occurs and it doesn't matter what I do. I

Is WPA2 a possible source for this problem?
 

bschmidt

Well-Known Member

Reaction score: 39
Messages: 298

What does reset mean? Your computer is rebooting? Connection drops? Firmware errors? Look into /var/log/messages for some messages.
 
Top