Filesystem support in FreeBSD

Greets to All,

I'm very glad to find out a FreeBSD-dedicated forum
has been finally unleashed :) I think many people have missed
it till now, having in mind that FreeBSD ain't a piece of cake...

I've been into FreeBSD for a couple of months,
so considering me as a noob won't be far from reality,
so "basic" knowledge will be ok, i think...

I'd like to ask for some support in matters of the damn
ntfs-filesystem, the onliest thing in the time i can't
manage to finish. I'm running a FreeBSD 7.0-RELEASE, with
GENERIC kernel and XFCE/Enlightenment desktop.In the box,
there are 2 Seagate SATA2 drives (500+750 gigs), running
as SATA only (old chipset, 875P + ICH5) and two externals,
a 300 gigs IDE and a 1000 gigs FreeAgent Desk.

I have tried tons of times to get fusefs-ntfs up and running,
though in vain. Mr.Google hasn't helped me too.
I have installed/deinstalled the fusefs-ntfs from ports, packages, found links, etc - nothing works.
Meaning - the required settings are done (loading fuse.ko,
the configs in /etc/rc.conf), but some seconds or a minute
after mounting a ntfs-partition, FreeBSD freezes, panics
and reboots.

Is there any enlightened person, who has managed to workaround
this issue, and might be helpful to the rest of us with
a short tut, how to do that ?

Will be very grateful to any help and thank to all in advance,

Cheers !

FreeBSD is the number 1 OS !
It's not working? I'm not sure if anything's changed, but last time I was using it the program was working fine.

I assume that you're doing something like:
ntfs-3g /dev/da0s1 /mnt

Are you just mounting the filesystems via the external drives, or have you tried an internal/different type of drive? It's hard to say, but sometimes the USB devices can be finnicky as of late. If the drive is getting disconnected for whatever reason that can cause panics.

I did just check and it does seem to be working at least on this system, so I'm guessing that it's not the program itself.
Are you sure that the kernel sources used to build fusefs-kmod are those used to build your GENERIC kernel? If you installed from the CD you should install sources from the CD.
Good morning,guys,

Thank you for your replies and sorry for not being able
to enter in and answer at the right time.
1.Hedwards - yes, i use the usual command "ntfs-3g /dev/ad6s5 /mnt/Downloads".
The panics happened with either internal & external drives, not at disconnecting; mounting the drives with ntfs-3g in many other linux distros and osx86 worked fine, so i assume i have made mistakes at fuse install process ;)

2. Kamikaze - i always use ftp-mode for getting ports and cvsup-ing the sources, so never used the CD-included collections... If i use the ROM-included sources, and build fuse using them, then would that mean - no sources update after that,
cause it would brake fuse again ?

Thank you very much for your help,

Greetings !