Ever had FreeBSD brick a device?

Trihexagonal

Daemon

Reaction score: 852
Messages: 1,465

I've got 2 different off-brand e-cig batteries that I've charged on a few different FreeBSD Thinkpads and my Gateway without any problems. The battery on one was shot and you could only get a couple uses out of a charge so I charged it probably 50 times in short succession before getting another. I never get random reboots on any of my machines and have had 12.0 and 11.2 boxen running constantly the past couple weeks. That USB exploit does worry me though.

I did have a dock brick a Thinkpad T61 when I pulled the USB mouse out of the dock while it was compiling ports from the login terminal. It died right before my eyes and went to laptop heaven. It looked like it had come right out of the box, too.
 

abishai

Aspiring Daemon

Reaction score: 161
Messages: 706

abishai maybe put a bug report to the manufacturer? Also there is a usbdump util (not sure about the name) which might tell you what the device tries to do.
I've got reply that FreeBSD is not supported. =/ This was rather disappointing to hear for a server grade device.
The trick is that device tried to establish normal operation, I even got vendor information and battery status if I was fast enough to read it.

By the way, what exactly do you mean with “without any drivers”?
Well, probably I've misused the word. Certainly. something attaches, probably ehci and hid. But I'm in serious doubt that this is enough reason for device reboot :)
 

Crivens

Moderator
Staff member
Moderator

Reaction score: 863
Messages: 1,820

abishai that is a typical tier1 support "leave us alone" reply. I'd ask them if their device just curling up it's toes ad going for a trip was due to their dev team not knowing what the device does or not knowing what the expected thing was.

That they don't support an OS does not mean they are allowed to give shoddy work for all others. Because that is what they do.
 
OP
OP
AlexanderProphet

AlexanderProphet

Active Member

Reaction score: 33
Messages: 152

Sorry for being kinda unfriendly olli. Just was dreading the inevitable “Why”, lol.
Well the device’s firmware can be upgraded via USB, so it’s not just for charging. What that means for low level OS behaviour I don’t know. The e-cigarette was an Eleaf Lexicon, that’s all I know about it.
Of course I’m sure whoever made the e-cigarette wouldn’t have even dreamed someone would plug it into a FreeBSD machine. And likewise the FreeBSD developers wouldn’t have dreamed... etc. But I would imagine most OSs are written to just do nothing if an unrecognised device is plugged in.
So anyway, it seems that FreeBSD, like Linux, only bricks things occasionally. That is kinda unnerving about the malicious internet-of-things stuff though. Ive heard of this before. I even saw a video on YouTube with Richard Stallman talking about malicious dildos.
 

Phishfry

Son of Beastie

Reaction score: 1,291
Messages: 3,798

I feel like ESD or straight-up uncompliant USB device drawing too much. I messed alot with USB power draws with the Beaglebone.
I have seen devices pulling 700ma., well over 500ma. max USB amperage allowed.

Have you tried looking at the dead laptops HDD system logs with another PC?
Most likely this is an electrical anomaly not software..

We have a large belt sander at work that keeps shocking the crap out of me.
I have never experienced such a high static electricity charge. The arcing gap getting to the switch is worse than touching it.
A couple days later it warmed up and I get no shock. Weird stuff ESD.
I have built lots of computers and never wear any ESD gear. So I really don't understand it at all. Never lost any gear to ESD.
Shoved an ISA card in a live system and saw white smoke. That was my first computer brick.
It was my first real PC and I learned my lesson. That was an expensive mistake.
I still cringe yanking a USB stick out of the computer after writing an image. It just seems dirty to me. The LED is still on too.
Part of my Windows brainwashing I guess.
 

aragats

Daemon

Reaction score: 500
Messages: 1,217

I still cringe yanking a USB stick out of the computer after writing an image. It just seems dirty to me. The LED is still on too.
You already presented a solution in your own thread 2 years ago (-;
A simple (not perfect) script can "automate" ejecting a USB mass storage device (assuming you want to eject the last inserted):
Code:
DEV=`dmesg | sed -n '/ugen/,/umass/ s/\(ugen.*\)/Turning off \1/p' | tail -1 `
`echo $DEV | sed 's/.*ugen\([0-9]\)\.\([0-9]\).*/usbconfig -u \1 -a \2 power_off/'`
dmesg | tail -2
 
Top