1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Error with Intel945GME

Discussion in 'X.Org' started by Ghirai, Nov 1, 2009.

  1. Ghirai

    Ghirai New Member

    Messages:
    57
    Thanks Received:
    2
    After running Xorg -configure, then running Xorg with the resulting configuration file, i get this error:
    "failed to set mtrr: No space left on device"

    Any ideas?

    This is the Xorg.conf.new file:

    Code:
    Section "ServerLayout"
    	Identifier     "X.org Configured"
    	Screen      0  "Screen0" 0 0
    	InputDevice    "Mouse0" "CorePointer"
    	InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "Files"
    	ModulePath   "/usr/local/lib/xorg/modules"
    	FontPath     "/usr/local/lib/X11/fonts/misc/"
    	FontPath     "/usr/local/lib/X11/fonts/TTF/"
    	FontPath     "/usr/local/lib/X11/fonts/OTF"
    	FontPath     "/usr/local/lib/X11/fonts/Type1/"
    	FontPath     "/usr/local/lib/X11/fonts/100dpi/"
    	FontPath     "/usr/local/lib/X11/fonts/75dpi/"
    EndSection
    
    Section "Module"
    	Load  "extmod"
    	Load  "record"
    	Load  "dbe"
    	Load  "glx"
    	Load  "dri"
    	Load  "dri2"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Keyboard0"
    	Driver      "kbd"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Mouse0"
    	Driver      "mouse"
    	Option	    "Protocol" "auto"
    	Option	    "Device" "/dev/sysmouse"
    	Option	    "ZAxisMapping" "4 5 6 7"
    EndSection
    
    Section "Monitor"
    	Identifier   "Monitor0"
    	VendorName   "Monitor Vendor"
    	ModelName    "Monitor Model"
    EndSection
    
    Section "Device"
            ### Available Driver options are:-
            ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
            ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
            ### [arg]: arg optional
            #Option     "NoAccel"            	# [<bool>]
            #Option     "SWcursor"           	# [<bool>]
            #Option     "ColorKey"           	# <i>
            #Option     "CacheLines"         	# <i>
            #Option     "Dac6Bit"            	# [<bool>]
            #Option     "DRI"                	# [<bool>]
            #Option     "NoDDC"              	# [<bool>]
            #Option     "ShowCache"          	# [<bool>]
            #Option     "XvMCSurfaces"       	# <i>
            #Option     "PageFlip"           	# [<bool>]
    	Identifier  "Card0"
    	Driver      "intel"
    	VendorName  "Intel Corporation"
    	BoardName   "Mobile 945GME Express Integrated Graphics Controller"
    	BusID       "PCI:0:2:0"
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Card0"
    	Monitor    "Monitor0"
    	SubSection "Display"
    		Viewport   0 0
    		Depth     1
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     4
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     8
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     15
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     16
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
     
  2. Zare

    Zare Member

    Messages:
    387
    Thanks Received:
    54
    Code:
    sysctl machdep.disable_mtrrs="1"
    
     
  3. Ghirai

    Ghirai New Member

    Messages:
    57
    Thanks Received:
    2
    Ok, i added that to /boot/loader.conf, and now i get a "failed to set mtrr: Operation not supported" message.
     
  4. vermaden

    vermaden Well-Known Member

    Messages:
    2,392
    Thanks Received:
    693
    Show me output of this command: df -h
     
  5. Ghirai

    Ghirai New Member

    Messages:
    57
    Thanks Received:
    2
    There's plenty of disk space on all devices.

    Turns out that since this was a fresh install, i forgot to add the hal and dbus entries to rc.conf. That seems to have fixed things.

    Thanks everyone.