Error while installing Deluge in jail on FreeBSD 11.0


I'm trying to install deluge inside a jail (created using ezjail) on FreeBSD 11.0 - headless. I have added OPTIONS_UNSET=X11 in /etc/make.conf. Also ran installation command with WITHOUT_X11=yes option.

After a lengthy process it failed with below mentioned error, looking forward for your help/step need to be done to get it installed successfully. Also do I need to uncheck any options other than "X11"s (believe this is for desktop env) ?

building 'pygame.scrap' extension
cc -DNDEBUG -O2 -pipe -fstack-protector -fno-strict-aliasing -fPIC -D_REENTRANT -D_THREAD_SAFE -I/usr/X11R6/include -I/usr/local/include/SDL -I/usr/local/include -I/usr/local/include/python2.7 -c src/scrap.c -o build/temp.freebsd-11.0-RELEASE-p1-amd64-2.7/src/scrap.o
src/scrap.c:73:6: error: Unknown window manager for clipboard handling
    #error Unknown window manager for clipboard handling
1 error generated.
error: command 'cc' failed with exit status 1
*** Error code 1

make[2]: stopped in /basejail/usr/ports/devel/py-game
*** Error code 1

make[1]: stopped in /basejail/usr/ports/devel/py-game
*** Error code 1

make: stopped in /basejail/usr/ports/net-p2p/deluge

Thanks SirDice.
Will try your suggestion.

Meanwhile it would be kind if you can explain or reason out what was the error about as I was not able to fix it (like tried to get src/scrap.c) and was not able to.

With help n suggestion from other sites tried the above said install without X support which turn outs not to be.

Also saw a net-p2p/deluge-cli that had been recently updated(as per freshports site description - my understanding) and was thinking of running it headless and accessing thru web ui. Is it possible in this case.

Basically wanted to get an understating of headless installation of any torrent client as I was not able to get help thru internet search (other than man pages) so pls bear with my ques...