Solved Error installing USB wifi driver

pwdr

Member


Messages: 34

I'm trying to install an Edimax EW-7811Un wifi adapter.

I have downloaded the Linux driver from the Edimax website, unzipped it, navigated to the directory holding install.sh, made it executable and run it with sudo. I get the following error:

Code:
Authentication requested [root] for make clean:
su: unknown class: make clean
Authentication requested [root] for make driver:
su: unknown class: make
##################################################
Compile make driver error: 1
Please check error Mesg
##################################################
Any help much appreciated!

Thanks
 
OP
OP
pwdr

pwdr

Member


Messages: 34

I know it's not Linux, but it's not Windows, Mac or RPi either, so as it's been well touted as a good option for FreeBSD I thought it sounded the most likely. Like how I'm using XFCE, even though I'm not running Linux. There might be good reasons that it's a different matter, but it seemed to make sense to me.

Thanks for the heads-up on loader.conf, I've amended but will need to join the wifi network another time.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,298
Messages: 29,745

Both systems are UNIX-like but the kernels are vastly different. It's therefor not possible to install Linux drivers on FreeBSD for the same reason it's not possible to install Windows 95 drivers on Windows 10.
 
OP
OP
pwdr

pwdr

Member


Messages: 34

Your wifi adapter is supported from urtwn driver, see urtwn(4) man page.
Ok, I've amended by /boot/loader.conf to include the following:
Code:
if_urtwn_load="YES"
as suggested in the urtwn(4)

After reboot, ifconfig -a returns:
re0, lo0

No urtwn0 in there. If I try and 'up' it, as suggested in this link I get:
Code:
interface urtwn0 does not exist
Any idea how to load the urtwn0 driver?
 
A

ASX

Guest


add this too, to loader.conf
Code:
legal.realtek.license_ack=1
and add this to /etc/rc.conf:
Code:
wlans_urtwn0="wlan0"
ifconfig_wlan0="WPA DHCP"
next you need to setup your /etc/wpa_supplicant.conf:
Code:
network={
            ssid="YOUR-SSID"
            psk="YOUR-KEY"
}
 
A

ASX

Guest


No urtwn0 in there.
That changed between FreeBSD 10.x and 11.x, in 11.x slave devices aren't shown by default, you should see the "wlan0" device after applying the suggested additions.
 
OP
OP
pwdr

pwdr

Member


Messages: 34

add this too, to loader.conf
Code:
legal.realtek.license_ack=1
and add this to /etc/rc.conf:
Code:
wlans_urtwn0="wlan0"
ifconfig_wlan0="WPA DHCP"
next you need to setup your /etc/wpa_supplicant.conf:
Code:
network={
            ssid="YOUR-SSID"
            psk="YOUR-KEY"
}
This fixed it, thanks!
 

wb7odyfred

New Member

Reaction score: 1
Messages: 3

I'm trying to install an Edimax EW-7811Un wifi adapter.

Any help much appreciated!

Thanks
HowTo setup Wifi Edimax EW-7811Un Nano USB Dongle for GhostBSD 10.3 & 11.0
http://forums.ghostbsd.org/viewtopic.php?f=64&t=526&p=2336#p2336

Note that in FreeBSD 12.0 Current revision 307529, the driver was rewritten where the RTL8192CU USB & RTL8188CE PCI Realtek Wi-Fi Devices
where incorporated into one driver rtwn. For RTL8192CU Load kernel modules: if_rtwn.ko if_rtwn_usb.ko For RTL8188CE Load kernel module: i f_rtwn.ko if_rtwn_pci.ko
# RTL8192CU
Code:
Kldload if_rtwn.ko if_rtwn_usb.ko
# RTL8188CE
Code:
Kldload if_rtwn.ko if_rtwn_pci.ko

Below are settings for FreeBSD 10.3 and 11.0, Read the GhostBSD forum post for FreeBSD 12.0 Current settings.
# 3 Files to add configuration lines into /boot/loader.conf /etc/rc.conf /etc/wpa_supplicant.conf

#/boot/loader.conf
Code:
if_urtwn_load="YES"
legal.realtek.license_ack=1


#/etc/rc.conf add 2 lines for Edimax EW-7811utn
Code:
wlans_urtwn0="wlan0"
ifconfig_wlan0="DHCP"
#/etc/wpa_supplicant.conf for an Open Network connection
Code:
network={
        ssid="innflux"
        key_mgmt=NONE
}
Now open a MATE terminal and login as root. Try the next two lines
#
Code:
su root
password:
#create urtwn0 device
Code:
ifconfig wlan0 create wlandev urtwn0
#create Wi-Fi password and setup for Wi-Fi connections
Code:
wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant.conf
#scan for operating wifi access points
Code:
ifconfig wlan0 up scan
#Use the dhclient to retrieve an IP address and setup the gateway and route
Code:
killall dhclient
dhclient wlan0
# or just restart the network services
Code:
service  netif restart
# Check the network status and socket status
Code:
netstat -4r  or netstat -i or
sockstat -4
#test network connections using the ping command
Ping google.com or Ping Hurricane Electric Network Internet Service Provider
Code:
ping -c 3 8.8.8.8
ping -c 3 he.net
ping -c 3 opendns.com
Here are some websites URL to read up on, to gain knowledge about wireless setup on FreeBSD.
http://www.wonkity.com/~wblock/docs/html/wireless.html This Wireless entry is helpful and even provides a PDF version file to save.
https://www.freebsd.org/doc/handbook/network-wireless.html FreeBSD Handbook
https://vzaigrin.wordpress.com/2016/10/16/running-freebsd-11-on-raspberry-pi/
 
Last edited:

wb7odyfred

New Member

Reaction score: 1
Messages: 3

# or just restart both the network interface and routing services. You should always issue both commands
Code:
service  netif restart
service  routing restart
RealTek RTL8188CE Wi-Fi PCI network hardware setup forum page for GhostBSD 10.3 and 11.0
http://forums.ghostbsd.org/viewtopic.php?f=64&t=570

Does someone know if the rtwn(4) driver has been backported from FreeBSD 12.0 to the upcoming Freebsd 11.1 BETA version?
I know this updated driver rtwn(4) supports the RTL8188CE PCI hardware and is in the FreeBSD 11.0 version.

Read more here about the rtwn driver for 11.0 which is for RTL8188CE PCI chipset.
https://www.freebsd.org/cgi/man.cgi?query=rtwn&sektion=4&manpath=FreeBSD+11.0-RELEASE+and+Ports

And here for 12.0, which supports both USB and PCI RealTek chipsets.
https://www.freebsd.org/cgi/man.cgi?query=rtwn&manpath=FreeBSD+12-current
 
Top