Solved dtrace: failed to establish error handler: "/usr/lib/dtrace/ipfw.d", line 1: syntax error near "in_addr_t"

I was trying to upgrade some ports and I got an error related to dtrace -h.

If I run manually the command in a jail get this:

Code:
jexec php81 dtrace -h
dtrace: failed to establish error handler: "/usr/lib/dtrace/ipfw.d", line 1: syntax error near "in_addr_t"

The same issue happens on all my jails on this server but not on other servers that have the same hardware & exactly the same software setup (I use an image to install FreeBSD).

If I run it in host then it works fine:

Code:
dtrace -h
dtrace: -h requires one or more scripts or enabling options

Any idea what is wrong?
 
I don't use poudriere, but I notice the issue during ports upgrading so I believe it's the same issue.

If you run dtrace -h in "host" and "jail" only jail has the issue, right?

When I had this issue the "host" was running 13.1-RELEASE and the "jail" 13.0-RELEASE-p4.

I also copy the same "jail" from another server that had not this issue to the server that had the issue and I had the same result (so the issue can't be related to the jail itself).

I have no idea what was causing the issue and I just check all my servers and none show it again.
 
Sorry, I didn't see your reply.

Yes, exactly, I experience this issue only in the jail. It does not happen on the host.

The host is currently running 13.1-RELEASE-p1 (TrueNAS), the jail has the same issue with 13.1-RELEASE-p1 and 13.1-RELEASE-p2.
 
I thought it might related to this: PR 232675
Too many types in the CTF (whatever that exactly is).

But why does it only happen in the jail, then? Also, based on the last comment, the fixes for this should be in 13/stable, but maybe my TrueNAS kernel doesn't have them yet.
 
Top