Double Fault. Automatic ReBoot in 15 Seconds - press a Key on the Console to Abort.

Hello, everybody!
I have a very unpleasant behavior on my server: It works fine (from 2 minutes to 2 months) until next manual reboot.
If server does nothing (really nothing), it reboots fine, but with a little load (writing to filesystem), at least "ATop", running as a daemon (atop_enable="YES" in /etc.rc.conf), causes that after manual reboot, server says:
Double Fault.
...Some Registers...
Automatic ReBoot in 15 Seconds - press a Key on the Console to Abort.
and goes into infinite loop of reboots. Power off/on does not interrupt it. The same continues, if I choose "Single Mode" during boot.
Not to mention that /var/log/messages contains nothing about this reboot loop, because filesystem is not mounted in R/W mode yet.
I already tested hardware (RAM, HDD) and detected nothing wrong.
The only way to heal server (as I know by now) is to boot from the installation media (flash drive), than press "S" to go to shell and mount filesystem as this:
# zpool import -o altroot=/mnt -f ZRoot
It mounts all my files in /mnt, so I can view and edit them, but it is not required.
# zpool status
  pool: ZRoot
 state: ONLINE
  scan: scrub repaired 0 in 0h6m with 0 errors on Wed Sep 21 00:48:45 2016

        NAME        STATE     READ WRITE CKSUM
        ZRoot       ONLINE       0     0     0
          gpt/zfs0  ONLINE       0     0     0

errors: No known data errors
It's enough just:
# reboot
After that, server starts and works, until next manual reboot again.
I suspect, that filesystem in unmounted too fast during manual reboot, and HDD does not really write all cached data before hardware reset, but I don't know, what to do in this case.

I tried to increase and in /etc/sysctl.conf, but it did not help, than I tried to insert "sleep 10" into the last section of /etc/rc.shutdown - It did not help too.

Can anyone tell where to dig, because of it seems to me, I do something wrong here... Thanks!

Hardware: Samsung NP‑NC10‑KA04RU
CPU: Intel Atom N270 Diamondville-SC 1.60, Ver. 6.1C.2.
ChipSet: Mobile Intel® Calistoga‑GSE i945GSE.
RAM: 1024 MB, DDR2‑667 (PC2‑5300) 667 MHz (1 × 1024 MB), Samsung M4 70T2864QZ3‑CE6
HDD: 2.5" SATA/150 Samsung HM160HI FirmWare HH100-06 SATA1 UDMA-6 Cache 8192 KB, 5400 RPM
# uname -m -r -s -v FreeBSD 10.1-RELEASE FreeBSD 10.1-RELEASE #0 r274401: Tue Nov 11 22:51:51 UTC 2014 i386