Solved Dolphin alternative?

pestslent1

Member

Reaction score: 2
Messages: 69

I am running 12.0-BETA3 during the upgrade I lost xrdp functionality and handbrake. When I try to install either of them they want to update samba version and remove Dolphin. I like Dolphin, is there a similar alternative or a way to install handbrake and xrdp without Dolphins removal? Is it just a temp issue do to it being a beta version?
Below is an example when I try to install handbrake.


Installed packages to be REMOVED:
dolphin-18.08.2
kio-extras-18.08.2
samba47-4.7.10_1

New packages to be INSTALLED:
samba48: 4.8.5_1
handbrake: 1.1.2
emby-server: 3.5.3.0



Thanks
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,553
Messages: 30,264

Change options in devel/kio-extras to SAMBA=off and build x11-fm/dolphin in the port.
Probably better to set the default Samba version so it doesn't conflict (it's the conflict between Samba 4.7 and 4.8 that causes Dolphin to be removed).
Code:
DEFAULT_VERSIONS+= samba=4.8
The problem is that emby-server has a hard dependency on Samba 4.8 while Dolphin is built with Samba 4.7.
 
OP
OP
pestslent1

pestslent1

Member

Reaction score: 2
Messages: 69

Probably better to set the default Samba version so it doesn't conflict (it's the conflict between Samba 4.7 and 4.8 that causes Dolphin to be removed).
Code:
DEFAULT_VERSIONS+= samba=4.8
The problem is that emby-server has a hard dependency on Samba 4.8 while Dolphin is built with Samba 4.7.
This may be a dumb question, where exactly do I put "DEFAULT_VERSIONS+= samba=4.8"?

I have managed to get everything up and running (dolphin, xrdp and handbrake). when I go to do pkg update then pkg upgrade:


Code:
New packages to be INSTALLED:
        samba47: 4.7.10_1

Installed packages to be UPGRADED:
        xkeyboard-config: 2.24 -> 2.24_1
        perl5: 5.26.2 -> 5.26.2_1
        mpfr: 4.0.1 -> 4.0.1_1
        libgit2: 0.27.5 -> 0.27.7
        libSM: 1.2.2_5,1 -> 1.2.3,1
        harfbuzz-icu: 2.0.2_1 -> 2.1.0_1
        harfbuzz: 2.0.2 -> 2.1.0
        firefox: 63.0_3,1 -> 63.0.1,1
        ffmpeg: 4.0.2_8,1 -> 4.0.2_9,1
        curl: 7.61.1 -> 7.62.0


Installed packages to be REINSTALLED:
        kio-extras-18.08.2 (options changed)



This I believe will put me back to square one.
I am assuming the "DEFAULT_VERSIONS+= samba=4.8" would prevent the samba install (once I know where to put it).
would the:
Installed packages to be REINSTALLED:
kio-extras-18.08.2 (options changed)

Also be a problem? ( I set SAMBA=off in options when I installed it)

Is that correct or am I totally off base ?

Can I block certain pkg from being included in a pkg upgrade, if so how?

Thanks again
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,553
Messages: 30,264

Yes, sorry, wasn't clear about that. I assumed you knew where to put this. But note that this only affects building from ports. That settings does nothing for the prebuilt packages (those dependencies are more or less set in stone).
 
Top