Docker-freebsd won't work

Choffa

New Member


Messages: 3

Hello,

I have been trying to get docker to work on an experimental server with FreeBSD, tried both 10.3 and 11.0-RC3 without any luck.

Following https://wiki.freebsd.org/Docker, iI get the following:
Code:
# docker pull centos
latest: Pulling from centos
3690474eb5b4: Pull complete
c6ba6252263b: Extracting [========>                                          ] 12.26 MB/70.59 MB
d800c914238f: Download complete
9baab0af79c4: Download complete
Pulling repository centos
Repository not found
Then trying to run a Plex container:
Code:
# docker run --net=host -e VERSION=latest linuxserver/plex
Unable to find image 'linuxserver/plex:latest' locally
latest: Pulling from linuxserver/plex
f1b49dd0c243: Pull complete
008ecf8686ec: Pull complete
fd74137ff5ae: Pull complete
35371c8124e2: Pull complete
99dc4d8f603d: Pull complete
f1fb466c672d: Pull complete
c9926c758af0: Pull complete
7105089db990: Pull complete
c26348124461: Pull complete
ed40943ac576: Pull complete
a4deea7dc3b7: Pull complete
b7a70a6c9bea: Pull complete
c17c5f915bdc: Pull complete
c75c8bd04a73: Pull complete
bb38cecd340a: Pull complete
aede71f84a94: Pull complete
6bb979ceef2a: Pull complete
5dad46e3ac09: Pull complete
e86c92bc5d52: Pull complete
3398bd2cdbb0: Pull complete
cae108124d0e: Pull complete
7670d35442b0: Pull complete
ded637292ab8: Pull complete
20bff4d74762: Pull complete
0eb5b58ecc32: Pull complete
9d77f1acf46e: Pull complete
0ed1c02a44f6: Pull complete
3c0ab77763c2: Pull complete
Digest: sha256:8fa98dceea306bdd0798f1d597bd31f82730fe605eff467394be629b905ff331
Status: Downloaded newer image for linuxserver/plex:latest
/bin/importas: 1: /bin/importas: Syntax error: end of file unexpected (expecting ")")
/bin/importas: 1: /bin/importas: Syntax error: end of file unexpected (expecting ")")
/bin/define: 10: /bin/define: Syntax error: ")" unexpected
/etc/s6/init/init-stage1: 17: /etc/s6/init/init-stage1: Syntax error: "}" unexpected (expecting "then")
jail: /init: failed
The only thing I have managed to get going is an ubuntu image:
Code:
# docker run -t -i ubuntu /bin/bash
root@:/#
Have anyone else had this problem? Or know how to solve it?

Thanks!
 
OP
OP
C

Choffa

New Member


Messages: 3

AFAIK Docker doesn't really work on FreeBSD. You should better try Tredly: www.tredly.com or Jetpack: https://github.com/3ofcoins/jetpack
Those seem interesting, but the availability of pre-built containers compared to docker is very slim.

SmartOS supports Docker and you can run FreeBSD in KVM as well as Linux, or run Linux on bare metal in an lx-brand zone.
I really want it to run on my freebsd machine or I will just stick with my current setup. :)

It's in ports, so it really should work.

There's a patch to be merged here you could try: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=211565
Yeah, I thought so too.
I tried the patch with no luck.
 

beatgammit

Member

Reaction score: 13
Messages: 78

I have the same problem when I try to pull the collabora/code repo, which is based on the ubuntu:16:04 image. I'm not sure how to pull only the dependent images

Code:
docker pull ubuntu:16.04
The above works, but seems to pull a different image.

This appears to still be broken and there's a bug open for it: PR 211041.
 
Top