dmesg permission change

bobmc

Member

Reaction score: 15
Messages: 51

I installed 12.2 a few weeks ago and recently installed again from the same USB stick to clean up my noob tinkering. Now dmesg is not permissable from a non-root account. Message "sysctl kern.msgbuf" complains. I find it inconvenient to activate root just to check read-only system messages.

"sysctl -a" reveals a ton of parameters but not kern.msgbuf exactly. Can something be put in the .conf file to make dmesg usable as default like before the new 12.2?
 

_martin

Aspiring Daemon

Reaction score: 227
Messages: 984

Did you try to set security.bsd.unprivileged_read_msgbuf ? First try without setting it, then set it with: sysctl security.bsd.unprivileged_read_msgbuf=1
 
OP
bobmc

bobmc

Member

Reaction score: 15
Messages: 51

Thanks Martin, your idea works but sysctl.conf holds the flag at zero. I will try editing the file and rebooting.
 
Top